T-Mobile carrier update for iPhone 5?

Discussion in 'iPhone' started by jdzialak, Apr 17, 2013.

  1. jdzialak macrumors regular

    Joined:
    Aug 14, 2008
    #1
    I received three 32G 5's from tmo today. I activated mine at work this morning, and my wife's and daughters just now at home. Mine received a carrier update within minutes of activation. The other 2 haven't gotten it yet, and cannot use imessage from the mobile number. There is now way to set the mobile number as your default "send from" that i can see.

    Any ideas?
     
  2. rockitdog Suspended

    Joined:
    Mar 25, 2013
  3. jdzialak thread starter macrumors regular

    Joined:
    Aug 14, 2008
    #3
    Say 4G where? They say enable LTE in cellular settings, and i have seen 4G in the status bar when not E.
     
  4. HiRisk macrumors 6502

    Joined:
    Jan 3, 2013
    #4
    Go to Settings, General, and then About. A menu should pop up giving you the option for the carrier update.
     
  5. rockitdog Suspended

    Joined:
    Mar 25, 2013
    #5
    I wonder of they already have the carrier update.... Mine went from 3G to 4G in my status bar when I ran the update.
     
  6. jdzialak thread starter macrumors regular

    Joined:
    Aug 14, 2008
    #6
    If they have it already, I wonder why they can't iMessage from their phone number, only the email address?

    ----------

    Thats what my unlocked 4S did last week.
    i just can't figure out why the message settings don't have a way to add their phone number.
     
  7. mizzouxc macrumors member

    Joined:
    Apr 12, 2010
    #7
    Go into Settings --> General --> About, then it should show up. In a few seconds, mine showed up.
     
  8. jdzialak thread starter macrumors regular

    Joined:
    Aug 14, 2008
    #8
    I did. Nothing. But... carrier says T-Mobile 14.1, which is what I have. Maybe they are updated already. Just can't figure out the iMessage thing. Must be unrelated.
     
  9. kazakh macrumors member

    Joined:
    Jan 19, 2009
    #9
    when you go to Settings-->Phone-->my number - does it show your number on there? because mine doesnt (and mine is an iphone 4 from att) - even though I did get a Carrier settings update earlier today.
     
  10. jdzialak thread starter macrumors regular

    Joined:
    Aug 14, 2008
    #10

    Yes.
    I'm going to try to restore the phone. It seems like something is corrupt or missing.
     
  11. bozzykid macrumors 68020

    Joined:
    Aug 11, 2009
    #11
    The carrier update has nothing to do with iMessage. iMessage worked fine before T-Mobile made the carrier update available. Did you try disabling iMessage and rebooting the phone. Then enable it again?
     
  12. aziatiklover macrumors 68030

    aziatiklover

    Joined:
    Jul 12, 2011
    Location:
    8.8.8.8 and 8.8.4.4
    #12
    For imessage just turn off then on again it should yrigger the activation again. Make sure you are on wifi it helps.
     
  13. jdzialak thread starter macrumors regular

    Joined:
    Aug 14, 2008
    #13
    Thanks for all of the help. They both work now. One took several reboots and iMessage resets, but all good.
     

Share This Page