T-Mobile WiFi Calling Bug On Automated Systems

bizack

macrumors 6502a
Original poster
Apr 21, 2009
576
334
This may be iOS 8, iPhone 6, T-Mobile, or a combination of all three, but thought I'd crowd source some feedback here.

I've found that if I'm making a call to an automated system, and I'm connected to WiFi (i.e. bad signal, auto switch to WiFi calling), that if I attempt to interact with the automated system, the call drops. An example would be:

Call T-Mobile
Listen to the prompts
Attempt to respond with numeric input or voice input (i.e please enter or say the last four of your SSN)

Call Apple
Listen to the prompts
Attempt to respond with numeric input or voice input (i.e. please enter or say the reason for your call)

As soon as I'm off WiFi, everything is fine. I can reproduce this over and over and over.
This leads me to believe that there's a corner case bug (being the one I'm describing) where automated playback downstreams fine, but attempting to respond to those systems through WiFi calling crashes on the upstream.

Can someone (anyone), attempt to reproduce this?

Thanks!
 
Last edited:

bizack

macrumors 6502a
Original poster
Apr 21, 2009
576
334
No issues here. Have you tried reaching out to Tmobile on Twitter?
I called them and spoke with technical support. They didn't have an answer, other than it's probably a bug with iOS 8.
Although since you're not experiencing this, then something is obviously up with my phone...
 

Supermallet

macrumors 65816
Sep 19, 2014
1,307
648
I use wifi calling in several different spots regularly, and have called plenty of automated systems without issue.
 

bizack

macrumors 6502a
Original poster
Apr 21, 2009
576
334
I use wifi calling in several different spots regularly, and have called plenty of automated systems without issue.
I Reset Network Settings, and... everything magically fixed itself. I have no idea what the issue was.