T-Mobile WiFi outgoing calls work, but incoming calls go straight to voicemail

Discussion in 'iOS 8' started by motulist, Sep 18, 2014.

  1. motulist macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #1
    Fresh iOS 8 "restore" installation done through iTunes, on a 5S.

    Turned on T-Mobile WiFi Calling.

    Turned on airplane mode + WiFi enabled.

    Status bar carrier line says "T-Mobile WiFi", and shows full WiFi signal bars.

    Can make outgoing calls perfectly, and it works great. Voices sound like a best-case cell call quality.

    ...

    BUT, when people try to call me, they say it goes to voicemail, while my phone never rang.

    Anyone else have this problem? More importantly, anyone know how to *fix* this problem?
     
  2. dipstik macrumors newbie

    Joined:
    Aug 30, 2014
  3. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #3
    Good thought, that might be the case, but it definitely *shouldn't*. Airplane mode disables all the antennas except for the one that you then specifically re-enenable. If WiFi is enabled, and I can make outgoing calls over WiFi, then I should be able to receive incoming calls over WiFi just the same. If this problem is caused by airplane mode, then it's a bug in the OS.
     
  4. Blackforge macrumors 6502

    Joined:
    Mar 8, 2008
    #4
    Maybe your line is not provisioned for Wi-Fi calling due to iPhone being new to this type of calling on their network. Someone with an S5 had a similar issue:

    http://forum.xda-developers.com/showthread.php?t=2723817

    You may want to call them and see. However, I found several instances through Google with other phones and T-Mobile, so it doesn't look isolated to just iOS 8.

    Maybe your WiFi is going to sleep if its been locked?
     
  5. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #5
    Restarted the phone and now the problem is gone. Can now receive incoming calls over wifi just as well as initiate them.
     

Share This Page