tattiebogle's Xbox Controller Driver and GamePad Companion broke in Yosemite DP4?

Discussion in 'OS X Yosemite (10.10)' started by wallydavid, Jul 24, 2014.

  1. wallydavid macrumors newbie

    Joined:
    Jan 24, 2012
    #1
    Not sure if anyone else can confirm this, I have been using steam's game platform on my Mac, tattiebogle's Xbox controller drivers and GamePad Companion from the App store stopped working in the DP4 release. The console thrown a IO usb error.

    I am dual booting mavericks and yosemite on different drives on the same machine.
    They still work in mavericks. but are dead in DP4.. anyone have this problem?
     
  2. bizzaregood macrumors regular

    Joined:
    Aug 31, 2008
    Location:
    MA, US
  3. Pintagrinta macrumors newbie

    Joined:
    Apr 21, 2008
    #3
    same here... the power led of the wireless receiver stay off..
    sent an email to the driver's developer.. hope for an update.:(
     
  4. GuySahaf macrumors newbie

    Joined:
    Aug 3, 2014
    #4
    revert back to version 0.11 and it will work again on Yosemite.
     
  5. ajhenley macrumors newbie

    Joined:
    Aug 3, 2014
    #5
    I installed 0.11 and it's still not working. I just installed over the top. Should I remove it totally first? How would I do that?
     
  6. gableroux macrumors newbie

    Joined:
    Feb 14, 2010
    Location:
    Quebec
    #6
    I deleted prefpane (go in settings.app and right click the prefpane). Downloaded 1.11 from Tattiebogle site, installed, said there was a more recent version, installed anyway. Opened preferences, didn't show up, installed again and it works just fine now.

    [​IMG]
     
  7. ryleylamarsh macrumors newbie

    Joined:
    Jun 17, 2010
  8. OneMHz macrumors newbie

    Joined:
    Mar 24, 2011
    #8
    Thank you! Downloaded and did a straight install overtop of v0.12. It's working again for me now! I thought of doing it, but felt too lazy to risk trying to go back through several possible versions.

    Note: It warned me about overwriting the driver with an older version. Just accepted and continued and that did the trick.

    Note 2: I'm running Beta 5.
     
  9. ikir macrumors 6502a

    Joined:
    Sep 26, 2007
    #9
    No official word from dev? An updated versions would be awesome
     
  10. simon48 macrumors 65816

    simon48

    Joined:
    Sep 1, 2010
    #10
    Don't count on it, look at the release dates for all the versions, it almost never gets updated.
     
  11. SurferSD, Aug 22, 2014
    Last edited: Oct 14, 2014

    SurferSD macrumors newbie

    Joined:
    Jul 19, 2011
    #11
    How to fix

    Install the 0.13.1 Driver from here (GitHub): https://github.com/d235j/360Controller/releases

    Open terminal and type the following: sudo nvram boot-args="kext-dev-mode=1"

    What this does, is it disables the requirement for having all kext files signed (and thus approved) via Apple.

    Please watch the GitHub page referenced above as from the looks of it, they just got approval to sign their drivers so we should be seeing a new install soon.

    Thanks to all those who have been working on this project. I haven't, but I appreciate everyone's effort.

    -- Ryan
     
  12. stormchasingk9 macrumors newbie

    Joined:
    Aug 24, 2014
    #12
    I've done everything listed in this thread but still can't get my Afterglow XBOX controller to function. It functioned perfectly in Mavericks.


    The instructions I used to follow were these, the download links were for a script automator that added a custom gamepad settings into the system. Even though I can still do that and it seems to work, the gamepad still isn't recognized:

    --
    1. If you have installed any version of TattiBogle and didn't work download UnTattie.

    2. Open Terminal and type: sudo sh and press enter, then insert your password - it will be invisible - and press enter.

    3. Type again: sudo sh and be sure there is a space after sh.

    4. Drag and drop UnTattie file in Terminal and press enter.

    5. Download TattieBogle 0.08 and install it. It probably will say that it failed the installation but it will be installed.

    6. Download this Controller List Installer.

    7. Download this Controller List.

    8. Go in About This Mac on the menu, click more info and then system report. Connect your controller if you haven't done that yet and check under hardware, and the USB. For me under USB High-speed bus, then Hub I had Afterglow gamepad. If you use an original controller you might see it as vendor specific device. Click on it and in the box below you will see a Product and Vendor ID. Write those down.

    9. Open the Controller List file with a text editor and you look for <key>Controller</key> or look for other key tag that contains your device name, is irrelevant, but I edited under <key>PDPAfterglow</key> just because I have the Afterglow controller.

    10. You will see this few line below it:
    <key>idProduct</key>
    <key>idVendor</key>

    11. Insert in between those <integer></integer> tags those number you wrote down earlier instead of those that are in the file. You might want to check the second 'Thanks to' link at the bottom if this is getting confusing.

    12. Once you have done save the changes and drag and drop the file over the automator controller list installer.

    13. Go in system preferences and go mess with your XBOX Controller while you'll joy with glee!

    --

    Is there any way to get the Afterglow to work again?
     
  13. bmac89 macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #13
    Still not working

    Hi,

    It is not working for me as well. I have tried all the methods above with no luck - installing older versions etc.

    It works fine on Mavericks, but not on Yosemite PB and strangely also not working on Snow Leopard.

    I have a Logitech F310 set to Xinput mode and the driver shows no devices and the green light is off. However when I go to: About this Mac> System Report
    It shows the Logitech device under USB devices.

    Any help appreciated. Many thanks.
     
  14. bmac89 macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #14
    It is strange that it is working for some people but not others. No matter what version I install it makes no difference. No device Found. I have tried all the methods above with no luck. I have Yosemite PB2. It was working fine on Mavericks.

    Any help much appreciated.
     
  15. bmac89 macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #15
    Strangely I got this working after multiple tries. I did a clean install of Yosemite and that didn't work. I then tried installing every version of Tattieboggle and following all the steps in this thread and that still didn't work. After trying multiple installs and reinstalls over and over again it has now randomly started working. I don't have much confidence that it won't break again or not work at all when Yosemite is finally released.
     
  16. stormchasingk9 macrumors newbie

    Joined:
    Aug 24, 2014
    #16
    I still haven't managed to get my Afterglow working again, but given that it's a third party controller, I'll probably have to rely on some youtube video again like I did with Mavericks. A shame Microsoft so half-assedly supports its controllers, even in the Windows environment. I had to go through hoops on Windows 7 to get it recognized, and it's an officially licensed product!
     
  17. MacGillicuddy, Sep 8, 2014
    Last edited: Oct 20, 2014

    MacGillicuddy macrumors newbie

    Joined:
    Sep 8, 2014
    #17
    There is a driver available for the Mac which works with Yosemite and the Xbox One controller. Download it from this link: http://stonelightpictures.com

    It's in beta but works really well.
     
  18. zulu.walker macrumors newbie

    Joined:
    Jun 14, 2010
    Location:
    SEAsia
    #18
    This works on Yosemite 10.10 PB3 (build 14A361p) with a wireless Xbox 360 Controller previously working on 10.9. Thanks!
     
  19. cuthead macrumors newbie

    Joined:
    Oct 20, 2014
    #19
    Thank you ,works well on 10.10 14A389
     
  20. TheJazz macrumors newbie

    Joined:
    Oct 23, 2014
    #20
    Super easy

    This worked really well! Thank you so much for the help!
     
  21. spaceyonhayling macrumors newbie

    Joined:
    Oct 25, 2014
    #21
    works!

    this is great, thanks for posting the fix!
     
  22. ikir macrumors 6502a

    Joined:
    Sep 26, 2007
    #22

    Awesome! THANKS.
     

Share This Page