Tethering through the iPhone 4S from hell!

Discussion in 'iPhone' started by -scott-, Sep 26, 2012.

  1. -scott- macrumors newbie

    -scott-

    Joined:
    Dec 8, 2010
    Location:
    Melbourne, Australia
    #1
    Hi all,

    My network (of 30ish mac clients) hosts an internal IMAP mail server, and an OS X file server with a PPTP VPN configuration.

    Mostly, it all works fine - except for one user. This client's machine refuses to connect to our mail server from certain remote networks - such as from his home, or from his iPhone's 3G Tethered connection. When connected via the office Ethernet or WiFi, he experiences no problem.

    I'm not sure whether this is a problem with his OS X 10.7.4 laptop, or iPhone, or both. As soon as his iPhone 4S 3G connection is established, the laptop cannot connect to our SMTP mail server.

    His internet connectivity is always fine… and he can always receive mail.

    We have:

    - tried tethering through different iPhones (on different networks), all of which connected OK
    - tried a new USB 3G modem, which worked. Tried my home ADSL internet via WiFi, which also worked.
    - tried different mail applications (Mail.app, Entourage, Thunderbird). The problem occurs with all mail programs; it is not mail specific.
    - tried a backup/hard reset of the iPhone, which made no difference.
    - tried creating new user accounts on his machine. The problem happens with all user accounts.
    - cloned his laptop: more specifically, used Migration Assistant to import his user accounts from Target Disk mode, onto a spare identical machine). His problem recurred on both machines. (which is great for testing, because now we have a malfunctioning clone with which to 'play with').
    - repaired permissions etc. (as a long shot)
    - Checked that his firewall is turned OFF in System preferences.
    - Note that the mail client app on the iPhone itself works OK.

    At the time of writing, we have not tried:
    - Another carrier's microSim in his iPhone (the phone was locked until yesterday, and the user is now away for this week)

    To me, all things point to either the user's iPhone, or his network carrier. It is also worth mentioning that this user's iPhone cannot connect our PPTP VPN. No problem with other iPhones. (Yes, we've tried setting up L2TP VPNs just for his phone, it won't connect to these either).

    However, this does not explain why the user is experiencing the same issue from his home WiFi. He has told me that it is just a stock-standard ADSL router (ie. without any firewalls or time capsules or nonstandard devices). he has tried both Ethernet and WiFi connections at home. He can get onto the internet at home, but cannot send mail.

    Is there any under-the-hood SMTP firewall things to look at? Either on his iPhone or Mac OS X? It's just a standard SMTP Port 25… (yes, we've tried with and without SSL, which makes no difference).

    Any ideas on what is going on?

    Thank you,
    scott
     
  2. -scott- thread starter macrumors newbie

    -scott-

    Joined:
    Dec 8, 2010
    Location:
    Melbourne, Australia

Share This Page