text fonts garbled in safari and address book snow leopard. Probable font issue?

Discussion in 'macOS' started by TwoBytes, Sep 26, 2009.

  1. TwoBytes macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #1
    System: clean install of 10.6

    Issues:[/B ]Safari has garbled menus/text and so does autotrader.co.uk
    Also the groups on the right in address book are garbled (the text looks out of place/corrupt ). The contacts look fine, it's just a couple group names, not all.

    What i've tried: There are no duplicates in my font book. I repaired permissions. I've tried the demo of fontdoctor 7.6 but it says no errors, everything passed.


    I'm completely stuck - anyone else have this problem?
     
  2. TwoBytes thread starter macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
  3. ncmason macrumors regular

    ncmason

    Joined:
    Feb 27, 2007
    #3
    In Font Book, go to "All Fonts" in the sidebar, select all the fonts (Command + A), go to File > Validate Fonts.

    Remove any corrupt fonts.

    If Address Book still displays text incorrectly, try deleting the Address Book ".plist" file:

    Home/Library/Preferences/com.apple.AddressBook.plist
     
  4. TwoBytes thread starter macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #4
    Thanks for the suggestion. Unfortunately, all fonts validated fine and deleting the address.plist didn't work.

    This is strange. Any other tips?
     
  5. ncmason macrumors regular

    ncmason

    Joined:
    Feb 27, 2007
    #5
    You may want to consider re-installing Address Book from the Mac OS X Disc.

    Install the Snow Leopard Disc. Choose "Optional Installs" folder. Then click on "Optional Installs.mpkg".

    Once you're on the window that lists what to install, select "Address Book" under Applications.

    [​IMG]
    [​IMG]
     
  6. TwoBytes thread starter macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #6
    thanks! good idea. I'll give that a go, and post back here, hopefully with the beer smiley :)
     
  7. ncmason macrumors regular

    ncmason

    Joined:
    Feb 27, 2007
    #7
    Hahaha.
     
  8. TwoBytes thread starter macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #8
    Hi there,

    I finally got round to it after a busy busy schedule...and it didn't work :(

    By the way, nice site http://masonsklut.com/ :)
     
  9. ncmason macrumors regular

    ncmason

    Joined:
    Feb 27, 2007
    #9
    Thanks for that comment. I appreciate it.

    On another note, I'm disappointed that it didn't work.
    Have you tried doing a PRAM reset (startup holding down Command + Option + P + R)?
     
  10. TwoBytes thread starter macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #10
    yeah, you only really check these sites when browsing or to check out the good person helping. I mean it - i picked up some great tips on your site.

    Will try the pram. I did read 10.6.2 will have some address book fixes so that may cure it :)
     
  11. ncmason macrumors regular

    ncmason

    Joined:
    Feb 27, 2007
    #11
    Thank you. Check back in a couple weeks, I'll post some more tutorials — I've been busy recently.

    I do hope Apple fixes this issue you are having with Address Book in the next update. I'm sure they will.
     

Share This Page