The Finder can’t complete the operation because some data can’t be read or written

Discussion in 'macOS' started by desmond, Jan 22, 2010.

  1. desmond macrumors newbie

    Apr 11, 2007
    Hi all

    I've done a search for this and cannot seem to find a definitive solution.

    I've just upgraded to a larger Verbatim external drive and when I go to take files off my existing external drive across to it, it keeps coming up with the error:

    The Finder can’t complete the operation because some data in *** can’t be read or written

    This only happens in certain folders. I am able to copy some folders across, but some I get this error. I've tried verifying both drives, formatting the Verbatim one for FAT32, repairing, but nothing seems to work.

    Some points that may be worth mentioning:

    - The original external drive is formatted as MAC OS X Extended Journaled.
    - Some of the folders I am having trouble with may have been originally created on a PC.

    I would like to keep the new drive as FAT32, so I can use it on a PC if I need to down the road. I read something about using dot_clean via terminal, but I can never seem to get the path correct to my external drive. (The name of the external drive is MASTER HD)

    Would appreciate if anyone else has had the same problem could tell me what they did to solve it? Not sure why some files will copy over and some wont?

    Thanks for any help
  2. InfoSecmgr Guest


    Dec 31, 2009
    Ypsilanti, Michigan
    I had the same issue when copying files from a PC over to my iMac. Some of the files on the PC were hidden or read only, so I changed the entire folder over to read/write. Fixed it.
  3. desmond thread starter macrumors newbie

    Apr 11, 2007
    Thanks for your help guys.

    GGJstudios, that first link seems to solve it, thanks for sending through. This is happening with a lot of folders. Is it possible to run the dot_clean command across all subfolders of a folder too? I tried adding * at the end of the path and it doesn't seem to work.

    Thanks again
  4. desmond thread starter macrumors newbie

    Apr 11, 2007
    I couldn't get the dot_clean function to work in sub-folders, so I just resorted to changing my Hard Drive back to "OS Extended Journaled" format. I guess I don't use it on PC's anyway.

    If anyone else comes across this post, I found some other tips here, but none of them worked for me - hopefully you'll have more luck!
  5. lancerkind macrumors newbie

    Jul 29, 2008
    Southern China, Seattle, and places in between
    dot_clean worked for me

    I couldn't get my 16GB SD card to copy to my other 16GB SD card without getting the Finder -32 error. (The 16GB SD cards are used with my Palm TX running PowerSDHC, thank you PalmPowerups! So they are formatted Fat32.)

    After reading through this thread and the others mentioned here, this is what I did:

    1) dot_clean -m ~
    It didn't make much sense to me to clean my /home directory so I also cleaned my source SD card.
    2) cd /Volumes/<enter SD card name>
    3) dot_clean -m .

    Then I was successfully able to copy the files from one SD card to the other. I don't know if step 2 and 3 are necessary as I didn't try the process with out them.

    Since this is a strange hassle and it was a big waste of time to discover how to do something simple (copy from one SD to another) I reported the bug to Apple along with the above workaround.


    ==>Lancer--- <- Science Author
  6. skajam66 macrumors newbie

    Jan 26, 2011
    I don't know if this will help anyone or not but, you never know....

    I have just today started getting this error when backing up to an external drive. I'm running 10.6.6 and have successfully been backing up for over a year - until today. (For note, I'm a sinner and back up my working directories by drag and drop onto the external drive when I feel like it).

    The only thing that I could think that I had done (of significance) since my last backup was to enable viewing of hidden files in Finder (using the command: defaults write AppleShowAllFiles YES). So I disabled viewing of hidden files (with defaults write AppleShowAllFiles NO), relaunched Finder and tried again but still no luck. I then restarted the computer, tried again and it was fine. Everything back to normal.

    This is not a definitive proof that enabling hidden files was the problem and I don't intend to fiddle around to prove it or otherwise. However, maybe this will help someone....
  7. djchriscleary macrumors newbie

    Mar 8, 2011
    Solution from apple


    I am new to mac, but have been having the same issues, I have been trying to copy my windows data over to my mac and getting the same ERROR 36 message,

    I have just spoken to mac and they have said that there is no definitive solution yet but there is a way around it.......

    Apple said because of the fact that my drive is in NTFS or FAT32 this is the reason the files will not carry over. The temporary solution is to.....

    1. Back up all your files that you want to transfer onto the windows machine (or another external harddrive)
    2. Replug the external harddrive into the mac machine.
    3. On the mac, Open Applications > Utilities > Disk Utilities
    4. Highlight the external harddrive > Accross the top there should be tabs for first aid / erase / partition etc....
    5. Click the "Erase" Tab> In the format box chose "MS-DOS (FAT)" option
    6. Format the drive in this format.
    7. Reconnect the drive in the windows machine > transfer the files you want to copy on to it
    8. Your drive should work at copying data from there...........

    I hope this helps, (if this is obvious, please dont laugh at my amatuer mac skills :))
  8. GGJstudios macrumors Westmere


    May 16, 2008
    It is absolutely NOT necessary to reformat the drive to FAT32 to solve this problem, and it is NOT an acceptable solution for those who need to store files larger than 4GB. Please read the thread before posting. If you had done so, you would have seen a solution in the 2nd post.
  9. stallie macrumors newbie

    Apr 2, 2010
    Same trouble

    I'm having the same trouble, but it's nothing to do with old Windows files.

    I replaced my hard drive as everything had ground to a halt and wouldn't boot. Did a time machine install onto the new drive and didn't fix it. Then I installed SL and used migration assistant to drag my applications across, but not the documents.

    I've been dragging my docs across from the old drive plugged in via USB but I've been getting the -36 error here and there. Often enough that I can't pull across whole folders.

    Most interestingly, my Aperture library won't pull across and gets the -36 error 2gb of the way through 12 gb.... That's nothing to do with old Windows files.
  10. GGJstudios macrumors Westmere


    May 16, 2008
    What format is the drive?
  11. stallie macrumors newbie

    Apr 2, 2010
    New Hard Drive - Mac OSX journaled (extended)

    Old Hard Drive - Mac OSX journaled (extended) - it's the old drive straight out of the MBP put into an external case.

    Curiously though, I notice that in disk utility for the Macintosh HD, the erase option is grayed out. The Windows partition and the plugged in drives it is not. I wonder if this is related?
  12. djchriscleary macrumors newbie

    Mar 8, 2011
    D'you know what mate, I thoroughly apologize for being born. It wont happen again.
  13. GGJstudios macrumors Westmere


    May 16, 2008
    You can't erase the Macintosh HD partition if you're currently booted from it.

Share This Page