Thick grey band across iMac monitor.

Discussion in 'iMac' started by plagued, Mar 31, 2014.

  1. plagued macrumors newbie

    Joined:
    Mar 31, 2014
    #1
    Hi, I have a 21.5-inch Mid-2010 iMac running 10.9.2 with 12Gb of 1333 MHz DDR3 RAM, and ATI Radeon HD 4670 256 MB Graphics and 3.06 GHz Intel Core i3 Processor. I’ve had this for about 3 and a half years.

    Some time back I noticed a ‘ghost’ panel on the left side of the display. It lasted a few months but wasn’t really that obvious. It was hardly noticeable and eventually disappeared. A few weeks ago I noticed another. This time it was a 65mm (2.5 inch) deep band running horizontally right across the screen just above the screen centre.

    These ‘ghosts’ seemed to be very light grey and stayed in front (on top) of whatever was displayed. The new panel has become much darker and sometimes holds a memory of what was beneath it for 30 seconds or so. It also flashes and rolls sometimes but always within the same 65mm band which is always displayed in the same position. This panel is immediately obvious when the Mac boots up and shows up even before the apple logo on the grey screen.

    I’ve tried to take an image of the panel but ‘Grab’ captures what is ‘beneath’ the grey area. I’ve read somewhere that this would suggest that the graphics card is not the problem. I’m wondering if it is the screen itself?

    Does anyone know what is happening and if I can fix it?

    I do not know if this is a hardware or software problem so apologies if I have posted in the wrong section.

    Thanks.
     
  2. fastlanephil macrumors 6502a

    fastlanephil

    Joined:
    Nov 17, 2007
    #2
    You could try resetting the pram and the SMC. Maybe connect another monitor to it and see if it also exhibits this issue.

    You could also boot from an external drive or the optical drive, maybe reinstall the OS.
     
  3. plagued, Mar 31, 2014
    Last edited: Apr 1, 2014

    plagued thread starter macrumors newbie

    Joined:
    Mar 31, 2014
    #3
    Thanks for the advice. I've reset the PRAM and SMC as well as run a Quick and Extended Apple Hardware Test (No problems found) and so far had limited success. The worst of the symptoms seem to have stopped but the grey band is still there. I think I'm going to order a cable adapter and connect the iMac to another screen, see if the band is still visible. If so I'll try a re-install.
     
  4. plagued thread starter macrumors newbie

    Joined:
    Mar 31, 2014
    #4
    The black band and black / grey flickering is back so while waiting for my cable to arrive to test if this problem is down to the LCD panel (which I'm becoming increasingly convinced it is) I've started looking at my options. If the monitor is the problem I was thinking of hooking up the iMac to a Samsung S22C300HS 21.5 inch LED Monitor. The problem then becomes how to turn the iMac screen off completely. As far as I can tell this is not possible. Could I open the iMac up and disconnect the LCD panel? Would the iMac still function properly through the Samsung monitor or would I cause other problems by disconnecting the LCD panel?
     
  5. melchior macrumors 65816

    melchior

    Joined:
    Nov 17, 2002
    #5
    Hi Plagued, have you had a chance to see the result of disconnecting the display ribbon? I'm interested to know.

    Cheers
     

Share This Page