This device isn‘t eligible for the requested build

Discussion in 'iOS 9' started by Kidder1994, Nov 20, 2015.

  1. Kidder1994 macrumors regular

    Joined:
    May 20, 2012
    #1
    i'm trying to install iOS 9.2 beta 4 on my iPhone 6S, i downloaded the correct ipsw, but everytime i want to load it into itunes it says "This device isn‘t eligible for the requested build" what can i do? i checked my host and my firewall doesn't seem to be the problem because i can install 9.1 ipsw without problems :C

    Please Help!
     
  2. aldrinjtauro macrumors regular

    Joined:
    Jul 3, 2014
    Location:
    Birmingham, AL
    #2
    Hey, that happened to me too! Thought for a second they turned developer UDID checks back on, but I'm not sure. Just installed the public beta instead, since it's at the same build #.
     
  3. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #3
    Just go through the public Beta and download it OTA.

    https://beta.apple.com/sp/betaprogram/
     
  4. gwang73 macrumors 6502a

    gwang73

    Joined:
    Jun 14, 2009
    Location:
    San Francisco Area
    #4
    It looks like an issue on Apple's side. I tried to install on the iPhone6s, iPad mini and iPod touch 5th gen and getting the same error message. They all update with the OTA method.
     
  5. Kidder1994 thread starter macrumors regular

    Joined:
    May 20, 2012
    #5
    Yeah, just tried 9.2 beta 3 and right now its restoring, after this im gonna update to beta 4 from beta 3... but i was quite interested in restore it via ipsw because it's more clean than doing OTA...
     
  6. mogilner macrumors newbie

    Joined:
    Oct 22, 2013
    #6
    I was really irritated about this error, I spent many hours trying to troubleshoot this, but couldn't find any solution. I didn't even think of trying the previous beta. I restored 9.2 beta 3 (developer version). That worked, which proved the premise that it is an Apple issue and not something on my side.

    I was so perplexed on what was happening I went as far as reformatting my computer and my devices. Did anyone put this in as a bug in developer center?
     
  7. Kidder1994 thread starter macrumors regular

    Joined:
    May 20, 2012
    #7
    Nope i didn't, so if you can you would be doing me a favor hehe.
     
  8. jobu3434 macrumors regular

    jobu3434

    Joined:
    Jun 26, 2012
    Location:
    Virginia Beach, VA
    #8
    I'm surprised the file has still not been fixed by Apple. It has been reported and I even came across an Apple developer forum discussion on it. That seems like a fix that would come fairly quickly.
     
  9. Makale.Helvetia macrumors 6502a

    Makale.Helvetia

    Joined:
    Sep 14, 2014
    Location:
    İSTANBUL - TÜRKİYE
    #9
    did the same thing today,first downloaded beta 3 - restored and updated to beta 4 from OTA

    must be an issue with Apple side.

    tried to change hosts settings on my pc but no luck.

    the ipsw files may be corrupted or not uploaded properly..
     

Share This Page