CarPlay Those who updated to iOS12, any major Carplay issues?

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by TheNorthWaves, Sep 20, 2018.

  1. TheNorthWaves macrumors 6502

    Joined:
    Oct 13, 2007
    Location:
    USA
    #1
    I hate that I have to ask this kind of question, since I used to never question Apple's software quality... but who has updated to iOS12, and has it introduced any CarPlay glitches? I know the apps it gains, I'm just enjoying a seamless CarPlay experience on my Sony headunit and would rather not upgrade into a bug.
     
  2. burnthefires macrumors member

    Joined:
    May 26, 2017
    #2
    Been driving 2 days with Google Maps and Apple Music on all the time - works as good as always.
     
  3. mikecalderone macrumors member

    mikecalderone

    Joined:
    Aug 5, 2015
    Location:
    Laguna Niguel, CA USA
    #3
    It works great, no issues to report. I am also using Google Maps, and it it much better that Apple maps. Can't wait for Waze to release their update to support Apple CarPlay.
     
  4. cyclingplatypus macrumors 65816

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #4
    The only issue that I have experienced is google music, it hangs on loading but other than that no issue.
     
  5. arod65, Sep 21, 2018
    Last edited: Sep 21, 2018

    arod65 macrumors newbie

    Joined:
    Sep 21, 2018
    #5
    Apple native apps work great! Haven’t tested Google maps yet! However, SiriusXM app on CarPlay is wonky. Can’t access favorites tab. If you open the app 1st in CarPlay, it affects other non Apple apps you try to open afterwards ..ie a blank screen shows up on Spotify if you open that app after you open SXM. Anyone else having similar issues? SMX worked with ios11.
     
  6. Agent001 macrumors newbie

    Joined:
    Sep 10, 2008
    #6
    Anybody tried out Tunein Radio? Didn’t seem to want to load at all.
     
  7. Bazooka-joe macrumors 68020

    Bazooka-joe

    Joined:
    Mar 12, 2012
    Location:
    Swindon, England
    #7
    Yep it works perfectly in my Merc. Google maps is a revelation compared to Apple Maps. Cant wait to try out Waze tomorrow :)
     
  8. Agent001 macrumors newbie

    Joined:
    Sep 10, 2008
    #8
    Tunein working perfectly for you? Anybody have any ideas why its not loading at all on Carplay for me?

    I turn on the app, then click browse, but it just wont load.
     
  9. correiart macrumors newbie

    Joined:
    Jul 31, 2018
    #9
    I have some problems with TuneIn too. The first time I open the app I need to open it in my phone and select the station. After it starts on my phone everything works well in carplay. I had the same problem in IOS11.
     
  10. Cheesybugger macrumors newbie

    Cheesybugger

    Joined:
    Sep 22, 2017
    #10

    I gave up on tunein ages ago. It doesn’t work more than it does. Rubbish app.
     
  11. Bazooka-joe macrumors 68020

    Bazooka-joe

    Joined:
    Mar 12, 2012
    Location:
    Swindon, England
    #11
    Not tried that one to be honest
     
  12. DaveTheRave macrumors 6502a

    Joined:
    May 22, 2003
    #12
    The SiriusXM app is still a flaming piece of crap.
     
  13. MacWorks916 macrumors member

    Joined:
    Apr 4, 2015
    #13
    I've had the issue whenever I launched the Map app on the stereo it pulls up the map with the directions to the next event on my Calendar. This issue occurred using iOS 10.3.x but I was able to disable it by going here Settings > Privacy > Location Services > System Services > Frequent Locations

    But with the new iOS 12 it has come back and the menus have since changed. Still haven't found out how to disable this feature again.
     
  14. flawtek macrumors newbie

    Joined:
    Aug 22, 2007
    #14
    The most notable issue I've encountered is that iOS 12 completely breaks the Podcast app in CarPlay. Often the screen is blank, or you can't select options like Library, etc. The problems render the app unusable from the car interface and you have to make your selections directly from your iOS device. The problem isn't specific to any auto manufacturer either:

    https://discussions.apple.com/message/33959928?ac_cid=tw123456#33959928
     
  15. PPSH-41 macrumors member

    Joined:
    Aug 20, 2009
    Location:
    USA
    #15
    CarPlay and Waze. Waze no longer stays on my phone where I want it. It moves to my truck nav screen where it is more cumbersome to use. Removing the icon from my iPhone CarPlay screen does nothing. I still want CarPlay for messages and phone so now I’m stuck with Waze displayed where I don’t want it (truck screen) or I don’t have CarPlay phone and messages. I’m emailed Ford, Apple and Waze. If only there was an option to stop Waze from transferring to truck nav screen. Very frustrating
     
  16. Perderder macrumors newbie

    Joined:
    Sep 23, 2013
    #16
    Upgraded to the iPhone XS Max and ever since I have had random CarPlay disconnects. Most of the time it will disconnect and then reconnect seconds later. It works for several minutes then does it again. Other times I will have to unplug the USB cable and plug it back in for it to reconnect. I never had this problem with the iPhone X. I am not sure if the issue started because of iOS12 or if it's an XS Max issue.

    Car is a RAM 1500 with Uconnect 8.4 system.
     
  17. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #17
    Worth swapping out the cable to be sure, even if temporarily??
     
  18. tromboneaholic Suspended

    tromboneaholic

    Joined:
    Jun 9, 2004
    Location:
    Clearwater, FL
    #18
    Fixed a few issues I was having under iOS 11 when a call would come in while navigating and listening to music.
     
  19. darrenf1 macrumors member

    Joined:
    Oct 5, 2012
    Location:
    South Jersey
    #19

    I have had that problem, and also if I am listening to anything NOT sourced from the phone, (Sirius via the satellite tuner, FM) and I pick up the phone and launch an app ( Tapatalk, Facebook, Twitter, etc), it causes the stereo to switch to "iPod" with nothing playing. I have to unplug the phone to use any apps without causing my source to switch. It's infuriating. And before anyone jumps on me, this is when my wife is driving and I am using my phone.
     
  20. jharrisinpdx macrumors newbie

    jharrisinpdx

    Joined:
    Sep 12, 2017
    #20
    Not sure if this is an iOS 12 issue (or 12.0.1 update, which I'm on) or iPhone XS issue, but while parked yesterday trying to film some falling leaves in a park while connected to wireless CarPlay I found all camera modes that take video (video, slow-mo) to be unresponsive on both back and front cameras. Autofocus "pulses" between completely out of focus and sharp rapidly and pressing the record button shows record state for about a second then flips back to static state, no file is recorded or saved. At first I didn't realize it was a CarPlay issue, and thought it was randomly occurring or not, but after observing the behavior only occurred while connected, and testing that while in the car if I disconnected from CP the camera behavior returned to normal. At first I thought it might be a driving safety feature, but would expect a notification screen, not what appears to be a glitch. Also all still image camera functions (photo, portrait, time-lapse) work while connected. Will file a case with Apple, but curious if anyone else can replicate.
     

Share This Page

19 September 20, 2018