CarPlay Those who updated to iOS12, any major Carplay issues?

TheNorthWaves

macrumors 6502
Original poster
Oct 13, 2007
329
18
USA
I hate that I have to ask this kind of question, since I used to never question Apple's software quality... but who has updated to iOS12, and has it introduced any CarPlay glitches? I know the apps it gains, I'm just enjoying a seamless CarPlay experience on my Sony headunit and would rather not upgrade into a bug.
 

arod65

macrumors newbie
Sep 21, 2018
1
1
Apple native apps work great! Haven’t tested Google maps yet! However, SiriusXM app on CarPlay is wonky. Can’t access favorites tab. If you open the app 1st in CarPlay, it affects other non Apple apps you try to open afterwards ..ie a blank screen shows up on Spotify if you open that app after you open SXM. Anyone else having similar issues? SMX worked with ios11.
 
Last edited:
  • Like
Reactions: slusmiles

Agent001

macrumors newbie
Sep 10, 2008
13
2
Yep it works perfectly in my Merc. Google maps is a revelation compared to Apple Maps. Cant wait to try out Waze tomorrow :)
Tunein working perfectly for you? Anybody have any ideas why its not loading at all on Carplay for me?

I turn on the app, then click browse, but it just wont load.
 

correiart

macrumors newbie
Jul 31, 2018
4
0
I have some problems with TuneIn too. The first time I open the app I need to open it in my phone and select the station. After it starts on my phone everything works well in carplay. I had the same problem in IOS11.
 

Cheesybugger

macrumors newbie
Sep 22, 2017
26
10
Tunein working perfectly for you? Anybody have any ideas why its not loading at all on Carplay for me?

I turn on the app, then click browse, but it just wont load.

I gave up on tunein ages ago. It doesn’t work more than it does. Rubbish app.
 

MacWorks916

macrumors member
Apr 4, 2015
32
6
I've had the issue whenever I launched the Map app on the stereo it pulls up the map with the directions to the next event on my Calendar. This issue occurred using iOS 10.3.x but I was able to disable it by going here Settings > Privacy > Location Services > System Services > Frequent Locations

But with the new iOS 12 it has come back and the menus have since changed. Still haven't found out how to disable this feature again.
 

flawtek

macrumors newbie
Aug 22, 2007
3
1
The most notable issue I've encountered is that iOS 12 completely breaks the Podcast app in CarPlay. Often the screen is blank, or you can't select options like Library, etc. The problems render the app unusable from the car interface and you have to make your selections directly from your iOS device. The problem isn't specific to any auto manufacturer either:

https://discussions.apple.com/message/33959928?ac_cid=tw123456#33959928
 
  • Like
Reactions: darrenf1

PPSH-41

macrumors member
Aug 20, 2009
34
5
USA
CarPlay and Waze. Waze no longer stays on my phone where I want it. It moves to my truck nav screen where it is more cumbersome to use. Removing the icon from my iPhone CarPlay screen does nothing. I still want CarPlay for messages and phone so now I’m stuck with Waze displayed where I don’t want it (truck screen) or I don’t have CarPlay phone and messages. I’m emailed Ford, Apple and Waze. If only there was an option to stop Waze from transferring to truck nav screen. Very frustrating
 

Perderder

macrumors newbie
Sep 23, 2013
5
0
Upgraded to the iPhone XS Max and ever since I have had random CarPlay disconnects. Most of the time it will disconnect and then reconnect seconds later. It works for several minutes then does it again. Other times I will have to unplug the USB cable and plug it back in for it to reconnect. I never had this problem with the iPhone X. I am not sure if the issue started because of iOS12 or if it's an XS Max issue.

Car is a RAM 1500 with Uconnect 8.4 system.
 

simonsi

macrumors 601
Jan 3, 2014
4,850
734
Auckland
Upgraded to the iPhone XS Max and ever since I have had random CarPlay disconnects. Most of the time it will disconnect and then reconnect seconds later. It works for several minutes then does it again. Other times I will have to unplug the USB cable and plug it back in for it to reconnect. I never had this problem with the iPhone X. I am not sure if the issue started because of iOS12 or if it's an XS Max issue.

Car is a RAM 1500 with Uconnect 8.4 system.
Worth swapping out the cable to be sure, even if temporarily??
 

darrenf1

macrumors member
Oct 5, 2012
56
19
South Jersey
The most notable issue I've encountered is that iOS 12 completely breaks the Podcast app in CarPlay. Often the screen is blank, or you can't select options like Library, etc. The problems render the app unusable from the car interface and you have to make your selections directly from your iOS device. The problem isn't specific to any auto manufacturer either:

https://discussions.apple.com/message/33959928?ac_cid=tw123456#33959928

I have had that problem, and also if I am listening to anything NOT sourced from the phone, (Sirius via the satellite tuner, FM) and I pick up the phone and launch an app ( Tapatalk, Facebook, Twitter, etc), it causes the stereo to switch to "iPod" with nothing playing. I have to unplug the phone to use any apps without causing my source to switch. It's infuriating. And before anyone jumps on me, this is when my wife is driving and I am using my phone.
 

jharrisinpdx

macrumors newbie
Sep 12, 2017
6
1
Not sure if this is an iOS 12 issue (or 12.0.1 update, which I'm on) or iPhone XS issue, but while parked yesterday trying to film some falling leaves in a park while connected to wireless CarPlay I found all camera modes that take video (video, slow-mo) to be unresponsive on both back and front cameras. Autofocus "pulses" between completely out of focus and sharp rapidly and pressing the record button shows record state for about a second then flips back to static state, no file is recorded or saved. At first I didn't realize it was a CarPlay issue, and thought it was randomly occurring or not, but after observing the behavior only occurred while connected, and testing that while in the car if I disconnected from CP the camera behavior returned to normal. At first I thought it might be a driving safety feature, but would expect a notification screen, not what appears to be a glitch. Also all still image camera functions (photo, portrait, time-lapse) work while connected. Will file a case with Apple, but curious if anyone else can replicate.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.