Time Machine SL restores pop3 emails twice a week - it's driving me bananas

Discussion in 'macOS' started by arpiuk, Oct 19, 2009.

  1. arpiuk macrumors newbie

    Joined:
    Feb 19, 2008
    #1
    Ever since SL was installed, Time Machine restores pop3 emails into my inbox. So, about twice a week I get about 300 emails restored, emails that I do NOT want. They have been filed away, replied to. What makes it difficult is that I have to trawl through what was restored and what was not read/replied to/filed away.

    As a test, I turned off Time Machine for 2 weeks, problem solved. Obviously, I don't want TM turned off.

    I then deleted my pop3 email accounts and re-created them with different names. Problem re-appeared. HELP!!! Apple do not have a solution, I tried.

    If any help, I have 4 pop3 accounts and 2 .me accounts. The .me accounts are not affected, only the pop3 ones.

    Any suggestions? it's driving me insane!

    Thank you
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    Time Machine doesn't write anything to your source drive, unless you're running the TM app and restoring something.

    Check your POP3 account settings and see when files are removed from your server - both for reading and trashed. It could also be something odd with your server, where it's not tracking removed/deleted files and keeps them as new/unread.
     
  3. sidewinder macrumors 68020

    sidewinder

    Joined:
    Dec 10, 2008
    Location:
    Northern California
    #3
    arpiuk,

    What email program are you using to read email from your POP accounts?

    If you are using Apple Mail:

    1. Start Mail
    2. Select "Preferences" from the Mail menu
    3. Select "Accounts" and click on the the POP account
    4. Click the "Advanced" button
    5. Verify that "Remove copy from server after retrieving a message" is checked and that the drop down is set to "Right Away". Then click the "Remove now" button.

    This will make sure the emails are deleted from the server when they are downloaded successfully.

    S-
     
  4. arpiuk thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #4
    yes,of course. TM machine does not restore unless you're running the application.

    However, I followed a process of elimination. When TM is turned off, then no problem. My pop3 settings are fine. It is set to leave messages for no more than 1 day. It is strange that "something" restores my emails that are upto month old.

    Settings are definitely correct, as I check my mail account on the webmail interface and no emails there, older than 1 day.

    Any other suggestions?

    PS:I would like to keep messages for 1 day, so that my iPhone has a copy of my emails too. Problem is that if they get deleted from the server, as soon as they are downloaded, then I won't get an exact copy on my iPhone.
     
  5. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #5
    The main point I was trying to make is Time Machine doesn't write anything besides when restoring. Otherwise it just logs activity.

    Well, if you watch the activity in Mail, and it's actually transferring the messages from the server, I'd still suspect something not right there. I've seen, on my own server, "issues" (bugs, no doubt) caused a set of messages to reload.

    Another thing [I just thought of] - is there a chance you've exceeded a quota? If so, you will only get [usually] 4096 at a time, until there's enough buffer space open for new messages. It would look like you're just reloading the same amount of "new" messages, but they're really a new batch.
     
  6. arpiuk thread starter macrumors newbie

    Joined:
    Feb 19, 2008
    #6
    Actually, something I did not mention. You cannot watch the activity window when all these emails are being re-populated. They are not being downloaded, as they appear in an instant, yes, 300 emails can just appear in 1 second, so am unable to watch the activity window. By the time I open the window, it shows nothing.

    I have a 1GB quota, no chance of exceeding those. Anyway, like I said, they are most definitely not on the server.

    Just got off the phone with Apple Care and they half heartedly acknowledged that they are aware of the problem, but have not found a solution yet. Apparently it happens on their own support line computers. I spent 2 hours on the phone with them, sent them various screen shots, let's see what happens.
     
  7. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #7
    It appears that Time Machine is stuck in time. I think it's quite obvious the solution here is to repair the flux capacitor.
     

Share This Page