Timeout error stupidity

Discussion in 'General Mac Discussion' started by arogge, Nov 19, 2004.

  1. arogge macrumors 65816


    Feb 15, 2002
    I'm having problems with OS X software timing-out after trying to resolve an address for only a few seconds. When I am on a slow connection and am downloading one thing or more, the software is useless because it won't wait for bandwidth before claiming that there is no connection or that the server doesn't exist. For example, I am downloading my e-mail on a slow connection. At the same time, I tell the Mozilla browser to load apple.com, and then I go back to the mail window. Several seconds later, usually seven seconds, the browser window pops up and covers the e-mail window I was reading, only to display a useless error message:

    "apple.com could not be found. Please check the name and try again."

    Why can't the software try again, preferably without saying anything? It could at least display a message in the status bar without interrupting work in other windows. The mail and newsgroups client will often have timeout problems related to low bandwidth, too.

    "<News server> could not be found. Please check the name and try again."
    "Failed to connect to server <News server>."
    "<Mail server> could not be found. Please check the name and try again."

    Mozilla will often begin loading a bulky page (with links to third-party servers like 112.2o7.net and hitbox.com) when it has another one of its timeout issues:

    "The document contains no data."

    Then the browser stalls with part of the page loaded. I have to reload the whole page again to get the rest of it. This is often followed by the error:

    "<Server> could not be found. Please check the name and try again."

    This is very annoying and it wastes time. The software should keep waiting for bandwidth until it gets it, or the user should be able to set the timeout period and the number of retries desired before the software stops trying to reach a server. There appear to be two problems:

    Software programmers assume that everyone has a high-speed connection which is never busy, and so they put useless error messages in the software instead of making the software able to ignore connection problems.

    OS X seems to be causing most of the timeout issue. In Linux, Windows, and various other Unix operating systems, Mozilla and most of the other network software has no timeout problems. But on OS X, they all have the same problem.

    While downloading one file at a slow 2 KB/sec, there is enough bandwidth for other applications, but:


    "The domain name server lookup for the specified host has failed. The host is unknown."


    "Could not connect to AIM The specified host cannot be located."


    "Could not purchase the items in your cart. An unknown error occurred (-9806). There was an error in the Music Store. Please try again later."


    "The specified server could not be found."


    "Could not locate remote server <Server>"


    "Couldn't open the file <File> because the Internet host was not found."

    Real Player:

    "Unable to locate server. This server does not have a DNS entry. Please check the server name in the URL and try again."


    "Safari can't find the server. Safari can't open the page <URL> because it can't find the server <Server>".

    Software Update:

    "Software Update can't connect to the update server. Make sure you can connect to the Internet, then try again."

    While OS X applications were popping up with all these complaints about failing to find a connection, I went into Netscape Communicator through Classic OS 9 and had no problems accessing any remote servers. Applications running under other operating systems also had no problems using the available network bandwidth while OS X insisted that there was no network.

    There's something in OS X that is causing this problem. :confused:
  2. broken_keyboard macrumors 65816


    Apr 19, 2004
    Secret Moon base
    Other people were talking about this in the "safari sucks" thread. It sounds like there may be a problem with the lookupd program, which is the program all the other programs use to translate a host name in to an IP address.

    The good news is there is a new version of lookupd coming with OS 10.3.7 so it looks like Apple is aware of the problem.

  3. blackpeter macrumors 6502a

    Aug 14, 2001
    Yes! I'm getting the same issues and my first thought was that it must be a DNS issue. But I've tried EVERY darn Pacbell/SBC DNS server in California, but still - pages sometimes have to be reloaded before my browser will find the site's server.

    I've switched over to Tiger and have yet to encounter a page not loading (which is becoming common in Panther). I will continue to test and get back to you.
  4. broken_keyboard macrumors 65816


    Apr 19, 2004
    Secret Moon base
    I spent ages playing with my router trying to fix this, and in the end just came to the conclusion that my ISP has intermitent DNS servers. It never even occured to me the problem could be with OS X. You just assume that domain name resolution is something that was written once in 1972 and the code has never been touched since. Oh well...
  5. neilrobinson macrumors 6502

    Aug 21, 2004
    Perth, WA, Australia
    i have the same problem, i also always thought it was my isp's dns server - i started using somebody else's dns and it improved but its still not that great. i do have an extra hop to my server but thats on gigabit lan and shouldn't make that much difference anyways. I even setup my own caching dns server which kinda helped with frequently visited pages.

    hope tiger fixes it.
  6. blackpeter macrumors 6502a

    Aug 14, 2001
    Interesting... I've been using Tiger for about a day now and keeping an eye on this reload issue. Guess what? Not one page has failed to load. Seems like it might be a Panther issue, but I'm holding judgement for another day or so.
  7. Geo49 macrumors newbie

    Nov 27, 2004
    DNS Problem: Mac OS 9.2.2 + AirPort + SBC YahooDSL

    I seem to have a similar DNS problem...

    Every time I reboot my Mac PowerBook, and try to open Yahoo.com or Google.com (for example), I get a DNS error:
    "The specified server could not be found".

    However, if I put in the IP address for Google or Yahoo, it works fine, every time. ( = Yahoo or = Google) AOK browsing with IP addr -- but then, using the ordinary URL, it fails the first "n" times... where "n" is large!!!

    It all worked just fine for the past year. THEN, a few weeks ago, my persistent DNS errors began.

    Whenever I reboot, and begin trying to check email, or begin web browsing, I must manually retry about 50-100 times, until finally it works, and then I can access most domains ok... Then, after awhile, sporadically, I must manually retry two or three times for some domains, but only rarely.

    The error is "The specified server could not be found". Seems like a DNS timeout?

    Every time I reboot, this condition returns, I must retry about 50-100 times to get ANY domain to work with my web browser. As soon as ONE domain works, almost ALL domains work, MOST of the time... Until at least one domain works in my web browser, there is no point in trying Outlook Express, it will error out, also looking for DNS.

    I have read some scuttlebutt on several websites that IPv6 DNS timeouts are the cause, and some other Mac users are suffering. Is there any help, or workaround, or fix for this? See :: http://forums.macosxhints.com/showthread.php?t=30226

    Is ANYBODY ELSE having this trouble???

    Every time I reboot it takes a few minutes to begin browsing anything, I must manually retry, until DNS finally kicks in...

    The SBC Yahoo DSL help line said "try contacting Apple, it looks like their problem..."

    My Control Panels: TCP/IP (ver 2.5, MacOS 9.2.2) ::
    DNS Server Addr:
    Additional Search Domains:

    Email >> GeoFan49-Mac <at> yahoo.com <<

    PowerBook G3 (Pismo) + Mac OS 9.2.2 + IE 5.1.7 using Apple AirPort wireless card and 2wire modem via SBC Yahoo DSL...


    DO NOT tell me to upgrade to OS X -- I hate UNIX!!!!
  8. topalli macrumors newbie

    Dec 9, 2004
    mac OS hangups, reload and other problems

    I also had this problem. Pages would require multiple reloads, mailservers would ask for authentication over and over.

    It happened when I did an upgrade to jaguar (Maybe a clean install would have been better).

    Anyhow, I found: <a href src="http://www.oreillynet.com/pub/wlg/2086?page=last&x-order=date"> this article </a>

    "Wireless networking insanity at OS X con"
    and it seems the problem is that the Mac is getting confused via the firwall and is sending multiple reset messages to the router, hanging up the connection.

    It is a jaguar problem.
    turning off the firwall in the sharing control panel cured this problem for me. Let me know if it does the same for you.

    I'm not sure what software is causing this problem for me (is it possibly some of the items I'm sharing? I'm not sure)

    This is very annoying, and I'm not sure if turning off my firewall is such a great solution. Hopefully Apple will do something about this.
  9. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I was talking to somebody seeing this with Safari and an Airport/Cable connection not 30 minutes ago. It's been discussed at length recently (MacFixIt went over potential causes and solutions for days), and although certain situations (say, AirPort networks combined with Safari) are more prone to seeing a version of it, there is more than one root cause.

    For example, some people only see it with Safari, though I occasionally get this using Cox and Camino, with my computer connected directly to the cable modem. A few people can resolve it by disabling IPv6, but that's not a universal fix. I know someone who is seeing exactly the same issue on Windows with a 3Ware wireless router and SBC DSL, as well, so it's not even limited to the MacOS.

    It would appear that Apple is aware of the problems and is working to either resolve or work around them (or some of them, at least), though, which would be great for all of us. Sadly, waiting seems to be the only thing to do right now.
  10. patinacreme macrumors newbie

    Dec 13, 2004
    I fixed my problem by going to system prefs
    built in ethernet
    IPv6 = off

    hope this helps
  11. dotnina macrumors 6502a

    Aug 19, 2004
  12. daveL macrumors 68020


    Jun 18, 2003
    I've experienced this problem, but it has been site dependent for me. Yahoo is the primary problem site, specifically their financial quote page. I've always felt it was an underlying DNS issue. It may have something to do with the way particular sites publish their DNS entries vs. the DNS servers you reference and the client side (OS X) look up. As mentioned above, 10.3.7 will update 'lookupd', so hopefully the problem on the client side will be fixed soon. Fortunately, it does affect me all that often.
  13. arogge thread starter macrumors 65816


    Feb 15, 2002
    It looks like Apple has finally fixed the timeout issue with the OS 10.3.7 update.

    Here is the DNS timeout problem in Mozilla:

    In appstrings.properties:
    "dnsNotFound=%S could not be found. Please check the name and try again."

    In nsDocShell.cpp:
    else if (NS_ERROR_UNKNOWN_HOST == aError) {
    // Get the host
    nsCAutoString host;
    CopyUTF8toUTF16(host, formatStrs[0]);
    formatStrCount = 1;

    // Display the error as a page or an alert prompt
    NS_ENSURE_FALSE(messageStr.IsEmpty(), NS_ERROR_FAILURE);
    if (mUseErrorPages) {
    // Display an error page
    LoadErrorPage(aURI, aURL, error.get(), messageStr.get());
    // Display a message box
    prompter->Alert(nsnull, messageStr.get());

Share This Page