Totally messed up my OS X 10.2.4

Discussion in 'Mac Help/Tips' started by totally_fly, Mar 19, 2003.

  1. totally_fly macrumors member

    Nov 12, 2002
    Somehow, I managed to completely massacre my OS. Click and drag (for Icons, text, the dock, pictures.. ANYTHING.. click and drag) does not work... also, icons of programs I download are not showing up.. they are simply Folder icons

    i think these problems happened after I ran these commands.

    I am ultimately annoyed as much of what I do is now extremely limited...

    can anyone whos a bit more UNIX aware help me find out what i've done??

    I would very much appreciate any help!!
  2. Goblin2099 macrumors member

    Jul 18, 2002
    New York City
    haha, I wouldn't worry about those commands, that's an april fools site from last year.

    Seriously though, I've had the problems you're discussing several times, usually running Repair Permissions clears up the drag/drop problems, and clearing the caches fixes up the folder icons. I recommend Cocktail, an easy freeware app that'll automate that kind of thing.
  3. totally_fly thread starter macrumors member

    Nov 12, 2002
    well I tried that.. and no luck

    I still have the no icons and the drag and drop issue (even after a restart)

    now I feel like an idiot cuz of the aprils fools joke (those names were suspicious: CocoaFinder.. RunSlowly!!!) but im still pretty annoyed at the drag and drop.. i dunno why but im gonna trash all my prefs and start over.. see if that helps at all.. and if that doesnt work.. im probly gonna break down and cry :mad:

    edit: trashing prefs didnt help, and just to be clear, click and drag works NOWHERE, not the dock, not in Safari, not in the finder, not in word, not in iTunes.. NOWHERE!!! AHH!!!! This is like living with a Borland Operating System!!!
  4. mnkeybsness macrumors 68030


    Jun 25, 2001
    Moneyapolis, Minnesota
    try booting from your install disc and repairing permissions that usually does the trick
  5. totally_fly thread starter macrumors member

    Nov 12, 2002
  6. Steradian macrumors 6502

    Dec 3, 2002
    San Jose
    Start up from install disk--->installer menu--->disk utilites--->select main HD--->first aid--> repair permissions

  7. FredAkbar macrumors 6502a


    Jan 18, 2003
    Santa Barbara, CA
    When you're booted up from the CD, with the installer open, there's a menu option (I think it's on the "Installer" menu) that says Open Disk that, then select the First Aid tab in the Disk Utility window...then click Repair Disk Permissions.

    This drag n drop problem happened to me when I first got my iMac with 10.2.3...I installed the 10.2.4 update and everything worked could try downloading the 10.2.4 update here, and installing it again...see if that works.

    By the way...are you using an Apple mouse, or a third party mouse? It probably doesn't matter, but you may as well make sure you're using the basic Apple mouse that came with the computer.

  8. totally_fly thread starter macrumors member

    Nov 12, 2002
    ok well i did reboot and i found the Repair Permissions.. but it was greyed out... so i did repair disk and it didnt fix the two errors it found.. and no im using a 3rd party mouse.. ahhh

    btw.. the icons thing is fixed.. but not the click n drag
  9. TEG macrumors 604


    Jan 21, 2002
    Langley, Washington
    Reinstall OSX from the CD, But do not erase the drive or do a clean install. If that still doesn't work, try a clean install (doesn't erase the drive, just replaces the "System" folder.

    Sorry Dude.

  10. totally_fly thread starter macrumors member

    Nov 12, 2002
    A Clean Install fixed the problems... working perfectly now.. and feels a lot snappier! I think im gonna stay off VT for a while :)

    thanx guys
  11. bennetsaysargh macrumors 68020


    Jan 20, 2003
    New York
    whenever that happens to me, a retsart usually does the job for me:confused:

Share This Page