touch 2G. Cannot restore firmware, nor kick out of recovery mode.

Discussion in 'iPod touch Hacks' started by morfluziat, Apr 16, 2009.

  1. morfluziat macrumors newbie

    Joined:
    Apr 15, 2009
    #1
    Hi all.
    I've got an ipod 2G with a version 2 firmware on it.

    I generated a custom firmware from a 2.2.1 package using quickfreedom, via itunes 1.7.6 on winXP.

    I then put the ipod into DFU mode and attempted to restore with the custom package.

    Initially, the restore failed with an "error 6".

    I tried a few more times, all with the same result.

    I rebuilt the firmware and tried again. Same result.

    I rebuilt the firmware and tried again on another computer - an old 2004 macbook. This time the process failed with an error 21.

    I then went back to the windows machine and uninstalled iTunes, and removes all vestiges of it from the system.
    I then installed iTunes 8 and tried again.

    This time it fails with an error 1604.

    At this point, I'd be happy to just get the ipod working again as it was before.

    If I reboot, the ipod goes into recovery mode.

    How can I get the ipod out of recovery mode, without installing new firmware ?

    Thanks.
     
  2. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #2
    if you have another USB port try plugging the ipod into that and see if iTunes will restore to original firmware
     
  3. Topper59 macrumors member

    Joined:
    Dec 25, 2008
    #3
    To get the iPod out of recovery:
    1. Plug it in to the computer
    2. Hold the Power and Home buttons until you hear a USB ding (or 10 seconds)
    3. Let go of both buttons
    4. Hold the power button just like your turning it on
    5. It should turn on normally

    As for the error, did you do the Pre-Jailbreak in Quickfreedom? your ipod screen has to be white to restore in iTunes
     

Share This Page