Touch came with 1.1.5 not 2.1 and they want me to pay?

Discussion in 'iPod touch' started by sportsfanMAW, Sep 18, 2008.

  1. sportsfanMAW macrumors regular

    Joined:
    Dec 27, 2006
    #1
    Hi,
    My grandma just ordered an imac and got an ipod touch with it. It is of course the 1st gen but it came with 1.1.5 and not 2.1 or even 2.0. And they want me to pay 10 bucks for it! Why is that?'

    EDIT: Oops forgot to mention she got it with the back to school promo.
     
  2. mariotheotaku macrumors regular

    Joined:
    Apr 16, 2008
    #2
    I think the 2.0 software only comes with the new ipod touch.
     
  3. sportsfanMAW thread starter macrumors regular

    Joined:
    Dec 27, 2006
    #3
    so they release it in the middle of july and two months later it still comes with the old software??? apple really is squeezing for money here, that ridiculous!
     
  4. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #5
    They stopped production of the iPod touch much earlier to ramp production of the 2G touch. No way were they going to unbox and update all the old iPod touches so they classed 2.0 as an optional install.

    With the 2G iPod touch, 2.1 was the standard installation.
     

Share This Page