Transparency creates blurry text/fonts — SOLUTION

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
561
276
UPDATE #1: Ignore my post below unless you have the same issue. It seems restarting my Mac fixed the blurry-fonts issue.

UPDATE #2: Turns out that a restart simply solves the issue temporarily but eventually comes back in the same session. A more permanent fix (until this bug is eliminated by Apple Inc.) is to do as user Paradoxally stated: "Turn off LCD font aliasing under General [then restart your computer]."

I can't be the only one. OS X Yosemite has turned my 27" iMac into a blurry text renderer. I feel like I need a new eye exam and glasses prescription.

I have a half-solution, but it requires eliminating the transparency effect:

  1. Go to System Preferences > Accessibility
  2. Check "Reduce transparency"



...but it doesn't eliminate all of it. The sub-menus are still blurry. I may discover more. Here's an example:



You'll notice the sub-menu items are blurry (under View), yet the Accessibility window underneath displays fonts in sharpness.

UPDATE: Restarting my Mac fixed the blurry-fonts issue. I'll keep an eye out for it, but I hope the issue doesn't return.
 
Last edited:

AllergyDoc

macrumors 68000
Mar 17, 2013
1,550
3,401
Utah, USA
I also have a 27" iMac. In addition to what you've posted, you can also try checking "Increase contrast" just above Reduce transparency. I've been on the beta for several weeks and have found I'm okay with just having LCD font smoothing on. I like the transparency and don't want to turn it off. You get used to the slight blurriness. I'm hoping it'll be improved in future releases but have been told not to be disappointed if it isn't.
 

SRLMJ23

Contributor
Jul 11, 2008
2,020
982
Central New York
Also if you turn on "Increase Contrast," that helps. This was pointed out by 9to5Mac I believe.

I will try the one tip, as I do not want to turn off Transparency, however, thank you for the tips and keep them coming!

:apple:
 

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
561
276
Restarting FIXED IT

For some reason, all it took was a restart. Now my fonts render fine, transparency or not. What an odd effect. I over reacted. Will make an edit to my original post.
 

SRLMJ23

Contributor
Jul 11, 2008
2,020
982
Central New York
I also have a 27" iMac. In addition to what you've posted, you can also try checking "Increase contrast" just above Reduce transparency. I've been on the beta for several weeks and have found I'm okay with just having LCD font smoothing on. I like the transparency and don't want to turn it off. You get used to the slight blurriness. I'm hoping it'll be improved in future releases but have been told not to be disappointed if it isn't.

Ha, we must have been writing our posts at the same time.

Turning off "LCD Font Smoothing" has seemed to be the best option for me so far. It really helped a lot!

Also, I did not realize that clicking on "Increase Contrast" turns off Transparency automatically, so I just turned up the Contrast a little bit in the slide bar.

I can understand why people said if you do not have a Retina Screen not to upgrade, but that certainly should not stop anyone plus I think Apple will fix the blurriness issue with some updates in the near future.

:apple:
 

AllergyDoc

macrumors 68000
Mar 17, 2013
1,550
3,401
Utah, USA
I can understand why people said if you do not have a Retina Screen not to upgrade, but that certainly should not stop anyone plus I think Apple will fix the blurriness issue with some updates in the near future.

:apple:
I admit it is difficult going back and forth between a retina and non-retina screen, but the huge monitor makes up for it. Text is at its worst on the iMac when using Safari's reader. It's terrible. Text inside apps is okay. I do hope it gets improved.
 

SAdProZ

macrumors 6502a
Original poster
Mar 19, 2005
561
276
Update #2

Added this to my original post as an update:

UPDATE #2: Turns out that a restart simply solves the issue temporarily but eventually comes back in the same session. A more permanent fix (until this bug is eliminated by Apple Inc.) is to do as user Paradoxally stated: "Turn off LCD font aliasing under General [then restart your computer]."
It's been 3-4 days and so far it worked (nothing blurry).