Tried to restore iPhoto library with Time Machine, now photos are all gone.

Discussion in 'Mac Basics and Help' started by perlanova, Nov 28, 2009.

  1. perlanova macrumors newbie

    Joined:
    Nov 28, 2009
    #1
    I use a white Macbook running 10.5.8.

    Alright, so this morning, I tried to restore my iPhoto library using Time Machine to about 2 months ago, since I had deleted some pics.

    Long story short, it didn't seem to work, so I restored the backup from this morning at 11 am, the latest backup, since I had just uploaded some new photos today.

    Now my iPhoto library is empty. There are just outlines where my pics used to be, and it seems to remember events and all, but there are no pics or videos at all. Everything is gone.

    I'm just lost and feeling a bit nauseaus that I may have lost 40 some gigs of photos.

    Any ideas?
     
  2. Ashka macrumors 6502a

    Ashka

    Joined:
    Aug 9, 2008
    Location:
    New Zealand
    #2
    Open the iPhoto application on your Desktop > Open the Time Machine Application and hopefully restore the photos from WITHIN iPhoto.

    Mucking about with the iPhoto Library leads to all sorts of problems.
    Fingers crossed.
     
  3. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #3
    Tell me about it, my boss put all his photos into iphoto - then he went back to windows. That took me hours and hours to get the photos back out.
     

Share This Page