Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

MP 1,1-5,1 Triple display Tribulations (also Gigabyte RX580 8G Gaming 2.0?)

mattspace

macrumors 68000
Original poster
Jun 5, 2013
1,506
1,165
Australia
Hey Folks,

So I'm having a hell of a time trying to get my triple displays to play nicely with my main pro apps, and I'd appreciate some advice on where to go troubleshooting -wise.

Setup:
  • Left: Benq SW240 HDMI (portrait - 1200x1920, switchresx'ed to 1390x2226)
  • Centre: Benq SW270c DisplayPort (landscape - 2560x1440)
  • Right: Benq SW240 HDMI (portrait - 1200x1920, switchresx'ed to 1390x2226)
System is set to a single space for all 3 displays, so just one menubar in the middle, and the dock down the left screen. That arrangement was the purpose of the exercise.

Symptom: on display wake, the sw240s light straight up, the sw270 takes about 5 seconds to get a picture. That happened even without the SwitchResX custom resolutons. However certain applications, eg Capture One, and the Affinity Suite seem to interpret this pause in the centre display weirdly, and lose the lefthand display, shifting their documents to a position in the centre of both the remaining screens, as well as pulling their palettes onto the main screen (sometimes placed above the menubar so that you can't get to their draggable parts).

So the conundrum, is it a:
  • High Sierra thing (gpu driver), is it a
  • some displays being hdmi & one being displayport thing, is it a
  • problem inherent to the slow wake from sleep on the sw270c thing?
I know when I attempt to start into recovery, nothing will display on any screen, until I toggle the sw270c's Displayport mode 1.1/1.4, then recovery appears on one of the hdmi screens (rotated).

Options so far:
  • I have a second ssd that I can partition and get fresh, vanilla high sierra, and maybe even mojave installs onto, in case it's an OS problem.
  • A different GPU, that has 3xDP, like the gigabyte RX580 8G Gaming (GV-RX580GAMING-8GD R2.0), in case it's a mixing of display type issue (eg if Apple only tested the sapphire with 2 displays)
  • Futzing with different cable combinations, in case that's contributing to it, though I'd rather not put the sw270c on it's only hdmi port, as something else is using that.
Any other suggestions?
Thanks.

c1_fail.jpg

publisher_fail.png

photo_fail.png
 
Last edited:

mattspace

macrumors 68000
Original poster
Jun 5, 2013
1,506
1,165
Australia
so at risk of jinxing myself... moving the SW270c over to HDMI, and the SW240s back to Displayport seems to have calmed things down (although the sw240s power LEDs don't work right when the machine is asleep - they stay fixed on, or off, rather than pulsing, as they do on HDMI).

I think I just have to conclude that Benq has janky Displayport technology. :/
 

Zlobnick

macrumors member
Mar 6, 2016
51
20
Croatia
I'm also having issues similar to yours. Running tripple monitor setup with RX 580 on Mojave. When waking up from sleep the window configuration often gets messed up. Never found any useful solution rather than manually dragging windows back to it's original position.

I haven't had these problems when running High Sierra and GTX 980 with the same monitor setup and cables. So it's a Radeon/Mojave issue.

1602577453786.png
1602577474558.png

[automerge]1602577499[/automerge]
 

mattspace

macrumors 68000
Original poster
Jun 5, 2013
1,506
1,165
Australia
I actualy think SwitchRexX can help with this, (possibly superstition) but it has a option to declare the main screen, also there does appear to be a physical correlation between the physical port, and where it's more stable in the virtual assignment.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.