Trying to download apps but it tells me to Connect With Itunes

Discussion in 'iOS Apps' started by needthephone, Nov 4, 2008.

  1. needthephone macrumors 6502a

    Joined:
    Apr 4, 2006
    Location:
    sydney
    #1
    I am trying to download some apps on my iphone but I keep getting

    Authorisation failed. Please connect to iTunes.

    I had this before with updates (which are also doing the same thing now by the way)
     
  2. kevin512 macrumors member

    kevin512

    Joined:
    Aug 19, 2008
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_1 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5F136 Safari/525.20)

    +1
     
  3. mickbab macrumors 65816

    mickbab

    Joined:
    Sep 13, 2008
    Location:
    Sydney, Australia
    #3
    i cant access itunes on my iphone (app store, havent tried itunes store) or computer

    itunes on iMac: "we could not complete your iTunes store request. an unknown error occured (-4). there was an error in the itunes store. please try again later."

    another one i had earlier was: "could not complete the itunes store request, the store may be busy. check your internet connection or try again later."

    iPhone says: "cannot retrieve download information. please connect with itunes" then "authorization failed. please connect to itunes"

    not sure what's going on.
     
  4. moka macrumors 6502a

    Joined:
    Aug 11, 2008
    Location:
    California
    #4
    getting same error on iphone, on my PC i am getting this error when trying to download an app/song etc...

    could not add an item to your cart. The network connection timed out.
    make sure your network settings are correct and your network connection is active, then try again.

    could this be caused because apple is updating itunes?
     
  5. neodiem macrumors newbie

    Joined:
    Nov 4, 2008
    #5
    I am having the same issue. I noticed it starting at about midnight last night.
     
  6. bunnyhero macrumors newbie

    bunnyhero

    Joined:
    Nov 4, 2008
    #6
    i'm glad i'm not the only one getting these errors! :) both in the iphone app store on-device and in itunes on my pc.

    i'm in canada, by the way, for whatever that's worth.
     
  7. RKO macrumors 6502

    RKO

    Joined:
    Oct 21, 2008
  8. sir42 macrumors 6502

    Joined:
    Sep 16, 2003
    Location:
    NY, NY
    #8
    Yup, App is store is connecting to me on my mac or iphone.
     
  9. defender macrumors member

    defender

    Joined:
    Dec 31, 2006
  10. Rayfire macrumors 68020

    Rayfire

    Joined:
    Aug 25, 2008
    Location:
    PNW
    #10
    I had the same problem 10 hours ago.

    Right now it's working fine, check again your iTunes it should connect normally. (I'm from US btw)
     
  11. bunnyhero macrumors newbie

    bunnyhero

    Joined:
    Nov 4, 2008
  12. Jtuner77 macrumors regular

    Joined:
    Sep 15, 2008
    #12
    still ****in up for me, i restored and resynced and i still got the problem.....any clues?
     
  13. jarofclay73 macrumors regular

    jarofclay73

    Joined:
    Nov 15, 2008
    Location:
    Honolulu, Hawaii
    #13
    I get this more on my phone than on iTunes. Usually happens at work too where I'm in a building. When I get home and get onto wi-fi it's usually all good by then.
     
  14. SFC Archer macrumors 68000

    SFC Archer

    Joined:
    Nov 9, 2007
    Location:
    Troy, MT
    #14
    For everyone above...RE-Authorize your account through the iTunes store then sync your iPhone. This does not affect your 5 authorized computers. Sometimes the system just forgets you and you need to let it know you are still authorized. Don't know why it does this but every time I have re-authorized my computer and then sync the problem goes away usually until some form of update happens on ours or their end.

    Hope that helps,
    Good Luck
     
  15. rcfa macrumors newbie

    Joined:
    Jun 30, 2007
    #15
    False diagnosis?

    I have googled the issue, and while there may be more cause for the same error message, in my case CLEARLY it's not any of the reasons people claim are the reason:
    a) in http://discussions.apple.com/thread.jspa?messageID=8085756 the "answer" Apple iTMS maintenance. Not the case I have this issue 24*7*365
    b) others suggested to reauthorize the iPhone with iTunes, wrong again.
    c) there were other suggestions, like hard-reboot the iPhone, etc. which again are all wrong.

    Here is what I have figured out: if I turn off WiFi, it works over EDGE. If I go to a public hotspot I know in a nearby coffee shop, it works over WiFi.

    In other words, there is an issue with CERTAIN, but not all WiFi networks.

    I have searched (to no avail) if the mobile version of the iTunes store uses different ports or requires otherwise specific firewall settings. Couldn't find anything. Regular services (Safari, Facebook, Skype, VNC, ssh, etc.) work from iPhone and Mac, iTMS works from Mac, but not from iPhone when on my home WiFi network (Apple AirPort plus ZyWall gatway).

    My suspicion is that the app tries to create a tunnel, and since some ISPs already create a tunnel to connect their clients into their backbones, there might be issues with tunneling a tunnel, VPN passthrough, or other such things.

    Since Apple doesn't seem to know what's going on, and since most users seem to try voodoo rather than analyzing this problem in a more scientific way, this is likely to stay with us for a while... :(

    Anyone I hope my post can help tracking this issue down...
     

Share This Page