Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Trying to revive an old Macbook pro

Mark Poppen 🇳🇱🇨🇦

macrumors newbie
Original poster
Hi gang,

I was gifted an old Macbook pro 15" 17" that I was going to try and revive, either with MacOS or Ubuntu. I'm running into the issue that on bootup, the screen slowly fades to white, the fans spin up to max and then the system hangs.

The Macbook was formatted by the previous owner and the only option is internet recovery. I tried that first. It downloads the packages and then it looks like it's doing the installation, but then it hangs (with the fading to white screen and spinning fans).

So, I figured I'd give Ubuntu a try. I can boot up Ubuntu fine from a USB drive and use Ubuntu like normal. I can go through the installation process no problem through the GUI but as soon as it needs to be booted from the hard drive, again, the white screen fade.

Ok, so maybe it's the hard drive. I took the SSD from my even older Macbook (which dual-boots Ubuntu with MacOS), put that in the MBPro and see what it would do. Same thing. As soon as it boots. Nope.

I re-seated the memory banks with no solution.

So, here I am, trying to rule out things. Looking at the above, I don't think it's the OS, not the hard drive, not the GPU/logic board (which is suggested on other forums) because I can use Ubuntu GUI just fine and not the memory.

I'm running out of ideas.
 
Last edited:

jafd

macrumors member
Oct 14, 2010
65
103
Sure you can boot into OSX recovery somehow; you can then launch Terminal and execute this:

Code:
sysctl machdep.cpu.brand_string

This will tell you what the processor is, and that can be used to determine the exact-ish model (AFAIK no two models use the same CPU family, so there you have it).

In Linux, you can try
Code:
biosdecode
, and should that be unavailable,
Code:
dmidecode
 

jafd

macrumors member
Oct 14, 2010
65
103
not the GPU/logic board (which is suggested on other forums) because I can use Ubuntu GUI just fine and not the memory.
It could be that booting from internal media creates a different heating pattern that is killing the LCD panel. (Google is telling overwhelmingly that it's either LCD panel or the LVDS flex cable.)

Boot to Recovery doesn't really count, it's basically reading ~700 MB of data during boot and then doing all of its things in the RAM.

It's either the LVDS cable, or you may have better luck replacing the display assembly if you can find a donor.
 

clueless88

macrumors member
Aug 23, 2020
99
24
Have you tried hooking it up to an external monitor and seeing if you get the white screen fade or if you just get the spinning circle?
 

Fishrrman

macrumors Core
Feb 20, 2009
20,491
7,275
I'm thinking, "bad GPU".

IF it had a copy of the Mac OS on it, you could try booting in safe mode (which bypasses the discrete GPU and uses only the integrated graphics).

Do you have any other Macs available?
 

wordsworth

macrumors regular
Apr 7, 2011
185
87
UK
I tried to install El Capitan on a late 2009 white MacBook running Snow Leopard. The install failed repeatedly. I have since learned that it is possible for this failure to occur when there is no battery installed in the laptop when attempting to upgrade the OS. I'd previously been obliged to remove the battery because it had swollen significantly and, I believe, affected the reliability of the display. I subsequently used the MacBook on mains power only for some considerable time, plugged into an external monitor also, so the display issue posed no real problem for me.

I do plan to buy a 2-Power battery (which seem to be a good reliable replacement battery) at some point to see if I can successfully revive this lovely little laptop but I've been in no hurry to do so as yet.

Is your laptop battery installed and working? If not, I'm not saying that this is the cause of the problem that you're encountering but it may be worth considering as part of your troubleshooting efforts.
 

Mark Poppen 🇳🇱🇨🇦

macrumors newbie
Original poster
Sure you can boot into OSX recovery somehow; you can then launch Terminal and execute this:

Code:
sysctl machdep.cpu.brand_string

This will tell you what the processor is, and that can be used to determine the exact-ish model (AFAIK no two models use the same CPU family, so there you have it).

In Linux, you can try
Code:
biosdecode
, and should that be unavailable,
Code:
dmidecode
I was unsuccessful booting in anything...

It could be that booting from internal media creates a different heating pattern that is killing the LCD panel. (Google is telling overwhelmingly that it's either LCD panel or the LVDS flex cable.)

Boot to Recovery doesn't really count, it's basically reading ~700 MB of data during boot and then doing all of its things in the RAM.

It's either the LVDS cable, or you may have better luck replacing the display assembly if you can find a donor.
I'm not sure if that's worth the hassle. I have very little time as it is. This would be a project I don't really need ;)

Have you tried hooking it up to an external monitor and seeing if you get the white screen fade or if you just get the spinning circle?
I have not, but usually external screens only initiate after the boot stage, no?

I'm thinking, "bad GPU".

IF it had a copy of the Mac OS on it, you could try booting in safe mode (which bypasses the discrete GPU and uses only the integrated graphics).

Do you have any other Macs available?
I do have a couple of other Macs. Someone else told me to download High Sierra off the app store and create a boot USB. I might try that.

Why not boot from a DVD or an USB-stick with Linux to check what's going on?
I did. Same screen-fade. Linux bootup actually hangs as well and then fades the screen. Very similar to MacOS.

I tried to install El Capitan on a late 2009 white MacBook running Snow Leopard. The install failed repeatedly. I have since learned that it is possible for this failure to occur when there is no battery installed in the laptop when attempting to upgrade the OS. I'd previously been obliged to remove the battery because it had swollen significantly and, I believe, affected the reliability of the display. I subsequently used the MacBook on mains power only for some considerable time, plugged into an external monitor also, so the display issue posed no real problem for me.

I do plan to buy a 2-Power battery (which seem to be a good reliable replacement battery) at some point to see if I can successfully revive this lovely little laptop but I've been in no hurry to do so as yet.

Is your laptop battery installed and working? If not, I'm not saying that this is the cause of the problem that you're encountering but it may be worth considering as part of your troubleshooting efforts.
There's a new battery in it because the previous owner also had battery-swelling, so he replaced it, I think with an aftermarket one, but it's holding charge nicely for several hours.
 

Alexander William

macrumors 6502
Apr 18, 2020
288
128
Sounds like bad capacitors or inductors possibly an ic.

Grab a electronic multimeter or oscilloscope and a diagram for your unit and verify every IC, CAP and IND is working as intended.

That fade to white though sounds like a power related problem.

Might be better to try to buy a new Logicboard if you can grab one cheap and toss it in, as the labour will be extreme to trouble shoot.
 

clueless88

macrumors member
Aug 23, 2020
99
24
I was unsuccessful booting in anything...

I have not, but usually external screens only initiate after the boot stage, no?

I did. Same screen-fade. Linux bootup actually hangs as well and then fades the screen. Very similar to MacOS.
If you do have an external monitor, it would be easy enough to hook the MBP to it and see if the MBP is actually booting up properly. If it works with the external monitor then you've narrowed the potential problem list down with little financial or time expense. Well, I just checked my mid 2012 MBP and am surprised (well not really) that it has a Thunderbolt port but no HDMI--yours may have a mini display port--either way if you don't have a connector cable you may want to pick up a cheap one that connects your MBP to HDMI and test the MBP with a monitor or TV.
 

Imacman65

macrumors newbie
Jun 21, 2020
6
1
i have an early 2009 pro 17 and it has mini display, i have a mid 2012 pro 13 and it has thunderbolt , they both look the same but one will run my thunderbolt 27 inch display the other will not
 

556fmjoe

macrumors 68020
Apr 19, 2014
2,091
2,075
I'm about 90% sure it's a GPU failure. The Ubuntu USB live images are probably not going to use the discrete GPU, so it would make sense that you can boot an Ubuntu USB and install from it, but can't boot the installed system.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.