HomeKit Turned off 2 factor authentication. Now can’t access HomeKit remotely

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by deeside81, Mar 16, 2018.

  1. deeside81 macrumors member

    Joined:
    Jan 31, 2018
    #1
    I needed to access my iCloud Drive whilst I’m at work on an oil platform in the North Sea. To do this I need to switch off 2 factor authentication. I did this when I was in the accommodation from my iPhone. Now I can’t remotely access any of my HomeKit aps or HomePod. I turned it back on and now not able to connect. I’m fuming. Why has apple forced this on people? Really starting to lose faith in Apple as I really trusted that they do things so well and it’s just works so nicely. The HomePod is definitely beta. They shouldn’t of release it so soon and all the problems I’ve ever had with Apple is this dam HomePod. Only understands me half the time and sometimes doesn’t respond. Not very intelligent Siri either.
     
  2. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #2
    I believe HomeKit requires two-factor auth. to be active.

    Why would you need to disable it?
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    Because that's apple's way. I'm assuming that given the level of control that homekit has, 2FA is a safety feature.

    I'm not denying that Siri is less capable then Alexia or Google, but that's not news to anyone, so perhaps the HomePod is not a good fit for you, and another product may work out better. With the echo you do have access to a wider range of home automation products.
     
  4. BrettStah macrumors member

    BrettStah

    Joined:
    Sep 17, 2016
    #4
    This is not a HomePod specific requirement. The same requirement is in effect if you would use an AppleTV for your hub.
     

Share This Page

3 March 16, 2018