Turned on Parental Controls temporarily…now even with them off, Dashboard is broken

Discussion in 'macOS' started by devburke, May 9, 2011.

  1. devburke Guest

    Joined:
    Oct 16, 2008
    #1
    Hey, so I turned on Parental Controls to temporarily block myself from going on reddit while I was writing a paper. At one point when I was messing with the settings, I checked the box to only allow specific applications. By default, this excludes third-party widgets. Anyway, I unchecked this box, and Parental Controls still wouldn’t let me launch them. A window would pop up letting me type in the admin password to allow it, but even then, nothing happened. I tried rechecking the box and explicitly allowing them, and the setting didn’t take. Still didn’t work, and going back to the setting, the widgets were disallowed again. I’ve tried turning off parental control completely, and all that does is prevent the window from coming up telling me parental controls blocked it, but the widgets still won’t launch. I’ve tried repairing permissions and rebooting, but nothing seems to work. My parental controls settings seem to have permanently been set to block third-party widgets, whether I have parental controls turned on or not.

    Can anyone help me?
     
  2. devburke thread starter Guest

    Joined:
    Oct 16, 2008
    #2
    Update: It seems that entering my password to allow it when the popup tells me its blocked does allow it, but only if the box to limit applications is actually checked. And then next time I launch the parental controls setting, it’ll revert to blocking them.

    It I enter my password in the popup when applications aren’t supposed to be limited, then nothing happens at all.
     
  3. devburke thread starter Guest

    Joined:
    Oct 16, 2008
    #3
    I’ve also tried giving my account admin privileges and reinstalling the widgets. No dice. What the hell OS X?
     
  4. sebastiannz macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    I'm getting a similar problem. I have an account set up with parental controls on. When I go into this account, I can't add widgets even though I've specifically allowed widgets in the parental control screen. WHen I check the box and restart osx, I find they are unchecked again when I log back in.
     
  5. bshannon macrumors newbie

    Joined:
    Jan 13, 2012
    #5
    I have the same problem.

    I tried removing the quarantine flag from the downloaded widgets but that didn't help.
     

Share This Page