TV App no longer displays videos in TV OS 12

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
Ever since the beta version of TV OS 12 was released, the Library tab of the TV app no longer displays videos.
I have been reporting this to Apple for several months now and they still haven't fixed it.
They keep telling me to wait for the next release and today 12.1 was released and the problem is still there.
This is the screen that has the 4K and HDR section so I no longer have access to my 4K movies.
I have suggested to Apple that this screen be moved to the Movies tab where it belongs.
I am so disappointed that this problem has not been fixed. I have seen that others are having the same issue.

Does anyone have any insight into what is causing this problem?
 

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
This issue is still going on. Does anyone have any updates? Apple keeps saying they are aware of the issue and reporting to Engineering but it's been about 4-5 months now.
 

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
TV OS 12.1.2 beta was released today and this problem has still NOT been fixed.
 

Hermes Monster

macrumors 65816
May 4, 2010
1,146
310
UK
Have you tried resetting the ATV?

Do you have a particularly large library? I know when I use the Movies App (which imo is still much better for movies than the TV app) sometimes a certain section, usually the Family one, often won’t load until I move away to another genre and back. That’s with 69 films (191 in total)
 

HDFan

macrumors 68020
Jun 30, 2007
2,325
631
This is the screen that has the 4K and HDR section so I no longer have access to my 4K movies.
I have suggested to Apple that this screen be moved to the Movies tab where it belongs.
Are these iTunes purchased 4K & HDR movies, or movies from elsewhere? If so, where?
 

570934

Suspended
May 3, 2011
710
107
TV OS 12.1.2 beta was released today and this problem has still NOT been fixed.
Make sure that you have the default display set to 4K SDR in the ATV settings. You will need to restart the ATV before the 4K Library section re-appears.
 

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
Another big disappointment today. Apple released another beta update for 12.1.2 and this problem is still NOT fixed. This is an account problem and does not affect all users. It is happening on 3 Apple TVs for me.
[doublepost=1545328143][/doublepost]
Are these iTunes purchased 4K & HDR movies, or movies from elsewhere? If so, where?
All movies are missing. The library screen is completely blank except for a message that says 'You don't own any videos'.
[doublepost=1545328234][/doublepost]
Make sure that you have the default display set to 4K SDR in the ATV settings. You will need to restart the ATV before the 4K Library section re-appears.
Thanks but anything and everything has been done. This issue has been going on for almost 6 months now. I have restored the Apple TV several times, signed in/out. The issue must be with my particular content because it affects 3 different Apple TVs.
 

570934

Suspended
May 3, 2011
710
107
Another big disappointment today. Apple released another beta update for 12.1.2 and this problem is still NOT fixed. This is an account problem and does not affect all users. It is happening on 3 Apple TVs for me.
[doublepost=1545328143][/doublepost]
All movies are missing. The library screen is completely blank except for a message that says 'You don't own any videos'.
[doublepost=1545328234][/doublepost]
Thanks but anything and everything has been done. This issue has been going on for almost 6 months now. I have restored the Apple TV several times, signed in/out. The issue must be with my particular content because it affects 3 different Apple TVs.

And how do your purchase show on an iOS device when using the TV app? As you said it should like some account problem.
 

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
The TV app on IOS works fine. It is TV OS 12 that is broken. This worked fine in TV OS 11.
 

570934

Suspended
May 3, 2011
710
107
The TV app on IOS works fine. It is TV OS 12 that is broken. This worked fine in TV OS 11.
Just reading back to your original post, how come you don't have access to your 4K movies anymore? Your purchases which are in 4K should still be in 4K. TV app just groups them together under the movie section.
Have you actually called Apple? Or make an appointment at your local Apple store and take a unit down to show them.
 

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
Just reading back to your original post, how come you don't have access to your 4K movies anymore? Your purchases which are in 4K should still be in 4K. TV app just groups them together under the movie section.
Have you actually called Apple? Or make an appointment at your local Apple store and take a unit down to show them.
I only care about the TV app because of the 4K grouping. I no longer have that but the movies/TV shows are still in the individual apps. But I want the 4K and HDR section back. I have been working with Apple for the past 5-6 months, ever since I first discovered the issue. I even sent their engineers my logs twice. How they have not been able to resolve it in all this time is baffling. Every time they release an update I look to see if it is fixed. I know I am not the only one affected by this issue.
 

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
It's very strange that you don't see what I see.

I've never had a beta release on my ATV 4k and it's running the latest release of tvOS.
My mother has a brand new Apple TV 4K with the same issue I have (she's logged into my account). And then an Apple TV 4 with my account has the same issue. So I know it's related to my account somehow. Other users experiencing the same issue think it has to do with large libraries. I have over 2500 movies and about 500 TV shows.
 

Audit13

macrumors 603
Apr 19, 2017
5,436
1,378
Toronto, Ontario, Canada
My mother has a brand new Apple TV 4K with the same issue I have (she's logged into my account). And then an Apple TV 4 with my account has the same issue. So I know it's related to my account somehow. Other users experiencing the same issue think it has to do with large libraries. I have over 2500 movies and about 500 TV shows.
Wow, that's a lot of movies and that right there could be the problem.

The only reason I have purchased movies is because the iTunes code was included with my disc.
 

570934

Suspended
May 3, 2011
710
107
My mother has a brand new Apple TV 4K with the same issue I have (she's logged into my account). And then an Apple TV 4 with my account has the same issue. So I know it's related to my account somehow. Other users experiencing the same issue think it has to do with large libraries. I have over 2500 movies and about 500 TV shows.
It is odd. So, this is an ATV4K connected to a 4K TV?
 

cmleblanc

macrumors newbie
Original poster
Oct 30, 2018
14
0
It is odd. So, this is an ATV4K connected to a 4K TV?
Yes, this problem started during the beta of TV OS 12. I first reported it to Apple then and they thought it would be corrected when TV OS 12 was released. So they've know about this for many months now but have not resolved it, maybe it's not affecting enough people for it to be a priority.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.