TV App no longer displays videos in TV OS 12

Discussion in 'Apple TV and Home Theater' started by cmleblanc, Oct 30, 2018.

  1. cmleblanc macrumors newbie

    Joined:
    Oct 30, 2018
    #1
    Ever since the beta version of TV OS 12 was released, the Library tab of the TV app no longer displays videos.
    I have been reporting this to Apple for several months now and they still haven't fixed it.
    They keep telling me to wait for the next release and today 12.1 was released and the problem is still there.
    This is the screen that has the 4K and HDR section so I no longer have access to my 4K movies.
    I have suggested to Apple that this screen be moved to the Movies tab where it belongs.
    I am so disappointed that this problem has not been fixed. I have seen that others are having the same issue.

    Does anyone have any insight into what is causing this problem?
     
  2. Donfor39 macrumors 65816

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
    #2
    I have watch in hdr with my 4K movies listed via tv app library
    Note sure why op's isn't working.
     
  3. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #3
    This issue is still going on. Does anyone have any updates? Apple keeps saying they are aware of the issue and reporting to Engineering but it's been about 4-5 months now.
     
  4. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #4
    I have no problem seeing my "Library" under the TV app of my 4k Apple TV running the lates tvOS.
     
  5. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #5
    TV OS 12.1.2 beta was released today and this problem has still NOT been fixed.
     
  6. Hermes Monster macrumors 65816

    Hermes Monster

    Joined:
    May 4, 2010
    Location:
    UK
    #6
    Have you tried resetting the ATV?

    Do you have a particularly large library? I know when I use the Movies App (which imo is still much better for movies than the TV app) sometimes a certain section, usually the Family one, often won’t load until I move away to another genre and back. That’s with 69 films (191 in total)
     
  7. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #7
    My library displays all mu movies in the TV app.
     
  8. HDFan macrumors 65816

    Joined:
    Jun 30, 2007
    #8
    Are these iTunes purchased 4K & HDR movies, or movies from elsewhere? If so, where?
     
  9. Cell-666 macrumors 6502a

    Cell-666

    Joined:
    May 3, 2011
    #9
    Make sure that you have the default display set to 4K SDR in the ATV settings. You will need to restart the ATV before the 4K Library section re-appears.
     
  10. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #10
    Another big disappointment today. Apple released another beta update for 12.1.2 and this problem is still NOT fixed. This is an account problem and does not affect all users. It is happening on 3 Apple TVs for me.
    --- Post Merged, Dec 20, 2018 ---
    All movies are missing. The library screen is completely blank except for a message that says 'You don't own any videos'.
    --- Post Merged, Dec 20, 2018 ---
    Thanks but anything and everything has been done. This issue has been going on for almost 6 months now. I have restored the Apple TV several times, signed in/out. The issue must be with my particular content because it affects 3 different Apple TVs.
     
  11. Cell-666 macrumors 6502a

    Cell-666

    Joined:
    May 3, 2011
    #11

    And how do your purchase show on an iOS device when using the TV app? As you said it should like some account problem.
     
  12. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #12
    The TV app on IOS works fine. It is TV OS 12 that is broken. This worked fine in TV OS 11.
     
  13. Cell-666 macrumors 6502a

    Cell-666

    Joined:
    May 3, 2011
    #13
    Just reading back to your original post, how come you don't have access to your 4K movies anymore? Your purchases which are in 4K should still be in 4K. TV app just groups them together under the movie section.
    Have you actually called Apple? Or make an appointment at your local Apple store and take a unit down to show them.
     
  14. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #14
    I only care about the TV app because of the 4K grouping. I no longer have that but the movies/TV shows are still in the individual apps. But I want the 4K and HDR section back. I have been working with Apple for the past 5-6 months, ever since I first discovered the issue. I even sent their engineers my logs twice. How they have not been able to resolve it in all this time is baffling. Every time they release an update I look to see if it is fixed. I know I am not the only one affected by this issue.
     
  15. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #15
    This is what I see on the app:
     

    Attached Files:

  16. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #16
    Yes, that's what it's supposed to look like. All I see is a blank screen saying 'You don't own any videos'
     
  17. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #17
    It's very strange that you don't see what I see.

    I've never had a beta release on my ATV 4k and it's running the latest release of tvOS.
     
  18. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #18
    My mother has a brand new Apple TV 4K with the same issue I have (she's logged into my account). And then an Apple TV 4 with my account has the same issue. So I know it's related to my account somehow. Other users experiencing the same issue think it has to do with large libraries. I have over 2500 movies and about 500 TV shows.
     
  19. Audit13 macrumors 68040

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #19
    Wow, that's a lot of movies and that right there could be the problem.

    The only reason I have purchased movies is because the iTunes code was included with my disc.
     
  20. Cell-666 macrumors 6502a

    Cell-666

    Joined:
    May 3, 2011
    #20
    It is odd. So, this is an ATV4K connected to a 4K TV?
     
  21. cmleblanc thread starter macrumors newbie

    Joined:
    Oct 30, 2018
    #21
    Yes, this problem started during the beta of TV OS 12. I first reported it to Apple then and they thought it would be corrected when TV OS 12 was released. So they've know about this for many months now but have not resolved it, maybe it's not affecting enough people for it to be a priority.
     

Share This Page