TvOS 11 doesn’t turn on my TV

Discussion in 'Apple TV and Home Theater' started by comics addict, Sep 19, 2017.

  1. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #1
    I just updated to the public release of tvOS 11. My 4K TV is HDMI-CEC compatible which worked flawlessly on tvOS 10 with turning on/off TV+aTV, switch inputs and control volume on TV. However since update if to tvOS 11 my Samsung smart TV no longer turns on the TV when I turn on my aTV but can still control audio and turn the TV off via the aTV. As anyone else experienced this?
     
  2. Rigby macrumors 601

    Joined:
    Aug 5, 2008
    Location:
    San Jose, CA
    #2
    CEC power on/off still working fine here with my Sony TV. Have you tried restarting the ATV? That has solved CEC issues for me in the past.
     
  3. comics addict thread starter macrumors 6502a

    Joined:
    Feb 16, 2013
    #3
    Thank you. That seems to have fixed it. :)
    I was worried there for a second that that was something that got changed.
     
  4. boston04and07 macrumors 65816

    boston04and07

    Joined:
    May 13, 2008
    #4
    Hey guys - having the same issue here. Now I’m finding that waking up one of my Apple TV 4s doesn’t wake up the attached TV when I’m using the remote app on my iPhone or iPad, whereas before the tv did wake up that way. It still does wake up from my Siri remote. And, strangely, my second TV (which is also connected to an Apple TV 4) does wake up when I wake up the connected Apple TV via my remote app.

    I’ve tried restarting the misbehaving Apple TV but it’s still not working. Strangely, when I put its connected Apple TV to sleep, this tv shuts off just fine. The only issue is waking up the Apple and not having the TV itself come back on...

    I’ve also tried toggling on/off the option in settings to turn on the TV via the remote, but that hasn’t done anything. If anyone has any ideas I’d greatly appreciate it...if not I’ll just try wiping and reinstalling the os tomorrow. I swear this was working not too long ago...
     
  5. ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #5
    I often find that an auto-update has happened in the background when the TV has been off. This seems to be the root cause of the CEC suddenly not working. Turning the Apple TV off and on again fixes the issue.
     
  6. NFriis macrumors newbie

    NFriis

    Joined:
    Oct 4, 2017
    #6
    After tvOS 11 my receiver keeps choosing the wrong hdmi channel. If I change it to the correct one it just goes back to the wrong one. Pulling out the hdmi cable from the Apple TV and then changing channel works fine. Then it stays.. I tried changing input in the receiver, does not help. I tried restarting Apple TV, both with force (menu and tv button) and in the settings.
    Next step will be trying to recover tvOS 10, hopes this helps. It worked 100% before 11.
    Any other suggestions for my problem?
     

Share This Page

5 September 19, 2017