Two known WIFI access points...iPad keeps swapping to one I don't want

Discussion in 'iPad' started by somerandomusern, Aug 16, 2010.

  1. somerandomusern macrumors newbie

    Joined:
    Aug 11, 2010
    #1
    Hi,

    I have an ipad for work purposes. In our office there are TWO wireless access points.

    I have entered the passwords for both so I can use either. The problem we are having (this is affecting both the ipads we have in the office) is I will choose the AP i want to be connected to, this AP is on the main LAN so I can surf from the ipad to my development web server.

    The problem is the ipad will randomly (and often) swap to the other AP. This AP is just connected to an ADSL modem and it NOT on our LAN. So once the ipad swaps I sit there waiting for my web pages to load until I am informed the Safari cannot find the server. At this point I will go into the ipad settings and see that it has connected to the other AP.

    Why is this happening? Better - how do I stop it happening (short of forgetting one of the AP's). This isn't a solution it's an annoying workaround.

    Any ideas why it drops the first AP? Any ideas why it doesn't rejoin the first AP?

    Cheers,
    Scott

    I really want to understand what is happening here. If you need further clarification let me know and i'll attempt to explain better.
     
  2. 3lionsbecks Suspended

    3lionsbecks

    Joined:
    Jul 19, 2010
    Location:
    Ontario, Canada
    #2
    I believe the iPad will automatically switch to the 'stronger' signal without letting you know so that is the problem.

    Sorry that I don't have a solution other than 'forgetting' the one you don't want like you already mentioned.
     
  3. somerandomusern thread starter macrumors newbie

    Joined:
    Aug 11, 2010
    #3
    Thanks for the feedback

    Hey thanks for getting back to me with your ideas.

    Here is some more (interesting) info about this situation.

    1. We recently noticed that this issue was not limited to the iPads. One of the WIFI Apple laptops did this Access Point swap the other day. Trying to see if we can get one of the WIFI windows OS machines to do this also (trying = logging in, selecting main LAN AP and then checking at the end of the day whether still connected to LAN AP or whether it's swapped to ADSL AP). So far just limited to Apple OS.

    2. Generally the LAN AP shows 3/3 bars (iPad signal strength) and the other one shows 2/3 bars. If I walk around the office there are only a few spots where the LAN AP drops to 2/3 bars. I can even get 1/3 bars when out side the office in the car park - at this point the other AP disappears. I have been told that the LAN AP broadcasts a very strong signal so I would be surprised if the other AP was ever the 'strongest'.

    3. I don't know if the iPad updates itself secretly but the initial problem seems to have been resolved. What I now see happen is this...will be using the Safari browser, the screen will darken and a Connecting... popup displays, after 5-10 seconds it fades out, immediately followed by another Connecting... popup, after 5-10 seconds it fades out, the sceen lightens back up and then Safari resumes. The good news is that I'm still on the initial AP I selected. ( These connecting popups are annoying but nowhere near as much as being secretly swapped to a different AP when I never left the original one ).

    Cheers,
    Scott
     
  4. cRuNcHiE macrumors 6502a

    Joined:
    Jan 2, 2007
    #4
    On your Macbook you can eliminate this problem by doing the following:-

    Goto System Preferences
    >Network
    >Airport
    >ADVANCED
    Then drag the preferred network higher than the one you don't want.

    The iPad doesn't have the same option though im afraid so as a workaround i'd just tell it to forget the wifi network you don't want.
     
  5. Capt T macrumors 6502a

    Joined:
    Mar 20, 2010
    #5
    Settings - Wi-Fi - click on the blue > for the network you don't want to connect to - click on Forget this Network at the top. Later if you want to join that network you can choose it but will need to forget it again if you don't want it to connect automatically to it. I know you think it is annoying but it seems it is the only choice for now. I would also suggest leaving feedback for Apple.
     
  6. panzer06 macrumors 68030

    panzer06

    Joined:
    Sep 23, 2006
    Location:
    Kilrath
    #6
    This^ Works perfectly if you want to get rid of less reliable connections.

    Cheers,
     

Share This Page