Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Two Watches - Alarm going off on watch being charged

ckurt25

macrumors 65816
Original poster
Mar 25, 2009
1,024
359
Grand Rapids, MI
I have two Apple watches. A Series 5 and a Series 3. Both running 7.0.2. My iPhone 11 Pro is running 14.0.1. I will first say that I only upgraded the S3 to 7.0.2 two days ago. The S5 was upgraded to 7X a while ago. I usually wear the S5 during the day and sleep with the S3 on but occasionally sleep wearing the S5. For the past week or two I've noticed when the S5 is on the charger at the time my alarm goes off (using the native alarm from the phone) that the alarm on the S5 goes off. This morning the S3 was on the charger and it went off.

Regardless if I hit snooze or stop on the watch I'm wearing or my iPhone, the alarm on the watch on the charger continues to go off until I snooze or stop it. The charging watch seems to be doing its own thing. I can hit stop on that watch after hitting snooze on my iPhone and the snooze isn't impacted.

Anyone have any similar experience or idea how to fix it?
 

Graham4723

macrumors member
Jan 24, 2018
66
11
You’ve setup two, independent, alarms on two watches.
The watches are not dependent on a connection to your iPhone in this case.
Both watches are operating as I would expect, imagine if you did the same with 2 alarm clocks !
You’ll have to learn to switch off the alarm on the watch you’re not wearing to sleep at bedtime.
Either that or decide which is going to be your ‘sleep’ watch.
 

ckurt25

macrumors 65816
Original poster
Mar 25, 2009
1,024
359
Grand Rapids, MI
You’ve setup two, independent, alarms on two watches.
The watches are not dependent on a connection to your iPhone in this case.
Both watches are operating as I would expect, imagine if you did the same with 2 alarm clocks !
You’ll have to learn to switch off the alarm on the watch you’re not wearing to sleep at bedtime.
Either that or decide which is going to be your ‘sleep’ watch.

I've had two watches for YEARS. Since the Series 3 came out. Back then I had 1 & 3. I replaced the 1 with the 5 when that came out. This issue NEVER happened in the past. Only when Watch OS 7 / iOS 14 came out did this start to happen. This isn't existing behavior. This is something new introduced with the latest operating systems.

Edit: I can appreciate your perspective but this isn't how it's worked for 4+ years and it appears the introduction of the new OSs has caused this and other watch alarm issues to pop up. A google search will return hits on threads of other alarm issues, all tied to the new OSs.

I'm going to make sure the Sleep settings on both watches are turned off and see if that helps.

The Apple Watch has always been an extension of the iPhone it is paired with. The phone watch on the charger doesn't ring when my phone rings so I wouldn't expect an alarm to go off either. Especially one that is set on the phone and when it hasn't done this for years leading up to the software updates.
 
Last edited:

DanShockley

macrumors newbie
Sep 24, 2008
10
0
I have two Apple watches.

Regardless if I hit snooze or stop on the watch I'm wearing or my iPhone, the alarm on the watch on the charger continues to go off until I snooze or stop it. The charging watch seems to be doing its own thing. I can hit stop on that watch after hitting snooze on my iPhone and the snooze isn't impacted.

Anyone have any similar experience or idea how to fix it?

I've experienced the exact same thing. My old S3, which I kept as a backup, is sitting in my office next door to my bedroom. When I snooze the S6 I'm wearing most of the time (including while sleeping), the S3 alarm keeps going and gets louder and louder, to the point where I can hear it loudly from the next room.
I found a post in the sub-Reddit r/AppleWatch that explains how to keep a Watch from getting the alarms and timers set on the iPhone:
https://www.reddit.com/r/AppleWatch/comments/jd00h5 Basically, while wearing the "do not want alarms" Watch, go to the Watch app on the iPhone, go to Clock, then disable "Push Alerts from iPhone"
I'm trying that tonight myself, and hopefully it will work.
It does mean that Watch also will not alert you about timers set on the iPhone, but that didn't matter to me.
 

ckurt25

macrumors 65816
Original poster
Mar 25, 2009
1,024
359
Grand Rapids, MI
@DanShockley I can say I've successfully solved my issue. Hopefully it can work for you. On my iPhone and while wearing one of the watches, I go to Watch > Sleep and disable Sleep for that watch. I repeat for the other watch.

This morning my alarm went off on my phone while I was wearing my S5 and holding my phone. Only the phone alarm went off. I hit snooze and when the snooze went off later, I had put the phone down and both the phone and S5 alarm went off and I could stop / snooze from the watch. The S3 on the nightstand & charger never went off.

I will add that I use the AutoSleep app for sleep tracking so turning off Sleep on the watches wasn't a big deal. Maybe Apple will fix this bug in a future update.
 
  • Like
Reactions: DanShockley

DanShockley

macrumors newbie
Sep 24, 2008
10
0
@DanShockley I can say I've successfully solved my issue. Hopefully it can work for you. On my iPhone and while wearing one of the watches, I go to Watch > Sleep and disable Sleep for that watch. I repeat for the other watch.

This morning my alarm went off on my phone while I was wearing my S5 and holding my phone. Only the phone alarm went off. I hit snooze and when the snooze went off later, I had put the phone down and both the phone and S5 alarm went off and I could stop / snooze from the watch. The S3 on the nightstand & charger never went off.

I will add that I use the AutoSleep app for sleep tracking so turning off Sleep on the watches wasn't a big deal. Maybe Apple will fix this bug in a future update.

I had to do the same thing for the S3 (disable Sleep entirely), where I didn't want the Sleep alarm to sound. The "Push Alerts from iPhone" method I linked to above turned out not to help. But, I did keep the Sleep feature turned on for my S6.
 

techtechtech

macrumors member
Nov 9, 2017
90
102
UK
Same issue here with Series 3 and 6 for that matter, assume a bug which will hopefully be resolved, previously my two Series 3 watches played together fine. Since I now use the Series 3 mostly just for sleeping I have disabled 'Sleep' on the Series 6 which should resolve things.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.