Ubuntu Killed My MacBook?

Discussion in 'Mac Basics and Help' started by kwanbis, Nov 21, 2009.

  1. kwanbis macrumors newbie

    Joined:
    Mar 1, 2008
    #1
    I have a prev gen macbook (non unibody), that came with Leopard 10.5.

    I bought the Snow Leopard 10.6 ugprade, and i installed it.

    All was fine. No problems. Restarted many times.

    Today i had to burn a copy of Ubuntu 9.10.

    I burned it, and restarted the macbook to test the burn.

    I turned on with the C key, and ubuntu started. It asked for language, and then if if i wanted to try or install.

    I choose try, and it go on to start, but the macbook would hang.

    So i turned off, and then on, expecting to see OSX 10.6 again.

    The macbook started loading, and then the NO/Forbidden sign.

    I tried to boot using again C key with the snow leopard 10.6 upgrade DVD, but the Macbook would try to boot from the DVD, and then same problem as above (forbidden sign).

    I then tried to boot with the Leopard 10.5 install DVD, but again, and again forbidden sign.

    I tried the apple-option-p-r to reset the mac, and then i tried to boot again with Leopard install dvd, and same problem.

    I tried booting with D key, but nothing happens (meaning it tries to boot from the HD, instead from the DVD).

    I tried to boot again with ubuntu, and it starts and then hungs.

    I booted on verbose mode, and more or less this is all i see (edited):

    ...
    Waiting on dict id=0 ioproviderclass string id=1 ioresourcematch string id =2 boot-uuid-media
    ...
    the iousbfamilly is having trouble enumerating a usb device that has been plugged in it will keep retrying port 4 of hub @ location 0x24000000
    ...
    still waiting for toot device
    ...
    the iousbfanumly was not able to numerate the device

    Any ideas? I have no accessories connected to my macbook. Nothing on the USB.
     
  2. someguy macrumors 68020

    someguy

    Joined:
    Dec 4, 2005
    Location:
    Still here.
    #2
    Ubuntu cannot, and did not kill your MacBook.

    What do you have plugged in to the USB ports on your Mac?
     
  3. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #3
    Boot and hold shift down to see if you can force it into safe mode.
    or

    Try powering on an pressing X to force it into OSX

    any luck with those?
     
  4. kwanbis thread starter macrumors newbie

    Joined:
    Mar 1, 2008
    #4
    SOLUTION: Somehow, booting with the ALT/COMMAND, and then selecting the 10.5 installer DVD, worked, while booting the Macbook by pressing C did not (i still wonder why).

    Once there, i followed this advise, to repair the bootloader:

    Anyway, the fix turned out to be easy with Disk Utility (and probably possible from the OS X boot disc). Run Disk Utility and click on your internal hard disk (the disk itself, not the partition under it). Then click on the Partition tab. If you move the triangular slider that adjusts the partition up and then back to where it was, the "Apply" button becomes active (it starts greyed out). You can now click "Apply," and the partition will be left alone, but the bootloader will be recreated.
     

Share This Page