Ugh, plz help. iPhone 4 makes double text alert sounds.

Discussion in 'iPhone' started by amazingdm, Dec 12, 2011.

  1. amazingdm macrumors 6502

    Joined:
    Jul 2, 2010
    #1
    Ok just got like my 19th iPhone 4 replacement the other day. This one seems to have a weird problem where if someone texts me it makes the text message alert sound twice in a row. Or if a facebook alert comes through it makes the sound twice. NO I'm not talking about the "alert a second time if you don't check it in a minute" thing I mean RIGHT away.
     
  2. ET iPhone Home macrumors 68040

    ET iPhone Home

    Joined:
    Oct 5, 2011
    Location:
    Orange County, California USA
    #3
    I guess I'd go back for the 20th time if it bothers you that much. Or were you thinking that it be embarrassing to go for the 20th time? Try and go to a different Apple store.
     
  3. thatoneguy82 macrumors 68000

    thatoneguy82

    Joined:
    Jul 23, 2008
    Location:
    Beach Cities, CA
    #4
    Wow? 19? Really? Maybe they decided to give you the crappy, problematic ones since they figured they'll see you again.
     
  4. ReliableSource macrumors newbie

    Joined:
    Nov 29, 2011
    #5
    This was happening to me as well, at the beginning of all my alerts the tone would stutter and start over. I'm not sure of the cause, but after a kernel panic my phone erased all of its music and wouldn't sync with iTunes anymore, so I did a restore and everything went back to normal, alert tones included.
     
  5. jmjoh122 macrumors member

    jmjoh122

    Joined:
    Oct 8, 2011
    Location:
    VA
    #6
    I noticed that mine was doing the same thing. I just figured that the next time that I had to update the firmware that the problem would be fixed.
     
  6. Smoothie macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    There's a "repeat alert" setting under "notifications." Uncheck that.
     
  7. DroidRules macrumors 65816

    Joined:
    Aug 10, 2010
    #8
    Annnnnd the reply without reading the entire post award goes to???????
     
  8. ApplesAndOrangs macrumors regular

    Joined:
    Sep 30, 2011
    #9
    This was happening to me with texts. Someone posted this on the other forum, it worked for me:

    1)Turn iMessage off in settings
    2)Power off your phone and then turn it on.
    3)Send a txt to yourself, and press the home button immediately.
    4)Go into settings, turn on iMessage.
    5)Send a txt to yourself again, should be fixed.

    That fixed it for me. Not sure which step fixes it, too lazy to test it out. So just followed it all.
     
  9. aphexacid macrumors 6502a

    aphexacid

    Joined:
    Jul 31, 2007
    Location:
    Chicago
    #10
    this happened to me once. all i did was close all apps from the task manager and reboot. never happened again.
     
  10. Certinfy macrumors 6502a

    Certinfy

    Joined:
    Jan 29, 2011
    Location:
    London
    #11
    This. Maybe the genius working there has a crush on you or something. :rolleyes:
     
  11. Smoothie macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #12
    Justly deserved. This is what happens when I respond to a post from my iPhone at 3:00 a.m.
     
  12. parseckadet macrumors 6502a

    parseckadet

    Joined:
    Dec 13, 2010
    Location:
    Denver, CO
    #13
    Just restarting my phone resolves this for me. It will come back after a couple weeks, but then I just restart again.
     
  13. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #14
    Bug in iOS5. My first 4S did this, returned it for a 32GB. My 32GB did it for a week then stopped by itself.

    Never touched any settings but it was annoying.
     
  14. amazingdm thread starter macrumors 6502

    Joined:
    Jul 2, 2010
    #15
    I never went to the apple store?

    Anyway it's not doing it today. Weird.
     
  15. DroidRules macrumors 65816

    Joined:
    Aug 10, 2010
    #16
    I work night shift so I'm always wide awake at 0300 :eek: OK maybe not wide awake lol.
     
  16. amazingdm thread starter macrumors 6502

    Joined:
    Jul 2, 2010
    #17
    I think restarting the phone must have fixed it but at least I'm not crazy.

    Also I was exaggerating about the 19th iPhone but not really

    - Got iPhone 4 on launch day
    - 8-10 months later, because of serious home button issues, called Apple and set up an advanced replacement where they send me a new/refurb iphone first then I send in my original iphone (they authorize like $700 on my credit card but take it off if I send original iPhone in).
    - Immediately sent that ^ one back because it was all scratched up when I got it so they sent me a different one.
    - Did another exchange recently because of more home button issues.
    - That ^ one had a huge speck of dust on the camera's sensor so they exchanged it again.
     
  17. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
  18. jasonsep macrumors newbie

    Joined:
    Jan 11, 2012
    #19
    Apples and Orangs solution works

    This was happening to me with texts. Someone posted this on the other forum, it worked for me:

    1)Turn iMessage off in settings
    2)Power off your phone and then turn it on.
    3)Send a txt to yourself, and press the home button immediately.
    4)Go into settings, turn on iMessage.
    5)Send a txt to yourself again, should be fixed.

    That fixed it for me. Not sure which step fixes it, too lazy to test it out. So just followed it all.

    The poster Apples and Orangs solution works! Thanks for the info!
     
  19. gagandeep90 macrumors newbie

    Joined:
    May 29, 2012
    #20
    There is a fix posted for this issue where you do not need to turn of vibrate or turn of view in lock screen. Go to the following link to read it. http://iostricks.com/double-text-message-ringtone-fix-iphone-4s-and-iphone-4-131
     

Share This Page