UIPickerView not responds to touches in certain places

Discussion in 'iOS Programming' started by roeik, Feb 9, 2012.

  1. roeik macrumors member

    Dec 25, 2008
    After a very long time I am updating an iPhone app to iOS5 version.
    I have a picker view with 4 columns, which worked normal until now.

    Now, for some reason, the touch behaviors seems to be buggy.

    My pickerview has 4 columns and 5 rows, so I have two rows above the middle row with the selection indicator, and two rows below it.

    the portion of the pickerview above the middle row is not responding to touches, unless the touch is at the upper border or on the border with the selection row (middle row). Any touch anywhere in the middle between this border in unrecognizable.

    The lower portion of the pickerview, i.e. the bottom two rows below the selection indictor, are behaving normally (no matter where i touch the picker responds to touch).

    I have tried both approaches of setting up the pickerview (i.e. though interface builder and programmatically, didn't change). I also changed the deployment and development in the Document Versioning of the xib to Xcode 4.2 and iOS5.

    Any idea what can cause this bug?
  2. roeik thread starter macrumors member

    Dec 25, 2008
    The problem was another subview. Removing it fixed the problem.

Share This Page