Unable to authenticate in System Preferences

Discussion in 'macOS High Sierra (10.13)' started by jake_T, Aug 7, 2017.

  1. jake_T macrumors newbie

    Joined:
    Aug 7, 2017
    #1
    Hi all,

    I've tried searching for this issue but can't find any mention of it anywhere.

    Since installing the High Sierra beta I have been unable to unlock any pane in System Preferences, it won't accept my credentials (it shakes as if they are incorrect). All other authentication seems to be working fine, e.g. I can install software, change file permissions etc.
    I tried logging in as root and unlocking the Security & Privacy pane, same thing happens. I've noticed a "loginwindow is not entitled" message in console every time I attempt to authenticate in System Prefs.

    I have tried running First Aid but no issues are found. I converted to APFS during install but I'm unsure of the implications of that as far as permissions go.

    Does anybody have any ideas as to what might be causing this?


    Cheers,
    Jake.
     
  2. b416 macrumors newbie

    Joined:
    Jan 20, 2014
    #2
    I have this issue with an account with a changed UID (I put 401 so it does not appear in the login window).
     
  3. intofx macrumors regular

    Joined:
    Jun 7, 2010
    #3
    I had this problem. My user account got corrupted. You need a second admin account. I went into my admin account and deleted the corrupted user account > do not change the home folder. Open a finder window goto the users folder > remove (deleted) from the home folder. Create a new user with the exact same name as before > use existing folder. Should be fixed
     
  4. jake_T thread starter macrumors newbie

    Joined:
    Aug 7, 2017
    #4
    That’s interesting, I use a standard user account and a hidden admin account with a UID of 401. Has been working this way for a couple of years. Do you only see this in the High Sierra beta?

    I would have thought logging in to root and authenticating with root credentials would do the trick.
    I’m going to try change the UID of my admin account and see if that changes anything.

    Thanks for the info :)
     
  5. LarryJoe33 macrumors 65816

    LarryJoe33

    Joined:
    Jul 17, 2017
    Location:
    Boston
    #5
    Not sure if this might help but this post made me think of this. When I first installed PB1 it told me that it is no longer allowed to use my Apple ID as my lock screen PW. So I changed it. I used the one I changed it to a few times and then out of nowhere it would not take it. After a few tries, I tried my "old" AppleID lock screen pw and it worked. There hasn't been a hint of anything or anywhere in High Sierra wanting this "new" password since. Very strange, but if this is similar for you, maybe try an older password?
     

Share This Page