Unable to connect to AirPort Extreme from certain Macs

Discussion in 'Mac Accessories' started by danduq, May 5, 2011.

  1. danduq macrumors newbie

    Joined:
    May 5, 2011
    #1
    Hi All,

    We had an office powercut a few days ago and since then two of our MacBook Airs are unable to connect to the Airport Extreme base station wirelessly.

    The WiFi is definitely working as several other machines (a mixture of MacBook Pro and Windows 7 Dell's) are able to connect wirelessly to it.

    The two Airs are able to see the network, but are unable to get an IP address. I've tried re-entering the password, checking the encryption type, renewing the DHCP leases, restarting the base station AND the Airs. Nothing seems to work though.

    We're using a linux based DHCP server to dish out IP's, and I've tried deleting the leases for the respective MAC addresses and restarting DHCP, but they are still unable to pick up an IP address.

    Any ideas what to try next?

    Thanks! :)
     
  2. Coolestdude macrumors member

    Joined:
    Mar 22, 2011
  3. danduq thread starter macrumors newbie

    Joined:
    May 5, 2011
    #3
    Tried setting a static IP but it still wouldn't connect. It pops up the password prompt, then upon entering the correct password, it popped up the password prompt again. The password was definitely the correct one, but I reset it on the AirPort just in case.

    The weird thing now is that the machines that were having problems are now saying "Connection timed out" instead of re-prompting for the password.

    The password is still correct as other machines are still able to connect to it. I've re-entered the password on my MacBook Pro too and that still works.
     

Share This Page