'unable to download application'

Discussion in 'iPhone' started by Hudzilla, Jun 5, 2012.

  1. Hudzilla macrumors 6502a

    Hudzilla

    Joined:
    Nov 12, 2007
    Location:
    England
    #1
    I keep getting this notification all the time, can anyone shed any light on what I could do?

    I've tried deleting my apple ID account, signing out, then back in. All to no avail.

    ImageUploadedByTapatalk1338911126.458232.jpg
     
  2. Arnezie macrumors 65816

    Arnezie

    Joined:
    Oct 10, 2011
    #2
    You must have started downloading it and it stopped for whatever reason, delete the app then go to the app store and re download it. It happens when you interrupt a download.
     
  3. Snakeyjake macrumors newbie

    Joined:
    May 9, 2012
    #3
    I've had this too, since I got my 4S. Never had it with 4. If you go to app store and check for updates then press update all this message
    pops up after about 20 seconds. The only fix is to turn airplane mode on and off quickly then try again (so you don't have to sign in and sign out). Incidentally this doesn't happen on my iPad. Both use wifi.
     
  4. lewys macrumors 6502

    lewys

    Joined:
    Jun 18, 2010
    Location:
    London
    #4
    Always happens to me and my friends with about 70% of the apps we download too. The only thing that seems to work is plug it in to the charger and it works.


    Happened on this firmware and the last for us and even restoring doesn't sort it out.
     
  5. AppleMan86 macrumors newbie

    Joined:
    Oct 15, 2012
    #5
    This might help..

    I've been having this issue myself for sometime, only seems to happen while on my Cellular connection, with 2-3 bars (Sprint). My settings are allowing App downloads over cellular connection. After rebooting failed to fix the issue, tried a Hard reboot (held down Home and Sleep buttons until the Apple logo appeared), and that has fixed the issue for me. I hope this helps a few people!!

    :D
     
  6. legreen macrumors newbie

    Joined:
    Jun 29, 2010
    #6
    It's been happening to me for a while now too on my iPhone (was 4 now 5) and my iPad. If it does it a few times I tend to press done and then go back to the app a little later to try downloading again. I get there eventually.
     

Share This Page