Unable to download Beta ,new MacBookPro 2019

Discussion in 'macOS Catalina (10.15)' started by latndude, Aug 2, 2019.

  1. latndude macrumors member

    latndude

    Joined:
    Jul 26, 2012
    Location:
    Fort Myers,FL
    #1
    I just bought a new 2019 MacBook Pro , I was using a 2017 MacBook Pro and Catalina installed without a problem , the public betas. Now in the new computer even if I have enrolled it in the beta programs , it will not download Catalina betas at all . Any hint why ? Thanks
     
  2. floraldo macrumors newbie

    Joined:
    Aug 3, 2019
  3. jdonshik macrumors newbie

    Joined:
    Sep 14, 2006
    Location:
    Hollywood, FL
    #3
    Finally decided yesterday that I would try and run the beta.
    I have a 2018 rMBP and 2017 iMac. Same issue. Cannot download the Catalina beta. Each time I hit software update it says that I am up to date.

    Of note, when the beta first came out (about 4 weeks ago), I didnt want to update. Software update offered me a Catalina upgrade as well as additional builds of 10.14. I clicked on something in the Software update window that I didnt want to upgrade to Catalina at that time. Could this have had something to do with my issue??

    I reinstalled the Mac OS beta software utility on each of the computers and restarted multiple times.

    Still no luck.
     
  4. bogdanw macrumors regular

    bogdanw

    Joined:
    Mar 10, 2009
    #4
  5. floraldo macrumors newbie

    Joined:
    Aug 3, 2019
  6. jdonshik macrumors newbie

    Joined:
    Sep 14, 2006
    Location:
    Hollywood, FL
    #6
  7. Tarek macrumors 6502

    Joined:
    Jun 25, 2009
    Location:
    Liverpool, UK
    #7
    I am currently on 10.14.6 Beta (18G59b) and I am trying to download MacOS Catalina but I am unable to. I tried running this script (unenroll > enroll > fixup / Developer Seed Program) but only the latest Mojave beta update shows up still.
    I tried a different script in the past (not sure if I am allowed to link to it) where you basically download three DMG files (one of which is InstallESD) and then use Terminal to compile and install them but it still kept giving me errors.

    Any ideas on how to fix this? Will I be able to receive the 10.15 Developer Seed update if I actually perform the latest Mojave beta update first?

    Thanks!
     
  8. bogdanw macrumors regular

    bogdanw

    Joined:
    Mar 10, 2009
    #8
    Use the script to switch to Mojave Developer Beta, it might offer you Catalina.
    You can also try running in Terminal
    Code:
    open "x-apple.systempreferences:com.apple.preferences.softwareupdate?installMajorOSVersion=10.15"
     

Share This Page

7 August 2, 2019