Unable to get internet to work on MBP that is connected to WiFi

Discussion in 'MacBook Pro' started by markw10, Nov 21, 2009.

  1. markw10 macrumors 6502

    Joined:
    Sep 4, 2006
    #1
    I have a MacBook pro that I'm having issues with. It connects to my home Wi-Fi (the n version of the Apple Airport Base Station) and I get a strong signal but whether I use Firefox or any other web browser or internet based program I get a message that I'm not connected to the internet.
    I can even select network diagnostics and it walks me through steps where I choose my network, reset my cable modem, base station, etc. and at the end it says it is unable to fix the problem.
    i have a 2nd MBP that I use on the same network with no issues at all. This issue started showing up about a month ago but did not happen often. Most of the time it happened when I had shut my MBP down since I had to go take it with me to meetings. Often after removing the battery for a minute I could boot up and it would work but now no matter what I do it won't work.
    Any ideas of what could be causing this? I know I may have to go to the genius bar to have this looked at but hope to avoid it. Is there any other troubleshooting I can do? Thanks for your help.
     
  2. rowsdower macrumors 6502

    Joined:
    Jun 2, 2009
  3. Nano2k macrumors regular

    Joined:
    Nov 6, 2009
    Location:
    Europe
    #3
    Have you tried moving around? My MBP 15 is the first laptop ever that does not work on my desk but still gives me full wifi signal strength and no actual data coming through. I ended up having to relocate my access point...

    it worked for a couple of hours before this happened...
     
  4. markw10 thread starter macrumors 6502

    Joined:
    Sep 4, 2006
    #4
    I just tried it at a neighbor's house today on his wi-fi which is actually unprotected and it still didn't work so seems it's related to the MBP, not my Wi-Fi. Also, that involved moving it around a lot so seems that didn't resolve it either. Is it possible it's a hardware problem?
     
  5. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #5
    What do your Airport network settings look like?

    IP Address? DHCP or Manual

    DNS Server?
     
  6. yaddam205 macrumors member

    Joined:
    Mar 20, 2008
    #6
    Mine is having the same erratic issue. Physically resetting the router worked for me.
     

Share This Page