Unibody macbook playing echo-y mono audio in OS X but not in Windows

Discussion in 'Mac Basics and Help' started by blue02, Jun 26, 2009.

  1. blue02 macrumors newbie

    Joined:
    Jun 26, 2009
    #1
    I've had a unibody Macbook for about six months now, and love it - the only problem is that recently I've noticed that the audio is no longer in stereo. At first I thought it might be my headphones, so I tried a set of new iPod headphones, a pair of Sony regular ones, and two sets of external speakers - no luck.

    Basically, the machine seems to be "blending" the stereo channels. I first noticed it in songs that have guitar in one ear only, for example. I tested it by opening a mp3 in Audacity, stripping out the left channel, and playing it in both VLC and iTunes. In both cases, the channel I kept played fine, but the other one also played the audio, albeit a little softer and with some echo. If I had to describe it, I'd say that it sounded like a set of speakers that are hooked up out of phase. It happened the same on the other headphones and on external speakers.

    The weirdest part is this: the sound is fine in Windows. I figured that it had to be software, and did an archive+reinstall of Leopard last night. When the computer first started, it was fine (the sound was back to normal). However, I then ran system update overnight (which upgraded to 10.5.7, among other things), and in the morning, the audio was back to echo-y mono.

    What could this possibly be? I really doubt that it's the software update, else other people would have heard of this problem, too. I don't have any crazy software installed (in fact, i did a complete reformat two weeks ago, so the system is "fresh"). Right now, I have firefox, VLC, skype, thunderbird, transmission, and AppDelete installed - and that's about it. Any ideas as to what my next step should be?

    Thanks!
     
  2. AJ OK macrumors newbie

    Joined:
    Jul 8, 2009
    #2
    i have EXACTLY the same problem as you! identical.

    Sounds are suddenly 'monoey' in all apps, and all audio has this annoying split second echo attached, which ruins the system for the purposes i use it for (music production on the road). but windows is fine. did an archive and install, problem still remains.

    i have noticed that the macbook speakers don't seem to have the echo (though they aren't very loud so my ears may be deceiving me).

    The only remote possibility i can think of is that me installing windows on bootcamp has somehow affected the audio functioning in os x?? as far as i can remember the audio was ok before i did this (although it's really impossible for me to pinpoint as i didn't use the macbook for about a month before i put bootcamp on).

    almost 2 hours on the phone to level 2 support and still no joy on this.

    Anyone else???
     
  3. twolfe111 macrumors newbie

    Joined:
    Nov 5, 2009
    #3
    I've got the same problem. Mine started about three days ago and its really quite frustrating.

    Not to destroy anyone's theory, but my macbook had windows xp on it, but then i replaced the hard drive and never replaced boot camp or windows.

    I don't know what caused this, but any help would be great!
     

Share This Page