Unlock Iphone 3G 3.1.3(just bought it) with iTunes 9.1 on my mac?

nik92

macrumors newbie
Original poster
Apr 7, 2010
5
0
So i just bought an iPhone 3G at the at&t store and would like to use it with a different carrier, it has firmware 3.1.3 on it and i have iTunes 9.1 on my mac, i've been looking all over for an answer but everyone just seems to be talking about the iPhone 3GS or the iPad >_< i really don't wanna break it or do anything before i'm sure it'll work..
I've had a jailbroken iPhone (first generation) before and unlocked it many times, but as it broke a few months ago I'm totally not up to date now..

Please help, Thank you!
 

luvu01

macrumors regular
Mar 7, 2010
104
0
So i just bought an iPhone 3G at the at&t store and would like to use it with a different carrier, it has firmware 3.1.3 on it and i have iTunes 9.1 on my mac, i've been looking all over for an answer but everyone just seems to be talking about the iPhone 3GS or the iPad >_< i really don't wanna break it or do anything before i'm sure it'll work..
I've had a jailbroken iPhone (first generation) before and unlocked it many times, but as it broke a few months ago I'm totally not up to date now..

Please help, Thank you!
There is no way to unlock for your version 3.1.3 right now
 

nik92

macrumors newbie
Original poster
Apr 7, 2010
5
0
so basically fml >_<
so when is the jailbreak gonna be released though? according to what i read they probably have it ready but are just waiting on iphone OS 4? and wasn't there an apple event about that today?
i really hope it's not gonna take too long because right now i can't use my iphone, i only have a german o2 sim card which i will have to use with it..
 

lamina

macrumors 68000
Mar 9, 2006
1,752
41
Niagara
I'm not sure this is entirely true. I accidentally updated my firmware and was able to downgrade my baseband and OS to 3.1.2 google it.
 

nik92

macrumors newbie
Original poster
Apr 7, 2010
5
0
it seems in order to downgrade i have to have cydia on it but i don't since it's new and not jailbroken and apparently there's no way to jailbreak 3.1.3 ... :(
 

pixelated

macrumors 6502a
Oct 21, 2008
713
0
it seems in order to downgrade i have to have cydia on it but i don't since it's new and not jailbroken and apparently there's no way to jailbreak 3.1.3 ... :(
You CAN jailbreak the 3G on 3.1.3. You CAN'T unlock it .
With a brandnew 3G you won't be able to downgrade the baseband , even jailbroken.
 

luvu01

macrumors regular
Mar 7, 2010
104
0
You CAN jailbreak the 3G on 3.1.3. You CAN'T unlock it .
With a brandnew 3G you won't be able to downgrade the baseband , even jailbroken.
Yes. Using redsnow to jailbreak or maybe pwnage but since redsnow does not restore and its faster. You cannot unlock though
 

lokster

macrumors 6502
Feb 7, 2010
364
2
you CAN jailbreak a 3g, with redsn0w using the 3.1.2 firmware

you CAN unlock it after jailbreaking by downgrading the baseband with FUZZYBAND from cydia. IF your bootloader model is 5.08
 

luvu01

macrumors regular
Mar 7, 2010
104
0
you CAN jailbreak a 3g, with redsn0w using the 3.1.2 firmware

you CAN unlock it after jailbreaking by downgrading the baseband with FUZZYBAND from cydia. IF your bootloader model is 5.08
he said brand new! cannot be bootloader 5.08
 

nik92

macrumors newbie
Original poster
Apr 7, 2010
5
0
So does anyone have any news on what the release of the new OS might've changed in my situation? Can I unlock my iPhone 3G 3.1.3 now?
I've been using it as an ipod touch basically..
 

lokster

macrumors 6502
Feb 7, 2010
364
2
well there is a way to unlock now, ultrasnow has been updated, i forgot how lucky i was, my 3g broke and when i got the replacement the BOOTLOADER was 5.08! not only is this a 2 month old thread, but there has been new updates to unlock. 3g is probably the most flexible to unlock and jailbreak compared to 3gs and iphone 4