Unlocked iPhone 3G on TMobile - SMS out of order?

Discussion in 'Jailbreaks and iOS Hacks' started by LissiSays, Jul 28, 2009.

  1. LissiSays macrumors member

    Joined:
    Jun 22, 2009
    Location:
    Miami, Florida
    #1
    Hey all. I had an iPhone 3G w/ 3.0, jailbroken, unlocked and on TMobile. It had a problem and I ended up getting a new one through Apple since it was still under warranty.

    All of a sudden, this one is not putting my SMS texts in the right order. I'll have a text from 11:01pm appearing before a text at 11:05pm (from different people). In other words, it won't display the most recent on top, sometimes.

    Does anyone know what is going on?

    I googled the problem and saw that this happened with a much older firmware (1.1.3). But I don't understand why this is happening now with this phone and not the one I had before that.
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    It's okay. That happens to me too. I think it is just a bug. I just ignore it or force quite the Messages app, and it sometimes fixes the problem. You aren't the only one with that problem. :p
     
  3. LissiSays thread starter macrumors member

    Joined:
    Jun 22, 2009
    Location:
    Miami, Florida
    #3
    Force quit? This isn't with a 3rd party app. This is with the original SMS texting on the phone.

    I've read something about the times being different on the phone and the network but there is no option to automatically set it and it was never an issue before....
     
  4. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #4


    Regardless of whether it's stock or not, you just need to go into messages, and then hold down the lock button until you see the power slider and let go, and then you want to hold down the home button until the app closes.
     
  5. LissiSays thread starter macrumors member

    Joined:
    Jun 22, 2009
    Location:
    Miami, Florida
    #5
    Anyone else have this problem and/or any suggestions/solutions?
     
  6. iPhone Addict macrumors 6502

    Joined:
    Jun 18, 2009
    Location:
    San Francisco, CA
    #6
    I've noticed the same problem on my 3GS and on my friend's 3G. Both running FW 3.0

    Don't know of any fix to it, just hoping Apple knows about it.
     

Share This Page