Unlocked my phone and saw this suspicious alert. Can anyone tell me what this is?

Discussion in 'iOS 7' started by g35, Sep 7, 2013.

  1. g35, Sep 7, 2013
    Last edited: Sep 7, 2013

    g35 macrumors 6502a

    Joined:
    Dec 13, 2007
    #1
    Wasn't sure whether to post this in the iOS or iPhone forum, so please forgive me if it's in the wrong spot.

    I unlocked my phone just now to find this alert on my screen. I'm on an unsecured Wifi network (that has a login page) but never been jailbroken or installed emulators or anything shady, and do have a developer account. And the Wifi network had not been logged into, so there was no internet access, only intranet (I think??). Also cellular data and bluetooth were turned off. I haven't tried to disable iAds or install any unsigned certificates or anything of the sort. I don't see any crash logs for the past few hours (latest was Safari at 6AM)

    In the last day I have installed Instagram, in the last week or so I've installed Jasmine, IFTTT, Kindle, and Bandits racing which I thought were all pretty reputable and well-known apps. This is on iOS 7 beta 5 but I didn't think beta 6 included any security fixes, just the iTunes downloading fix? In the last day I have also enabled a bunch of iCloud features...could that have something to do with it? Enabled everything except Mail, Contacts, Calendars and Notes because I have those syncing with my email.

    Should I be concerned? What steps, if any, do I need to take now?
     

    Attached Files:

  2. user-name-here macrumors 65816

    Joined:
    Aug 31, 2013
    #2
    Me personally I'd restore my phone to factory settings with iTunes if I saw something like that.
     
  3. j4zb4 macrumors 6502a

    j4zb4

    Joined:
    Oct 15, 2011
    #3
    ^^ Correct...

    Fresh re-install is what I would do...
     
  4. towg macrumors regular

    Joined:
    Jul 9, 2012
    Location:
    Cardiff
    #4
    Indeed - then set it up as a new iPhone in iTunes rather than restoring from a backup. Just to be sure.
     
  5. g35 thread starter macrumors 6502a

    Joined:
    Dec 13, 2007
    #5
    Thanks for the advice. I will do a fresh restore.
     
  6. jk111 macrumors regular

    Joined:
    Oct 12, 2007
    #6
    I would recommend changing your icloud / iTunes account passwords as well. Better safe than sorry.
     
  7. dannyyankou macrumors 604

    dannyyankou

    Joined:
    Mar 2, 2012
    #7
    It's a bug. Same thing happened to me when I tried to update my apps. Wouldn't be too concerned, but maybe you should restore just incase.
     
  8. g35 thread starter macrumors 6502a

    Joined:
    Dec 13, 2007
    #8
    I'm glad to see i'm not the only one. But how do you know it's a bug? I couldn't find anyone else mentioning this situation on the internet (which I guess is evidence neither in favour of or against it being a bug)
     
  9. dannyyankou macrumors 604

    dannyyankou

    Joined:
    Mar 2, 2012
    #9
    I didn't read your whole first post. I thought you just meant your apps weren't downloading. Your issue sounds like more than a bug...
     
  10. adam044 macrumors 65816

    adam044

    Joined:
    Jan 24, 2012
    Location:
    Boston
  11. expertmac2 macrumors newbie

    Joined:
    Jun 29, 2013
    #11
    The "app" is from this site. It's supposed to show that error message, then when you press done, iAds will be gone from all apps. I'm not sure if it works though.
     
  12. gslrider macrumors 6502

    gslrider

    Joined:
    Nov 4, 2005
    #12
    Always expect glitches and issues with betas. Take them with a grain of salt. Try restoring as new, and use the official release of iOS 7. It will contain additional fixes and features not available in beta versions. Sometimes even the GM gets tweaked the last minute for the final release. That being said, I've had similar messages. It's an issue on the app side. Sometimes the app wanting to update isn't compatible with newer iOS. When I updated to iOS 6.1.3 from 6.0, I got error messages from a couple of apps wanting to update. I contacted the developer and they told me they were aware of an update issue. Has been fixed since.
     

Share This Page