Unwanted music from my library keeps appearing on my iPhone

Discussion in 'Mac Apps and Mac App Store' started by AVR2, Jun 3, 2017.

  1. AVR2 macrumors 6502

    Jan 16, 2006
    I manually manage the music on my iPhone 5S (10.3.2) and I only ever want very specific music tracks on there. I create a playlist and then sync those tracks to the phone. I don't want the phone to be aware of any other tracks than those specific ones on that playlist, and I don't want to stream music (I have mobile data turned OFF for the Music app).

    However, for some reason I always end up with loads of tracks on the phone that I don't want to be there...

    If I go into Playlists and browse the one playlist that's there, I only see the tracks that I specifically synced. But if I go into Songs or Albums, I'll see all kinds of additional songs. Some will have the correct name for the track with the "cloud" icon next to them, so obviously they won't play because I have streaming switched off, while others will have a long number for the track title - like "190953578876615178902" -and these are actually on the phone and *will* play unless I specifically select my playlist. They're all songs that I have in my library on my Mac mini, but I don't want them on the phone.

    I hope I explained that well enough :)

    So, what can I do to ensure that the phone *only* sees the songs that I have specifically synced to it via the one playlist I use?
  2. Stefan johansson macrumors 65816

    Stefan johansson

    Apr 13, 2017
    Check iTunes settings,is it really set to manual sync for music?
  3. AVR2 thread starter macrumors 6502

    Jan 16, 2006
  4. ApfelKuchen macrumors 68030

    Aug 28, 2012
    Between the coasts
    Settings > Music > iCloud Music Library - off, or on?
  5. Partron22 macrumors 68020


    Apr 13, 2011
    There used to be a setting in iTunes prefs "fill rest of device with other music".
    It may still be there, and you may have it turned on.

Share This Page