Update 3.1.2 jb to 3.1.3 jb (only because of app requirements)

Discussion in 'Jailbreaks and iOS Hacks' started by m3coolpix, Jul 5, 2010.

  1. m3coolpix macrumors 6502a

    m3coolpix

    Joined:
    Dec 24, 2007
    #1
    Haven't done much with JB'ing lately, as everything has been 'status quo' for me since mid January 2010. I have a 32gb 3Gs with 3.1.2, it has iBoot-359.3.2 and JB with blackra1n. Not unlocked (at&t official sim). Currently a tethered JB (hasn't been that big of a deal for me). iTunes version is 9.1.1 (12). I do have shsh blobs stored for both 3.1.2 and 3.1.3. Lastly, I am MAC based, on OS X 10.5.8.

    A couple of app store apps that I use heavily (Pocket Informant and Pocket Money) are now (or are about to) requiring 3.1.3 if I want their latest updates (and of course I do, there are some new sync options).

    If I understand my scenario, I can update to 3.1.3 via iTunes normally (just point to Saurik's servers in my hosts file, and use official 3.1.3 IPSW). Then, I can JB with SpiritJB to an untethered solution. But, no unlock yet.

    Is this correct? Any other method(s) better (PWNAGE work)? What'd I miss? I'm just trying to do a self check on my last hour of Googling research. :)

    And, FWIW, I'm currently not really interested in 4.0 at all. I may be getting the iPhone 4, but will wait a month or two to see how it all falls out with that JB scenario.

    Thank you in advance!
     
  2. stockscalper macrumors 6502a

    stockscalper

    Joined:
    Aug 1, 2003
    Location:
    Area 51
    #2
    Where did you hear that Pocket Informant requires 3.1.3? I think you confused not getting new features in the app unless you upgrade to 4.0, which will allow alarms from the iPhone. There is nothing in 3.1.3 that 3.1.2 doesn't have as far as PI is concerned. So if you have no interest in 4.0 then just hang on to what you have.
     
  3. m3coolpix thread starter macrumors 6502a

    m3coolpix

    Joined:
    Dec 24, 2007
    #3
    Ok, so basically updating to 3.1.3 doesn't buy me anything feature wise with PI 1.5 (submitted to App Store a few days ago). Guess I misunderstood the blog post on their website.

    SO....if I want to update to iOS 4.0 to get those features on PI 1.5, then I'm in the same boat as everyone waiting until new JB tools are released? Or, I just update iTunes (to 9.2) and then restore to iOS 4.0 and be on official software/firmware?
     
  4. The General macrumors 601

    Joined:
    Jul 7, 2006
    #4
    You have the new bootrom, so you can't jailbreak 4.0 yet. You'd have to just update to official 4.0.
     
  5. thundermustard macrumors regular

    Joined:
    Apr 21, 2008
    #5
    There is a jailbreak app in Cydia that fools iTunes into thinking you are on 3.1.3
    Search for Firmware 3.1.3 App
     
  6. m3coolpix thread starter macrumors 6502a

    m3coolpix

    Joined:
    Dec 24, 2007
    #6
    Got it. Brought my head out of the 3.1.2 sand just long enough to find out' there's nothing new to see here yet'......

    Will have to check that out, and see if it helps anything in the meantime.

    And now I'll go back to the corner sandbox and quietly wait on the 4.0 JB.......for either the new bootrom on a 3Gs or the iP4. :eek:
     
  7. thundermustard macrumors regular

    Joined:
    Apr 21, 2008
    #7
    Just installing the App doesn't do it by the way, you have to install it, then go run the program, it will ask whether you want to be on 3.1.2 or 3.1.3 and then you can toggle back and forth as needed. Remember, it doesn't do anything to your actual firmware, just spoofs it.
     

Share This Page