Update on BENM page for ATT 3.1.3 tethering. Can anyone confirm?

vader1990

macrumors regular
Original poster
Sep 23, 2008
220
2
So the benm webpage on the iphone just updated that they found a fix for tethering for 3.1.3 for ATT. Has anyone tried this on a 3gs on 3.1.3 and can confirm that tethering does in fact work again on 3.1.3??

Thanks!
 

pcs are junk

macrumors 65816
Sep 28, 2009
1,044
0
My iPhone is Jailbroken and has a tethering hack already. Before there was something wrong where the BenM tethering profile would not install. It installed fine for me. It wont cause any problems. Just go to their site, click Tethering > USA > Thing > Download > Install > type your passcode, and reboot. My friend isn't Jailbroken and he has a 3GS on 3.1.3. He's trying it out now so I'll report back if it works.
 

CylonGlitch

macrumors 68030
Jul 7, 2009
2,925
109
SoCal
I just tried it and I guess I shouldn't have. :(

I have 3.1.3, and figured I'd give it a try... stupid, I'm not at home.

Well, it SORT of works, a little. It installed OK and seems to work -- the phone is active and I can make calls, BUT it keeps popping up saying I don't have a Data Plan on the phone. :( So I can't get any data.

When I get home this afternoon I'll restore it. Oh well.
 

CylonGlitch

macrumors 68030
Jul 7, 2009
2,925
109
SoCal
Sweet, it wasn't as bad as I thought. You can just go into the profiles and delete the profile that it installs and I was back to begin alive again.
 

pcs are junk

macrumors 65816
Sep 28, 2009
1,044
0
Did you restart the phone? Thats what you need to do to get it to work.

So it does work? Even if you do restart, does the message still pop up? If it does, that means they're getting extremely close. If it doesn't, it means we're already there. Also if you still get the message, try uninstalling the profile by going to Settings > General > and then the profiles section. Click on it and uninstall it and reboot. I really hope this works, if I need to restore, I know I have tethering which is one of the main reasons I Jailbroke.
 

CylonGlitch

macrumors 68030
Jul 7, 2009
2,925
109
SoCal
Yes I restarted. I have not restarted after uninstalling the profile. Going to try it now. But yes, it kept popping up that I didn't have a data plan. :(

I forgot, where is the tethering settings supposed to setup?
 

CylonGlitch

macrumors 68030
Jul 7, 2009
2,925
109
SoCal
Same thing here, that is where I thought tethering should be but nope, nada. I tried it again and still nothing. :(

Oh well, close, but no success.
 

senorhappy

macrumors member
Jun 8, 2009
56
0
Same here... never got the message about the data plan, but don't have anything about tethering under network after rebooting. crap!
 

senorhappy

macrumors member
Jun 8, 2009
56
0
I have 3.1.3, but my phone isn't unlocked.... according to the benm website, it says "At 3.1.3 only without simlock!" Does this mean that i'd have to unlock my phone to get this to work?
 

pcs are junk

macrumors 65816
Sep 28, 2009
1,044
0
I don't think they mean unlocked iPhones. I think they're referring to the passcode lock that can be put on a sim card.
 

ouimetnick

macrumors 68020
Aug 28, 2008
2,497
566
Beverly, Massachusetts
I don't think they mean unlocked iPhones. I think they're referring to the passcode lock that can be put on a sim card.
I think they are referring to non unlocked iPhones. This didn't work for my brother. He didn't have a PIN on his SIM. All it does is change the settings on the iPhone, not sim card.

pcs are junk, the passcode you are referring to is called a SIM PIN. :rolleyes:
 

danpmor

macrumors newbie
Feb 18, 2010
2
0
No luck!!

I tried installing the profile and it says it installs but then I go to general>network and there is no internet tethering option. I think I am installing it correctly, I install it than reboot but nothing. Anything I am doing wrong?
 

ViViDboarder

macrumors 68040
Jun 25, 2008
3,447
0
USA
Something to do with the config file itself. If you read the whole post he said that he's not sure it would work and he'd just try something. So we'll have to wait and see if he fixes it.
 

ivanovnv

macrumors newbie
Feb 9, 2010
4
0
I tried installing the profile and it says it installs but then I go to general>network and there is no internet tethering option. I think I am installing it correctly, I install it than reboot but nothing. Anything I am doing wrong?
You people are like little kids. None of you is actually reading and verifying. The mobile configuration benm had was wrong. There were issues with the Username and pass. I am working with him to have them corrected. Try and create your own config file by using the utility benm has provided you with and with the following data:

APN: Thing

wap.cingular
WAP@CINGULARGPRS.COM
CINGULAR1
 

ViViDboarder

macrumors 68040
Jun 25, 2008
3,447
0
USA
You people are like little kids. None of you is actually reading and verifying. The mobile configuration benm had was wrong. There were issues with the Username and pass. I am working with him to have them corrected. Try and create your own config file by using the utility benm has provided you with and with the following data:

APN: Thing

wap.cingular
WAP@CINGULARGPRS.COM
CINGULAR1
Does that work? I almost did that yesterday when I realized the .com was missing from that line. (After someone mentioned it on twitter ;) )
 

CylonGlitch

macrumors 68030
Jul 7, 2009
2,925
109
SoCal
Just tried it but not sure if I entered the fields right :

Carriername : wap.cingular
APN : Thing
User : WAP@CINGULARGPRS.COM
Password : CINGULAR1

With things setup this way, I got exactly the same results as before. No networking capability.
 

pcs are junk

macrumors 65816
Sep 28, 2009
1,044
0
Maybe every iPhone user can call up AT&T on the same day, and the same time, and complain that we want tethering. It seems like it would work...