Updated firmware broke my onboard network Port

Discussion in 'Macintosh Computers' started by revilord, Oct 28, 2004.

  1. revilord macrumors newbie

    Oct 28, 2004
    :confused: In an attempt to upgrade my G4 500Mhz APG I upgraded the firmware to 4.2.8.f1. The upgrade requires that you boot into OS 9. After the upgrade everything seemed to be working fine in OS 9. I rebooted in OS X 10.3.5 and the Mac froze during the boot sequence. On the Screen it had "Initializing Networking" and a progress bar. I realized that if I unplugged the cable to the onboard network card that it would continue to boot normally and everything except netowrking seemed to be working. If I plugged the cable back in then the Mac froze again until I unplugged the cable. I setup a PCI network card and that seems to be working good.

    I'm not sure what the problem is or where to look. I've tried removing all the non-mac memory and the other PCI card.
  2. revilord thread starter macrumors newbie

    Oct 28, 2004
    After checking the Asante PCI network card I installed to work around the broken built-in NIC I am finding that I am getting several RECV Errors. about 1000 for every 50,000 packets recieved. The error rate was worse until I turned off the built in NIC from the port configuration. I have tried moving the mac, swapping network cables, hubs without success. The other 5 Macs on the network don't have any network issues.

    I have not had any response to my issue so I'm asuming it is unusual. But if someone could give me some guidence for what to look for, that would be great. Why would the built-in work in OS 9 but not OS X? Hmmm
  3. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    That's a pretty darned strange issue. It is, at least theoretically, possible that there's something wrong with the onboard networking hardware, and while OS9 can "overlook" the issue enough to function, OSX is pickier (or uses some feature of it that OS9 doesn't), and so fails.

    This is very unlikely, but here's something vaguely similar I've seen: under 10.2, if the network wasn't responding properly (most often when the DHCP server in my cable modem was down), it would hang on startup for a very long time. It would, however, eventually kick in (I think the timeout was 5-10 minutes). I'm assuming this is unrelated to your issue, and I'm not sure how it'd help, but just thought I'd mention it.

    You could always try the old standbys of motherboard CUDA switch, reset PRAM, then boot into open firmware and do a reset-all. This has resurrected firewire ports for people who had power glitches, so maybe it'll help with malfunctioning networking hardware.

    You could also try shutting down, unplugging the computer from the wall, and letting it sit for a while (overnight, say)--that has also, on occasion, reset things that other methods didn't.

    Good luck.

Share This Page