Updated to 10.13.2 and now my Mac is showing up as an audio device when I make a call on iPhone

Discussion in 'macOS High Sierra (10.13)' started by avanpelt, Dec 6, 2017.

  1. avanpelt, Dec 6, 2017
    Last edited: Dec 6, 2017

    avanpelt macrumors 68030

    Joined:
    Jun 2, 2010
    #1
    I just updated to 10.13.2. After updating, I made a subsequent call on my iPhone (running iOS 11.2) and I noticed that my Mac is now listed as an audio device during the call in addition to the standard "iPhone" and "Speaker". I tapped on my Mac from the menu thinking that perhaps the audio would be routed to the bluetooth headphones that I'm currently using for audio input and output on my Mac, but I didn't hear anything through the headphones.

    Anybody know why my Mac is suddenly showing up as an audio option during calls on my iPhone?

    macOS 10.13.2.jpg
     
  2. v1597psh macrumors regular

    v1597psh

    Joined:
    Feb 4, 2014
    Location:
    London
    #2
    That's a new feature with iOS 11.2 and macOS 10.13.2. You can now route the phone calls between your devices. It works fine for me on my Mac. Try restarting and reconnecting your headphones
     
  3. MacGarage macrumors member

    Joined:
    Jun 18, 2017
    Location:
    Ohio
    #3
    How do you remove the computers from the list...my MacPro does not even have a mic!
     
  4. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    Try the Facetime preference.

    Screen Shot 2017-12-20 at 16.11.47.jpg
     
  5. MacGarage macrumors member

    Joined:
    Jun 18, 2017
    Location:
    Ohio
    #5
    I was never logged into FaceTime.

    When I do log in and then uncheck the Calls From iPhone, it still does not make a difference...MacPro still shows up.
     
  6. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #6
    Then try your phone. Preferences -> phone

    EA81A10C-A79F-459C-844C-19FD4D6DBBA5.jpeg
     
  7. MacGarage macrumors member

    Joined:
    Jun 18, 2017
    Location:
    Ohio
    #7
    Thanks...that has been turned off as is handoff and WiFi Calling.

    I turned off Wi-Fi, Bluetooth and still no difference. The only way it goes away is if iCloud is completely logged out (no iCloud services.

    I also signed out of Messages...no difference.

    Driving in today, once again, even when I was miles away from my MacPro, it shows up!
     
  8. MacGarage, Dec 22, 2017
    Last edited: Dec 22, 2017

    MacGarage macrumors member

    Joined:
    Jun 18, 2017
    Location:
    Ohio
    #8
    Okay...I think I figured it out:

    Under Celluar > Wi-Fi Calling (I had it turned off completely), you need to turn it on and then turn off all of the devices there and leave the Wi-Fi Calling setting "On."

    Apparently, turning the option off completely does not work.
     

Share This Page