Updated to High Sierra 10.13 - Copy/Paste not working

Discussion in 'macOS High Sierra (10.13)' started by yomacroni, Oct 5, 2017.

  1. yomacroni macrumors member

    yomacroni

    Joined:
    Sep 19, 2017
    #1
    Copy/Paste has been working fine using High Sierra until I updated to the latest High Sierra patch today. I rebooted, same problem, rebooted in safe mode, same problem. Cut works fine, Paste doesn't work either using shortcut or from menu (greyed out). Tried in multiple apps including Notes. Has anyone seen this before?
     
  2. biyahero1 macrumors newbie

    biyahero1

    Joined:
    Oct 18, 2017
    #2
  3. johnsawyercjs, Aug 7, 2018
    Last edited: Aug 9, 2018

    johnsawyercjs macrumors member

    johnsawyercjs

    Joined:
    Feb 27, 2007
    #3
    I hope you got your text copy/paste problem fixed. I'm seeing exactly the same problem today, after I used dosdude1's 'MacOS High Sierra Patcher' to install 10.3.1 onto a new 500GB SSD in my Mid 2009 Macbook (5,2), after which I used Migration Assistant to copy everything from a backup of this Macbook's prior drive, a 240GB SSD, to the new 500GB SSD. About a year ago, I used this patcher to install 10.3.1 onto the 240GB SSD, which I've been using in this Macbook up until today, but I hadn't seen this copy/paste problem on the patched OS on the 240GB SSD. I suspect Migration Assistant might have messed up something while copying files to the 500GB SSD, rather than MacOS High Sierra Patcher being the problem--maybe Migration Assistant failed to copy one or more of the patcher's files from the backup to the 500GB SSD, or messed up file/folder permissions somewhere, or something.

    Before I ran the 'MacOS High Sierra Patcher' today on the 500GB SSD, I didn't check first whether a newer version of the patcher had been released since the last time I downloaded it for use with the 240GB SSD, so I just used my earlier patched 10.3.1 installer (on a USB stick), patched with version 2.4.0 of the patcher. Later tonight I learned, on dosdude1's website, that the latest version is 2.6.2, with some significant fixes (SIP can be active now, etc.), but my use of the earlier version wasn't responsible for the copy/paste problem--I point this out to remind people who have used MacOS High Sierra Patcher before, to first check dosdude1's website before using it again, if you haven't for a while, to check for updates.

    Things I tried that didn't fix the problem:
    • Rebooted.
    • Tried a new user account.
    • Rebooted in Safe Mode.
    • Used Sierra Cache Cleaner to:
    - Delete all cache files that it can.
    - Repair permissions, since Disk Utility doesn't do that any more.
    - Run the cron scripts (daily, weekly, monthly)
    - Rebuild prebinding
    - Rebuild Launch Services database
    • Tried the suggestions in the article at www.osxdaily.com/2018/02/02/fix-copy-paste-not-working-mac/, including suggestions in the comments, including using Terminal to run 'sudo update_dyld_shared_cache'.
    • Rebooted from my patched High Sierra installer and reinstalled the list of patches applicable to my 5,2 Macbook, and at the next reboot from the 500 GB SSD, I didn't allow the Patch Updater to install anything new.
    • Rebooted again from my patched High Sierra installer and selected the patch installer's option to force cache rebuild.
    • Some people recommend trashing the prefs file at /Library/Preferences/com.apple.finder.plist, but I had no file there--I have a com.apple.finder.plist file in my home folder, at ~/Library/Preferences, but that's not the problem since the problem exists across all my user accounts. I trashed my home folder's com.apple.finder.plist file anyway, but I wasn't surprised when it made no difference.
    • I quit from the Finder, since some people find that the Finder itself (or some other running app) is causing the problem. Not so on my Macbook.

    So that's where I am right now--text copy/paste still not working (I haven't tested whether file copy/paste works, since I never use that). Each time I try to copy some text, nothing appears on the clipboard when I go to the Finder and select Edit/Show Clipboard. I may download the MacOS 10.3.1 Combo Updater later and try it, in case it will replace any corrupted files or bad patches installed by Patch Updater, but of course before I can boot from this I'll have to immediately re-patch it using my patched High Sierra installer, and maybe that will just reintroduce the copy/paste problem. I plan to make a new patched High Sierra installer using the latest version (2.6.2) of MacOS High Sierra Patcher, which will theoretically also download OS 10.13.4 or 10.3.5, and maybe that will help, but apparently other people are seeing this problem even using a recent version of High Sierra Patcher and High Sierra, and even some people who aren't using any kind of patcher, on fully supported Macs.

    [Update: I decided I didn't want to continue on a typically lengthy and unproductive effort to fix the copy/paste problem, so since I'd also done a backup earlier today of the 240GB drive, I booted the Macbook from the backup (a Firewire drive), used Disk Utility to erase the startup volume on the 500GB SSD (leaving the Recovery partition intact), and used SuperDuper to copy the entire 240GB SSD backup to the 500GB SSD, rebooted from the 500GB SSD, and the copy/paste problem is now gone. So another yay to having current backups.]
     
  4. yomacroni thread starter macrumors member

    yomacroni

    Joined:
    Sep 19, 2017
    #4
    Ultimately I ended up switching to Windows but good luck!
     
  5. johnsawyercjs macrumors member

    johnsawyercjs

    Joined:
    Feb 27, 2007
    #5
    Thanks! I'm going to keep plugging away, and when I fix it, I'll post the fix here for others.
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    So, did you try the link in post #2? If so, was that unsuccessful?
     
  7. johnsawyercjs macrumors member

    johnsawyercjs

    Joined:
    Feb 27, 2007
    #7
    Yes, I tried that too, as I mentioned in my first post in this thread.
     

Share This Page