Updated to Os4 (with iPhone 3G) and can't connect to home WIFI?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by crackedandblack, Jun 23, 2010.

  1. crackedandblack macrumors member

    Joined:
    Apr 29, 2009
    #1
    I updated last night and it worked fine for an hour - now it won't let me select my router - I've tried a restore and still not working - once I select the router the little tick just vanishes.

    Any help?
     
  2. synagence macrumors 6502a

    Joined:
    Jul 23, 2008
    #2
    You're not the only one. Rumours suggest changing wifi on router to not use wpa2 as ios4 has a bug
     
  3. crackedandblack thread starter macrumors member

    Joined:
    Apr 29, 2009
    #3
    thanks - might try that.
     
  4. Jsn macrumors member

    Joined:
    Feb 1, 2008
    #4
    Yup. I've got exactly the same problem. I'll try the non-WPA2 change and see if it works.
     
  5. Jsn macrumors member

    Joined:
    Feb 1, 2008
    #5
    That did the trick! Changed from "WPA2" to "WPA/WPA2 Personal" in AirPort Utility. Now the WIFI shows up as before.

    Whew. I wasn't relishing having to restore to pre-iOS 4 software.
     
  6. aschulman macrumors newbie

    Joined:
    Jun 25, 2010
    #6
    A few more facts:

    I may be the original source (on macworld's forum) of the rumored incompatibility of ios4 with WPA2, as an Apple tech instructed me to downgrade wireless security to WEP from WPA2 to get my iphone 3gs with ios4 connecting to the network again. It worked.

    Oddly enough, a few days later (unhappy to be stuck using WEP) I tried going back to WPA2 security on my airport extreme and both my 3gs and my new iphone 4 seemed to work fine with it. Then today, my iphone 4 started losing wifi intermittently. Like Jsn, I changed network security to WPA/WPA2 and, voila, consistent wifi restored!

    Presumably Apple will sort this out with a software update soon.
     
  7. synagence macrumors 6502a

    Joined:
    Jul 23, 2008
    #7
    Try pre-loading your WiFi config into the phone via a profile from iPhone Configuration Utility ... it worked for me (3GS to an Airport Extreme on WPA2 only)
     
  8. Pagemakers macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #8
    Mine works fine until I turn my phone off then on. Them it does not automatically reconnect to the network
     
  9. markeaton Guest

    #9
    Any update?

    Hello,

    This is still a problem with IOS 4.0.1 on a 3GS; any word on whether this is fixed in 4.0.2?

    Thanks,
    Mark
     
  10. markeaton Guest

    #10
    Well, I can confirm that 4.0.2 does not fix the problem.:(

    Mark
     

Share This Page