iPhone Updating from 5.1.1 to 6.1.2 - Not 6.1.3

Discussion in 'Jailbreaks and iOS Hacks' started by Jetheat, Apr 3, 2013.

  1. Jetheat macrumors regular

    Joined:
    Mar 13, 2008
    #1
    I have an iPhone 3GS on 5.1.1. I wanna update to 6.1.2 and not to the latest 6.1.3.

    Any idea how I can do that?

    JH
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    I'm pretty sure that is only possible if you have the SHSH blobs saved for 6.1.2.
     
  3. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #3
    First see if you have old bootrom or new bootrom (check the link in my signature), as this may determine your options regardless of firmware.

    If new bootrom, see if you have blobs first by using Tiny Umbrella, maybe they were saved automatically through Cydia, IF you have been on 5.1.1 when 6.1.2 was being signed and were jailbroken. Otherwise, you cannot go to 6.1.2.
     
  4. iRetired macrumors 6502a

    iRetired

    Joined:
    Apr 21, 2012
    Location:
    WNY
    #4
  5. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #5
    Wrong my friend. The 3GS and 4 need blobs to move between firmwares on iOS 6. Downloading the firmware alone will not allow one to do this.
     
  6. Jetheat thread starter macrumors regular

    Joined:
    Mar 13, 2008
    #6
    ok, seems like I have a new Bootrom. I have downloaded TU, but how do I use it to check to see if I have blobs?


    Do I need to start TSS Server?

    Do I need to go into Recovery Mode first?

    I also have Cydia. I don't know if that can be used to get the info I need.


    JH
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    Download the latest version of iFaith (v1.5.6) and run it. Plug in your iPhone 3GS and click "show available shsh caches on server". After it finds it, save them.

    See if it marks them as valid or not. If its not valid, don't upgrade or else it'll put your device into a soft DFU loop.
     
  8. Jetheat thread starter macrumors regular

    Joined:
    Mar 13, 2008
    #8
    Sadly I only have a Mac. iFaith is only for Windows.

    Can't I do it with TinyUmbrella?
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    Open TU.
    plug in you iPhone. Go to advanced and check the box to request shsh from cydia.
    Click save shsh and see what blobs you have a available for your phone first.
     
  10. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #10
    As of right now, only iFaith properly validates the shsh blobs. As far as I'm aware of

    You can get your shsh blobs off of cydia's server using tinyumbrella but it doesn't validate whether your shsh blobs are complete or not. But as applejuiced said, check if you even have any 6.x shsh blobs first
     
  11. Jetheat thread starter macrumors regular

    Joined:
    Mar 13, 2008
    #11
    ok, My 3GS is on 5.1.1 but I have Blobs for 5.1.1 and also 6.0.1 amongst other older ones.

    What's next?

    JH
     
  12. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Cal
    #12
    OP why did u wait until now to decide to update?
     
  13. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #13
    If 6.0.1 is the only shsh blob you have for 6.x, that is the only version you can update to. You can stitch your shsh blobs into the ipsw and restore. If you are stuck in a soft DFU mode/loop when restarting your phone, do the same to a 5.1.1 ipsw and downgrade back to 5.1.1 so you can have an untethered jailbreak back
     
  14. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #14
    If you have 6.0.1 blobs then you can go up to that.
    Download the latest redsnow version.
    Download the official 6.0.1 ipsw for the 3GS.
    Open redsnow,extras, custom ipsw and select the 6.0.1 ipsw you downloaded.
    Redsnow then should be able to restore your 3GS to that version.
     
  15. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #15
    What he said :D

    But if you're on 5.1.1 and content with iOS 5, just stay there. Or you can go to 6.1.3, but your jailbreak will be tethered!
     
  16. Jetheat thread starter macrumors regular

    Joined:
    Mar 13, 2008
    #16
    If I follow this, will it also unlock the iPhone?

    Coz I just tried putting my wife's sim in there and it shows "No Service".

    How can I unlock my phone at the same time?

    JH
     
  17. quietstormSD macrumors 6502a

    quietstormSD

    Joined:
    Mar 2, 2010
    Location:
    San Diego, CA
    #17
    You can unlock your phone by paying $2-$3 from IMEI-unlock site or on ebay.
     
  18. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #18
    No, that has nothing to do with unlocking.
    If its an AT&T locked iphone like the bro said above pay the $2 and get it imei unlocked at swiftunlocks.
     
  19. Jetheat thread starter macrumors regular

    Joined:
    Mar 13, 2008
    #19
    I am in the UK. Wont be ATT.
     
  20. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #20
    I see.
    Try to contact the carrier to see if they will unlock it for you.
     
  21. Jetheat thread starter macrumors regular

    Joined:
    Mar 13, 2008
    #21
    The phone is not connected to the carrier. Bought the phone offline.

    JH
     
  22. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #22
    You may have bought it from someone else but the phone is still locked to the carrier. You will have to contact the carrier your phone is locked to and ask them to unlock it
     

Share This Page