Updating to iTunes 11.1 gave me a ton of disk permissions errors

Discussion in 'Mac Apps and Mac App Store' started by Akuratyde, Sep 18, 2013.

  1. Akuratyde macrumors regular

    Joined:
    Feb 7, 2011
    #1
    I ran a Verify Disk Permissions a few days ago and nothing came up, then I did one after installing iTunes 11.1 and I got a ton of errors. See below:

    [​IMG]

    The list goes on for awhile. I tried doing a Repair Permissions twice and a reboot and the errors are still showing up.

    What's my next course of action?
     
  2. RahulRulz macrumors member

    RahulRulz

    Joined:
    Sep 18, 2013
    Location:
    London, UK
    #2
    You could try Uninstalling the Current iTunes and Fresh Install from website.
    http://www.apple.com/itunes/

    Hope this should fix your problem.

    Thank You
     
  3. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #3
    Same here, the errors persist even though DU says it repaired them, makes no difference when DU's repair permissions is run for the boot drive or from a booted external.
    However, it doesn't seem to affect the performance or function of iTunes.
    Probably have to wait for 11.1.1 to see Apple fix it. :mad::rolleyes::mad:
     
  4. Akuratyde thread starter macrumors regular

    Joined:
    Feb 7, 2011
    #4
    I did, and OS X won't allow me to uninstall it. I get an error message that says iTunes cannot be deleted because it's required by OS X.

    I did the standard drag-to-trash method of uninstalling. Is there another method, or any free uninstaller applications that anyone would recommend?
     
  5. dlb1920 macrumors newbie

    Joined:
    Mar 19, 2012
    #5
    I had the same thing happen before and after repairing permissions. Both Macs are working fine so I will not worry about it.
     
  6. Jon-PDX macrumors regular

    Joined:
    Oct 20, 2011
    Location:
    Pacific NW - USA
    #6
    I knew I should have not clicked on this thread. I have the same issue and the same results trying to fix it [​IMG].

    I noticed it's language files for just about everything but US English.....hummmm.

    But iTunes seems to be working so I guess I will not worry about it at this time. It does bother me though since I made a point of making sure there were no issues before updating.

    Jon...
     
  7. Akuratyde thread starter macrumors regular

    Joined:
    Feb 7, 2011
    #7
    Same here, it's not a big deal but it does bother me as I make it a point to keep my machine in tip-top shape.
     
  8. extramindful macrumors newbie

    Joined:
    Oct 8, 2011
    #8
    iTunes 11.1.0 Permissions

    Also experienced bushels of permission errors with the iTunes update. Before that NO ERROR permissions for last 3 or 4 months. Also tried to use Onyx and Mountain Lion Cache Cleaner, but errors persists.Since iTunes is an Apple application, users' hands are tied. If you try to do more to correct this, it probably will mess up your computer! Before Apple updates, it should do more research and troubleshooting.
     
  9. Jon-PDX macrumors regular

    Joined:
    Oct 20, 2011
    Location:
    Pacific NW - USA
    #10
    Risco,

    Thanks for posting the link to the thread over at the Apple forums.

    After reading the thread at the link you provided it looks like we have two choices.

    1). Live with the issue until Apple fixes it with an update.

    2). Go back to the previous version as talked about in that thread.

    If I remember correctly the current version 11.1 is needed for iOS-7. So option #2 will not work for people that have a device running iOS-7.

    Jon...
     
  10. effla macrumors newbie

    effla

    Joined:
    Jul 28, 2012
    #11
    Same issue here
    iMac 27" 2011

    But today i had a bad problem with the boot. My iMac was stuck on the white screen and trying to boot him in recovery mod gave me Green, blu, blu with black lines screen.

    Also a friend of mine with a macbook pro is stuck with the white screen and he's unable to fix it. Same problems with itunes permissions.

    This is the report after i succeded bootin again my iMac in OSX.


    Code:
    Interval Since Last Panic Report:  622560 sec
    Panics Since Last Report:          1
    Anonymous UUID:                    A6843CCD-9438-2A3C-54AE-5FD644536E51
    
    Fri Sep 27 15:00:39 2013
    panic(cpu 3 caller 0xffffff8005e9e54b): "TLB invalidation IPI timeout: " "CPU(s) failed to respond to interrupts, unresponsive CPU bitmap: 0x3, NMIPI acks: orig: 0x0, now: 0x0"@/SourceCache/xnu/xnu-2050.48.11/osfmk/x86_64/pmap.c:2343
    Backtrace (CPU 3), Frame : Return Address
    0xffffff81d82cbaa0 : 0xffffff8005e1d636 
    0xffffff81d82cbb10 : 0xffffff8005e9e54b 
    0xffffff81d82cbb90 : 0xffffff8005ea2d60 
    0xffffff81d82cbc50 : 0xffffff8005ea3595 
    0xffffff81d82cbca0 : 0xffffff8005e6722c 
    0xffffff81d82cbd90 : 0xffffff8005e6b100 
    0xffffff81d82cbdc0 : 0xffffff8005e65bff 
    0xffffff81d82cbdf0 : 0xffffff800620a723 
    0xffffff81d82cbe10 : 0xffffff800626d743 
    0xffffff81d82cbe50 : 0xffffff8005e949b2 
    0xffffff81d82cbe80 : 0xffffff8005e20b4d 
    0xffffff81d82cbeb0 : 0xffffff8005e10448 
    0xffffff81d82cbf00 : 0xffffff8005e1961b 
    0xffffff81d82cbf70 : 0xffffff8005ea6546 
    0xffffff81d82cbfb0 : 0xffffff8005ecf473 
    
    BSD process name corresponding to current thread: UserEventAgent
    
    Mac OS version:
    12F37
    
    Kernel version:
    Darwin Kernel Version 12.5.0: Mon Jul 29 16:33:49 PDT 2013; root:xnu-2050.48.11~1/RELEASE_X86_64
    Kernel UUID: B1B58405-A2B2-3C44-B25D-495053D52AB5
    Kernel slide:     0x0000000005c00000
    Kernel text base: 0xffffff8005e00000
    System model name: iMac12,2 (Mac-942B59F58194171B)
    
    System uptime in nanoseconds: 27273634045
    last loaded kext at 6343166259: com.apple.driver.AppleHWSensor	1.9.5d0 (addr 0xffffff7f87968000, size 36864)
    loaded kexts:
    at.obdev.nke.LittleSnitch	3876
    com.apple.driver.AppleHWSensor	1.9.5d0
    com.apple.driver.AudioAUUC	1.60
    com.apple.iokit.IOBluetoothSerialManager	4.1.7f2
    com.apple.filesystems.autofs	3.0
    com.apple.driver.AGPM	100.13.12
    com.apple.driver.AppleTyMCEDriver	1.0.2d2
    com.apple.filesystems.ntfs	3.10
    com.apple.driver.AppleMikeyHIDDriver	124
    com.apple.driver.AppleHDAHardwareConfigDriver	2.4.7fc2
    com.apple.driver.AppleHDA	2.4.7fc2
    com.apple.iokit.IOBluetoothUSBDFU	4.1.7f2
    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport	4.1.7f2
    com.apple.driver.AppleMikeyDriver	2.4.7fc2
    com.apple.iokit.IOUserEthernet	1.0.0d1
    com.apple.driver.AppleSMBusPCI	1.0.11d1
    com.apple.driver.AppleLPC	1.6.3
    com.apple.driver.AppleMuxControl	3.4.5
    com.apple.driver.AppleBacklight	170.3.5
    com.apple.driver.AppleUpstreamUserClient	3.5.12
    com.apple.driver.AppleMCCSControl	1.1.11
    com.apple.kext.AMDFramebuffer	8.1.6
    com.apple.AMDRadeonAccelerator	1.0.8
    com.apple.driver.AppleIntelHD3000Graphics	8.1.6
    com.apple.driver.AppleIntelSNBGraphicsFB	8.1.6
    com.apple.Dont_Steal_Mac_OS_X	7.0.0
    com.apple.driver.ApplePolicyControl	3.4.5
    com.apple.driver.AppleSMCPDRC	1.0.0
    com.apple.driver.AppleSMCLMU	2.0.3d0
    com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
    com.apple.driver.AppleUSBCardReader	3.3.1
    com.apple.driver.AppleIRController	320.15
    com.apple.iokit.SCSITaskUserClient	3.5.6
    com.apple.driver.AppleFileSystemDriver	3.0.1
    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0d1
    com.apple.BootCache	34
    com.apple.driver.XsanFilter	404
    com.apple.iokit.IOAHCIBlockStorage	2.3.5
    com.apple.driver.AppleUSBHub	623.4.4
    com.apple.driver.AirPort.Atheros40	600.72.2
    com.apple.driver.AppleUSBEHCI	621.4.6
    com.apple.driver.AppleFWOHCI	4.9.9
    com.apple.driver.AppleAHCIPort	2.6.6
    com.apple.iokit.AppleBCM5701Ethernet	3.6.2b4
    com.apple.driver.AppleUSBUHCI	621.4.0
    com.apple.driver.AppleACPIButtons	1.8
    com.apple.driver.AppleRTC	1.5
    com.apple.driver.AppleHPET	1.8
    com.apple.driver.AppleSMBIOS	1.9
    com.apple.driver.AppleACPIEC	1.8
    com.apple.driver.AppleAPIC	1.7
    com.apple.driver.AppleIntelCPUPowerManagementClient	214.0.0
    com.apple.nke.applicationfirewall	4.0.39
    com.apple.security.quarantine	2.1
    com.apple.driver.AppleIntelCPUPowerManagement	214.0.0
    com.apple.iokit.IOSerialFamily	10.0.6
    com.apple.kext.triggers	1.0
    com.apple.driver.DspFuncLib	2.4.7fc2
    com.apple.iokit.IOAudioFamily	1.9.2fc7
    com.apple.kext.OSvKernDSPLib	1.12
    com.apple.iokit.IOBluetoothHostControllerUSBTransport	4.1.7f2
    com.apple.iokit.IOSurface	86.0.4
    com.apple.driver.AppleThunderboltEDMSink	1.2.0
    com.apple.driver.AppleBacklightExpert	1.0.4
    com.apple.driver.AppleSMBusController	1.0.11d1
    com.apple.iokit.IOAcceleratorFamily	74.15
    com.apple.kext.AMD6000Controller	8.1.6
    com.apple.kext.AMDSupport	8.1.6
    com.apple.iokit.IOBluetoothFamily	4.1.7f2
    com.apple.driver.AppleGraphicsControl	3.4.5
    com.apple.iokit.IONDRVSupport	2.3.7
    com.apple.driver.AppleHDAController	2.4.7fc2
    com.apple.iokit.IOGraphicsFamily	2.3.7
    com.apple.iokit.IOHDAFamily	2.4.7fc2
    com.apple.iokit.IOFireWireIP	2.2.5
    com.apple.driver.AppleSMC	3.1.5d4
    com.apple.driver.IOPlatformPluginLegacy	1.0.0
    com.apple.driver.IOPlatformPluginFamily	5.4.1d11
    com.apple.driver.AppleThunderboltDPOutAdapter	2.5.0
    com.apple.driver.AppleThunderboltDPInAdapter	2.5.0
    com.apple.driver.AppleThunderboltDPAdapterFamily	2.5.0
    com.apple.driver.AppleThunderboltPCIDownAdapter	1.3.2
    com.apple.iokit.IOSCSIBlockCommandsDevice	3.5.6
    com.apple.iokit.IOUSBMassStorageClass	3.5.2
    com.apple.iokit.IOUSBHIDDriver	623.4.0
    com.apple.driver.AppleUSBMergeNub	621.4.6
    com.apple.driver.AppleUSBComposite	621.4.0
    com.apple.iokit.IOSCSIMultimediaCommandsDevice	3.5.6
    com.apple.iokit.IOBDStorageFamily	1.7
    com.apple.iokit.IODVDStorageFamily	1.7.1
    com.apple.iokit.IOCDStorageFamily	1.7.1
    com.apple.iokit.IOAHCISerialATAPI	2.5.5
    com.apple.iokit.IOSCSIArchitectureModelFamily	3.5.6
    com.apple.iokit.IOUSBUserClient	630.4.4
    com.apple.driver.AppleThunderboltNHI	1.9.2
    com.apple.iokit.IOThunderboltFamily	2.7.7
    com.apple.iokit.IO80211Family	530.5
    com.apple.iokit.IOFireWireFamily	4.5.5
    com.apple.iokit.IOAHCIFamily	2.5.1
    com.apple.iokit.IOEthernetAVBController	1.0.2b1
    com.apple.iokit.IONetworkingFamily	3.0
    com.apple.iokit.IOUSBFamily	630.4.5
    com.apple.driver.AppleEFINVRAM	2.0
    com.apple.driver.AppleEFIRuntime	2.0
    com.apple.iokit.IOHIDFamily	1.8.1
    com.apple.iokit.IOSMBusFamily	1.1
    com.apple.security.sandbox	220.3
    com.apple.kext.AppleMatch	1.0.0d1
    com.apple.security.TMSafetyNet	7
    com.apple.driver.DiskImages	345
    com.apple.iokit.IOStorageFamily	1.8
    com.apple.driver.AppleKeyStore	28.21
    com.apple.driver.AppleACPIPlatform	1.8
    com.apple.iokit.IOPCIFamily	2.8
    com.apple.iokit.IOACPIFamily	1.4
    com.apple.kec.corecrypto	1.0
    Model: iMac12,2, BootROM IM121.0047.B1F, 4 processors, Intel Core i5, 3.1 GHz, 16 GB, SMC 1.72f1
    Graphics: AMD Radeon HD 6970M, AMD Radeon HD 6970M, PCIe, 2048 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x802C, 0x31364B54463531323634485A2D3147344B31
    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x802C, 0x31364A54463531323634485A2D3147344831
    Memory Module: BANK 0/DIMM1, 4 GB, DDR3, 1333 MHz, 0x802C, 0x31364A54463531323634485A2D3147344831
    Memory Module: BANK 1/DIMM1, 4 GB, DDR3, 1333 MHz, 0x802C, 0x31364B54463531323634485A2D3147344B31
    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380: 4.0.72.0-P2P
    Bluetooth: Version 4.1.7f2 12718, 3 service, 21 devices, 3 incoming serial ports
    Network Service: Wi-Fi, AirPort, en1
    Serial ATA Device: WDC WD1001FALS-403AA0, 1 TB
    Serial ATA Device: SAMSUNG SSD 830 Series, 128,04 GB
    Serial ATA Device: OPTIARC DVD RW AD-5680H
    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2
    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 4
    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3
    USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3
    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2
    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4
    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 5
     
  11. borostef macrumors 6502

    borostef

    Joined:
    Feb 10, 2012
    Location:
    Zagreb, Croatia
    #12
    I have the same problem since upgrading... But it is not only the disk permissions, iTunes on my MacMini crash at least once a day... Well maybe not crash but rather stall... I have to force quit and then it all goes to normal... Until it happens again...
     
  12. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #13
    These have NO relationship to the message about iTunes permissions.
     
  13. effla macrumors newbie

    effla

    Joined:
    Jul 28, 2012
    #14
    I know but the fact that after two days me and my friend had the same issue (white screen and stuck at the boot) made me a bit confused :confused:
     
  14. Chriscotech macrumors newbie

    Joined:
    Mar 21, 2008
    Location:
    Sydney, Australia
    #15
    I have both those problems since installing iTunes 11.1 too. It seems more and more likely that they are related but I agree it doesn't make sense. The fans on my 12 core Mac Pro also keep revving up now and no amount of reseting the SMC or PRAM seems to fix it. everything was smooth before iTunes 11.1
     
  15. mplspitbull macrumors newbie

    Joined:
    Oct 11, 2012
    #16
    same issues

    I too have had the same itunes permissions issues and the booting my computer issue. Very frustrating and still working on a fix.
     
  16. Jon-PDX macrumors regular

    Joined:
    Oct 20, 2011
    Location:
    Pacific NW - USA
    #17
    iTunes 11.1.3

    Anyone update to 11.1.3 yet?

    Did it fix the disk permissions issue?

    Jon…
     
  17. ssls6 macrumors 6502a

    ssls6

    Joined:
    Feb 7, 2013
    #18
    No it did not
     
  18. Akuratyde thread starter macrumors regular

    Joined:
    Feb 7, 2011
    #19
    The latest update did resolve this issue for me.
     
  19. jnaeve macrumors newbie

    jnaeve

    Joined:
    Aug 24, 2007
    Location:
    Murphy, TX
    #20
    Mavericks Blues and iTunes permissions

    Hi All,
    I was just reading this thread and saw the same issues I'm experiencing. I recently rolled back to ML from Mavericks and have been in restoration he!! for the last week but all that I'm lacking at the moment is getting the iTunes permissions issue resolved. I looked on Apple's Support site and they claim these are non-issues and we can ignore them.

    Now if some of you still need to figure out how to remove iTunes, I found that using a tool like "Path Finder" www.cocoatech.com which allows you to initiate the process but because it requires authentication that Finder ignores, you're able to enter your password and remove the app.

    The question I have is this: Has anyone attempted to go into the iTunes package contents and correct the attributes independently of Repair Permissions? If thats not an option, the only one left is going back to a previous version of iTunes and not upgrading.

    Funny, maybe you all are or aren't in the same boat but I no longer view the term upgrade as a positive thing with respect to Apple. :mad: They're becoming like so many others with severe QC gaps.

    Thanks for any feedback and/or input.

    Happy New Year!
    Jim
     

Share This Page