Upgrade on Macbook Pro 13" question to Lion, Not sure whats going on!!

Discussion in 'Mac OS X Lion (10.7)' started by RADDAV, Oct 14, 2011.

  1. RADDAV macrumors newbie

    Joined:
    Oct 14, 2011
    #1
    I have just run the downloaded Lion OSX to upgrade my daughters Macbook Pro, ran okay, took about 30 mins but at the end instead of saying successfully installed it asked to close down running applications and then restart.

    When I restart it takes me to Mac OSX Utilities instead of booting into the operating system as it did on my iMac when I upgraded that. It now wants to restore from backup, Reinstall Mac OSX, go online or use the disk utility!

    Which one do I choose and why didn't it just upgrade and reboot into the lion osx?

    I don't want to loose all my daughters data, have I done something wrong????

    Thanks
     
  2. Samuriajackon macrumors 6502

    Samuriajackon

    Joined:
    Feb 9, 2009
    #2
    I don't remember it asking me for anything like that, did you buy the LION usb disk from the store or did you purchase it digitally on the APP STORE?
     
  3. RADDAV thread starter macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    It's the download version, worked fine when I did the process on my iMac version I downloaded.

    I need to make sure I can get in to ensure I don't lose her data, my fault for not backing up before I started, never dreamt after it went so smoothly on the iMac it would be a problem. Can I use the disk utility to repair the Macintosh HD or has it started changing the installation?

    Or do I use the reinstall option, but this wanted to connect to the internet and the key chain wanted a password that wasn't the admin one or the wifi one, so I don't know what it wants there!!

    Will the reinstall keep the data and files and just update the main operating system?

    Thanks
     
  4. RADDAV thread starter macrumors newbie

    Joined:
    Oct 14, 2011
    #4
    Well, I managed to reboot into the original snow leopard partition and everything is as before I ran the Lion OSX upgrade .dmg.

    Confused why it didn't upgrade as it did on my iMac! It seemed to install then when it rebooted went into a clean install I think instead of upgrading Snow Leopard 10.6.8.

    Any ideas why it didn't upgrade, it took 30 minutes approx. before it wanted to reboot. The only thing it didn't do like the iMac was say installation completed successfully, said needs to close some running apps before it can reboot!!

    Thanks
     

Share This Page