upgraded 2009 mac pro to 2 x 3.46ghz xeon. but memory is not recognized on slot B

Discussion in 'Mac Pro' started by eric79won, Aug 22, 2015.

  1. eric79won macrumors newbie

    Joined:
    Dec 21, 2013
    #1
    Hello. I just upgraded my 2009 mac pro 2x 2.26 ghz to 2x 3.46 ghz.

    My memory is 6 x 8Gb = 48gb.

    But, after I upgraded my cpu, slot B memory is not recognize my memory.

    So, only slot A 3x8gb=24gb is being recognized.

    I did SMC reset / PRam reset.

    And, I tried reinstall CPU.

    Please help how can I make my mac pro recognized all my memory.

    Thank you in advance.
     
  2. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #2
    Try switching the CPUs from socket to socket. See if the problem follows the CPU. I can tell you my experiences on my 5,1. One of the CPUs would not recognize slot 2. I swapped the RAM from slot to to slot, and Slot 2 was still not being recognized. When I swapped CPUs the problem followed the CPU. I exchanged CPUs and that fixed the issue.

    Lou
     
  3. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #3
    RAM not showing up is classic sign of not having screws tightened correctly. Be careful.
     
  4. Bubalight macrumors newbie

    Joined:
    Apr 22, 2015
    #4
    Dirty pin contacts can cause memory issues, although more commonly this is limited to just 1 channel and not all 3. Depending on where you bought your CPUs from, if they were old server pulls, as most are, there may have been some thermal paste and or finger prints on the gold contact pads on the bottom. Use rubbing alcohol on a piece of paper towel to thoroughly clean before you try again.
     
  5. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #5
    I agree with all that has been said here and just wanted to add that you may want to check the CPU socket. At one point, my Mac Pro was unable to detect RAM in one bank and it turned out to be one pin on the socket that was bent ever so slightly.

    What made diagnosing even more difficult was that 2GB sticks of RAM (with all the chips only on one side of the DIMM) worked fine while 8GB sticks (with chips on both sides of the DIMM) did not. It took me about an hour of checking with a magnifying glass to find what was wrong. I carefully bent the pin back in to place and it has been working perfectly.
     

Share This Page