Upgraded to Yosemite, now Mac can't open or update iPhoto or iMovie :(

Discussion in 'OS X Yosemite (10.10)' started by Burnsey, Oct 19, 2014.

  1. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #1
    When I go to the store to update, I get the error: "This update is not available for this Apple ID either because it was bought by a different user or the item was refunded or cancelled."

    These programs came installed on my machine when I bought it (MBP 13 inch Retina 2013). I don't know what else I can do?

    Anyone else with this problem?
     
  2. BasicGreatGuy, Oct 19, 2014
    Last edited: Oct 19, 2014

    BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    Are you positive you are signed into the same account on the Canada store, as you were when you purchased your Mac?
     
  3. Jacooch macrumors member

    Jacooch

    Joined:
    Oct 23, 2011
    #3
    I am having the same issue with Server. Under purchases it shows I have never purchased the app, but alas, I have. Reported to Apple, waiting to hear back from them on what the fix ix for the issue. Must be a known issue as I hear it has been escalated t engineering.
     
  4. Burnsey thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #4
    I have never signed into Apple on the App store on this MBP prior to just recently when I purchased my iPhone 6. I attempted to sign in once with an older account but didn't remember the password and left it.
     
  5. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #5
    Download of the update seemed to go OK on my Mac, but now a day later, launchpad went into sparkly icon/progress bar mode on iMovie. When it finished, the new version opened just fine.
    Probably some funny server load attenuation scheme on Apple's part that we are not supposed to notice.
     
  6. Burnsey thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #6
    So no one knows a solution to this issue? Am I doomed to be without iPhoto and iMovie going forward? Had I known I would have never upgraded to Yosemite :(
     
  7. acuad12 macrumors newbie

    Joined:
    Oct 20, 2014
    #7
    Solution to grey apple id box


    I called apple support since I had this same exact problem after upgrading. http://www.apple.com/support/

    My problem was that I have a MACBOOK PRO that i had bought used from someone else and they had iPhoto included on the Mac. When updates came out I could never update it since the previous owner owned it and when I tried to update it a box popped up and said to sign-in with a GREY APPLE ID BOX pre-filled with the previous owners id (email.) I don't know his password or have contact with him. I updated to Yosemite and to be up to date with the software iPhoto NEEDED to be updated (iPhoto app had a circle with a line through it.) I called apple support and they told me I needed to purchase it through my apple id in order to get access back to the application and to my hundreds of photos.


    1. Go to finder on the top right and type in "applications" and enter.

    2. Look for the iPhoto application logo.

    3. Click and drag the logo to the trash in on the bottom right on your mac. (Don't worry your files/photos won't be deleted we are just replacing the application.)

    4. Now empty your trash by clicking on to the "trash bin" icon and on the top right you will see "empty" click that.

    5. go to the app store and sign out from your account. (go to the top left and click on "store" and click sign-out) of course if you not signed in the first place you're fine.

    6. Close the app store window.

    7. Reopen window and type in on the top right search box: "iPhoto" and enter.

    8. You will see the application and it should say "free" or some price. (for me it was free) once you click on that it says install and click that and then it says sign-in.

    9. Put your apple id and password. (if it says its free you won't be paying but if it says a price you will be charged) just to let you know.

    10. The application will start to download and you will be able to track its process in the "launchpad" (the app that is a rocketship.)

    11. The download takes 5-10 minutes.

    12. Click on the iPhoto app and you will see that it will load up. A box will pop up saying that it will need to be upgraded. Click on the button that says "upgrade."

    13. It should load up in less than 5 minutes depending on how many photos you have in your library.

    14. You will be ready to go! You might see that the icon for iPhoto has a circle and line through it but that is fine. Just exit out of iPhoto and click on it again. The icon should be replaced with the new look icon for iPhoto.

    15. Repeat this process with another application you may have that is owned by someone else and you don't know their password.
     
  8. joecool99, Oct 30, 2014
    Last edited: Oct 30, 2014

    joecool99 Suspended

    joecool99

    Joined:
    Aug 20, 2008
    Location:
    USA
    #8
    thanks, i was able to fix iPhoto this way. i have complete iLife '11 and iWork '09 installed - showing 5 pending updates: iPhoto, iMovie and 3 iWork.

    iphoto resolved with the steps above. and i was able to reinstall it for FREE.
    however iMovie and 3 from iWork still show pending update i cannot do since this issue, and repeating the technique above would work, but i would have to PAY!
    only iPhoto was FREE for some reason.

    i wonder why?
    why are the other apps forcing me to pay? i have legit install from discs.
     
  9. chris.L91 macrumors newbie

    Joined:
    Nov 13, 2014
    #9
    iPhoto stuck on installing

    since done the yoshemite update. i had to update the iPhoto app. clicked install. everything fine. but it is still saying installing after 3 hours and no change. and still can't open the app.
     
  10. alwaysireland macrumors newbie

    Joined:
    Aug 5, 2013
    #10
    Can update after accepting apps!

    I just purchased a refurbished iMac, 3.2 i5, 8 gb 1600, and immediately updated to Yosemite. I thought I was doomed because nothing seemed to be working and everything needed to be updated and wouldn't work.

    I happened to click on the "Purchases" tab where it stated I had to "accept" six applications.

    After accepting the applications and putting in my apple id that was used to purchase the machine, for all six apps, it finally allowed me to update everything.

    Perhaps it will be that easy for some of you. Good luck.
     
  11. rbmiddleton macrumors newbie

    Joined:
    Nov 15, 2014
  12. Swolepd macrumors newbie

    Joined:
    Dec 21, 2014
    #12
    Awesome!!!

    Thank you for posting this. I have worried about this problem for awhile now and have had no luck finding a solution until you came along..........:)
     
  13. jetvw5 macrumors newbie

    Joined:
    Oct 31, 2013
    #13
    i love you, been googling this for hours man :dddddd
     
  14. sparkle:) macrumors newbie

    Joined:
    Jan 11, 2015
    #14
    I found out a new solution;
    1. Go to the app store
    2. Search iMovie
    3. Click on it
    4. There should be a button that says accept on where to buy it, and click it
    5. It should say to enter your Apple ID password, and enter it
    6. Now go to updates
    7. Find iMovie, and press update
    8. Then go to purchases and check to see if it is updating
    9. Wait for it to update and you should have it all up to date!
     
  15. dddear macrumors newbie

    Joined:
    Apr 9, 2015
    #15
    iphoto has a circle with line through it

    Hi all, this is my first time ever posting but I have an issue with my Macbook Pro. I just updated to Yosemite and when I tried to open iPhoto, it says to download the latest version, but when I go to the App store, it says the item I requested is currently not available in Canada. Help!! Have I lost all of my photos??
     
  16. Claudinho Andre macrumors newbie

    Joined:
    Apr 11, 2015
    #16
    It worked for me with a little change

    This solution worked perfectly for me with a little difference: I deleted iPhoto App, then entered the AppStore and went to purchased items. I Clicked on Install and done! Now I have iPhoto back and fully functional in an iMac mid 2011 with Yosemite installed over Mavericks, hehehe!!
     
  17. dddear macrumors newbie

    Joined:
    Apr 9, 2015
    #17
    Thank you, I am hesitant to delete the app though. I won't lose my 9000 photos if i put iPhoto in the trash?
     
  18. dyt1983, Apr 12, 2015
    Last edited: Jun 2, 2015

    dyt1983 macrumors 65816

    Joined:
    May 6, 2014
    Location:
    USA USA USA
    #18
    edit: To remove personally identifying information not relevant to the thread.
     
  19. Claudinho Andre macrumors newbie

    Joined:
    Apr 11, 2015
    #19
    You won't. Just take care to delete the App in Applications Folder, not the same icon in any other directory because in that case you are not deleting the app but one of your libraries. The icon is the same but you have to do this procedure in your Applications Folder. Just that and rock!
     
  20. dhowl macrumors newbie

    Joined:
    Apr 16, 2015
    #20
    No Iphoto in App store

    Hello Claudinho Andre
    I followed the instructions and deleted my trash bin containing my iPhoto, but when I searched the app store there wasn't an iPhoto app to download. Have I lost all my photos?
    I have to also find out how to transfer my Aperture photos because I can't open that app either.
    Any help would be greatly appreciated.
     
  21. Claudinho Andre macrumors newbie

    Joined:
    Apr 11, 2015
    #21

    No, your photos are not lost. They are in your Mac and I'll show you how to get them back. But before I have to explain that you won't find iPhoto for download in the searching tool of AppStore. If you purchased iPhoto formerly you will find it in Purchased Items. If not, of course you lost the App, but it's not important if you cannot have a compatible version for Yosemite. Now, the instructions for having back your photos:

    1.- Go to any of your libraries wherever you have a one in the Mac.

    2.- Right click over the icon and choose "Content Package" or "Show Content Package" that it's the first option bellow "Open With"

    3.- Find a Folder called "Masters" and enter in... Guess what? Hehehee!! All yor photos organized in subfolders by date and numbers.

    4.- Follow this procedure for all your libraries no matter where directory they were in.

    I hope this will be helpful for you! Tell me when you are done!

    Cheers!
     
  22. Emmakhosrovani macrumors newbie

    Joined:
    Apr 25, 2015
    #22
    Help

    I've followed the original instructions about putting iPhoto from applications in the trash and now iphoto is not available on the app store. how do i rebuy?

    on your comments above where you say 'go to any of your libraries where you have one..'
    how do i do this?
    do i have any libraries and where would i find them?

    any help appreciated!!

    ----------

    found the master photos in the library now!

    but how do i rebuy iPhoto?
     
  23. Claudinho Andre macrumors newbie

    Joined:
    Apr 11, 2015
    #23
    If you did never buy iPhoto you won't be able to retrieve the product. In that case you have to use someone else account for re-downloading. On the other hand, if you bought iPhoto in the past, you will find it in "purchased" items from your account. Personally I don't do by loggin in the AppStore; I enter in my account from iTunes, its the same thing.

    You just have to select "purchased" and voi là!

    Tell me if you get it!
     
  24. VanTvyl macrumors newbie

    Joined:
    Apr 27, 2015
    #24
    now what?!

    Ok so there are 14 apps that come up when I type iphoto into the search...which one is the correct replacement?

    ----------

    Ok so there are 14 apps that come up when I type iphoto into the search...which one is the correct replacement? And Claudinho what do you mean go into the libraries wherever there are any....? To what are you referring?
     
  25. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #25
    Is there an iPhoto showing up in your Purchased list in the Mac App Store? Post a picture of what you are seeing.
     

Share This Page